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Preface
For details, see the following topics:

• About this documentation

• Notation conventions

• Aurea global support

About this documentation
This guide is par t of the documentation set for Aurea CRM.

Notation conventions
This document uses the following notation conventions:

MeaningConvention

Fixed-width font indicates code, path names, file names, envi-
ronment variable names, parameter names, command names,
machine names, URLs.

Fixed-width

Bold Fixed-width  font is used to indicate user input or to
emphasize cer tain lines of code.

Bold Fixed-
width

Italic Fixed-width font indicates a placeholder for which you
must supply a value.

Italic Fixed-width

Bold sans serif typeface indicates the names of graphic user
interface elements such as dialog boxes, buttons, and fields.

Bold Sans serif

In text, italic serif typeface indicates the first use of an impor-
tant term. The term is defined in the glossary.

Italic serif

Underlined text in command lines and parameter descriptions
indicate that you only have to enter the underlined part of the
command or parameter name. For example, if you use
the-LOGFILE parameter in a command, you only need to enter
-LOGF.

Underlined

Brackets enclose optional arguments.[ ]

Braces enclose two or more items. You can specify only one
of the enclosed items. Vertical bars represent OR separators.
For example, you can specify a or b or c.

{ a | b | c }
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MeaningConvention

Three consecutive periods indicate that you can repeat the
immediately previous item. In code examples, they can be
horizontal or ver tical to indicate omissions.

...

An angle bracket between two menu items indicates that you
should choose an item from a menu. For example, the notation
File >  > Exit means: "Open the File menu and choose Exit."

Menu > Choice

Links to related information in other chapters or documents are
indicated using the >> symbol.

>>

Aurea global support
If you encounter a problem while using an Aurea product or require assistance with
downloading the software or upgrading a product release, please open a ticket on
Aurea Support Central. Preferably, search the ar ticles on the Aurea Knowledge
Base for solutions to your issues before opening a ticket.

Information about the support organization is available on Support Central. The
product documentation is available athttps://help.aurea.com/crm/#.

For information about purchasing an upgrade or professional services, contact your
account executive. If you do not know who your account executive is, or for other
queries, contact us through our website.
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1
Introduction
This manual is intended for Aurea CRM win administrators.

This manual covers the following:

• Configuration of Aurea CRM win, see Configuration Module on page 14.

• Importing and exporting data for external systems, see  Import/Export on page
17.

• Communication between stations to synchronize data (main office, branch offices,
laptops etc.), see Communication on page 84.

• Customizing the Aurea CRM win user interface, see  User Interface on page 168.

• Analyzing data in Aurea CRM win, see Analysis Module on page 313

Additional information is provided in the following manuals:

• For details on installing Aurea CRM win, refer to the Aurea CRM win Installation
Guide.

• The administration and configuration of Aurea CRM core functions (access rights,
data model etc.) are described in the CRM.core Administrator Guide.

• For more information on the user interface and basic functions in Aurea CRM win,
refer to the Aurea CRM win User Manual.

• For information on the Aurea CRM Business Logic, refer to the Business Logic
Manual for your ver tical.

• For details on the meaning and functionality of individual database fields, refer
to the field help.

Information on the structure of the Aurea CRM database (tables, fields, indices etc.)
can be found in the Data Model (in the Aurea CRM win Maintenance module). You
can also output the database structure as text or XML files (see mmba.exe Param-
eters in the Aurea CRM.core Administrator Guide).

All available documentation can be found on the Aurea CRM support page at
https://support.aurea.com.

If not mentioned otherwise, all examples in this manual apply to the BTB vertical.

Directory structure
The directory structure is required to star t the individual modules.

Do not change the directory structure added during the installation.
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When adding a new user, a directory with the same name as the user name is added
automatically. The \SU directory is the supervisor's directory and is automatically
created during installation.

In both stand-alone and network installations, each user is assigned a personal
user directory. User settings, selections, mail-merge documents etc. are stored in
this directory, see \<user name> on page 11.

Access Rights
When a user star ts a module, the system creates temporary files that are deleted
when the module is closed.

You should therefore ensure that users have the privileges necessary to read, write
and delete files in their sub-directories.

The following rights are required:

Administrator RightsUser RightsData Directory

Write, Erase, CreateWrite, Erase, Create\<user name>\ db
\<user name>\ frm
\<user name>

Write, Create, Read, Modi-
fy, Erase

Write, Create, Read, Modi-
fy

\system\ db

Administrator RightsUser RightsProgram Directory

ExecuteExecute\system\exe

Write, Create, Read, EraseWrite, Create, Read\system\ frm

Write, Create, ReadRead\system\sys

\system
Learn about the \system directory structure.

The \system\com\system\di

and

\system\ frm

directories are required by Aurea CRM win in order to operate.
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\system\exe

This directory contains:

• the program and library files, see Aurea CRM win Modules on page 12

• the online help

• the program icons (*. ico)

• the win_Patch_History.txt file

\system\db

This directory contains:

• log files, see Logs and Error Messages in the CRM.core Administrator Guide.

• files containing information on the data structure and user interface, see mmba.exe
Parameters in the CRM.core Administrator Guide

• the file mmsms.ini, used to send SMS as part of activities, see mmsms.ini File
in the User Manual.

\system\sys

This directory contains the system settings:

• dokupfad.asc: global document directory, see Directories in the User Manual

• mm.ini: more system settings, see mm.ini File

\system\xml

This directory contains the graphics, XML and XSLT files used by reports and the
print and XML views of formats.

• ..\calendars: XML file containing holidays, see Defining Calendar Settings in
the CRM.core Administrator Guide

• ..\images: Icon files and style sheets for XML reports and XML views of formats,
see Reports and Formats in the CRM.Win User Manual.

\<user name>
Whenever a new user is added, a corresponding directory with the same name as
the user name is created.

This directory contains user-specific settings stored in the following files:

• pro *. cfg: Current UI settings (masks, lists, calendar, search results) for each
module, see Module Numbers in the CRM.core Administrator Guide. Delete a
user's pro*. cfg files to reset the user's settings.

• dokupfad.asc: User-specific document directory

• dokusys.asc: User-specific settings relating to the word processor and
spreadsheet in use
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• *mtmp.doc: Control files used to transfer data to the word processor, see Word
Processor in the User Manual

• mm.cfg: User-specific settings configured by selecting Extras > Other Options.

• mm.ini: User-specific system settings required before Aurea CRM is star ted,
see mm.ini file.

• gm.ini: Mask generator settings, see Mask Generator on page 169

\<user name>\frm

This directory contains log files (merge<Link to Info Area>.txt), created if
an error occurs when merging companies/persons, see Managing Companies and
Persons in the User Manual.

Aurea CRM win Modules
This topic has a list of CRM win modules.

DescriptionexeStart Menu

The Aurea CRM win main module: Customer
data is added and managed in the main
module, see User Manual.

mmba

The Print module, see User Manual.mmpr

Use the Maintenance module to administer
the database. You can add and update cata-
log values, info areas and fields, update or
delete large numbers of records etc.,
see Maintenance Module in the CRM.core
Administrator Guide.

mmri -w

Use the Import module to import data into
Aurea CRM from other systems, see Im-
port/Export on page 17.

mmim

Use the Export module to export data for
use in other systems in a variety of formats,
see Import/Export on page 17.

mmim -e
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DescriptionexeStart Menu

Use the Communication module to transfer
data between the main office and other sta-
tions (e.g. notebooks), see Communication
on page 84.

mmco

Use the Rebuild module to restore damaged
database tables, see Rebuild Module in the
CRM.core Administrator Guide.

mmba -r

Use the Rights module to define Aurea CRM
access rights, see Rights Module in the
CRM.core Administrator Guide.

mmri

Use the Configuration module to display li-
cense information and to configure user data
such as the name, personnel number, initial
password, module access rights etc.,
see Configuration Module on page 14.

mmcfg

Use the Analysis to display marketing and
sales-relevant information clearly, in either
tabular or graphical form, see Analysis
Module on page 313.

mman

Starting Modules
Learn how to star t modules.

You can star t the Aurea CRM win modules in different ways:

• From the Start menu

• From other Aurea CRM win modules by selecting Window > Modules from the
menu

• From the command line,  Aurea CRM Commands and Parameters on page 343

Note:  Users can only access modules if they have the necessary access rights,
see Module Access Rights, System Locks and Process Tracking in the CRM.core
Administrator Guide.
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Configuration Module
Learn to manage users and allocate station number.

Use the Configuration module to:

• Allocate a station number, see  Aurea CRM win Installation Guide.

• Add users (user names and passwords), see Adding, Editing and Deleting Users.

• Edit users' password settings and module access rights, see Password Settings
and Module Access Rights, System Locks and Process Tracking in the CRM.core
Administrator Guide.

Adding, Editing and Deleting Users

Aurea recommends adding your company's employees in the Rep info area,
see Defining Reps in the CRM.core Administrator Guide. Select Configure Login
from the context menu in the Rep info area to set their Aurea CRM user name and
password, see Configuring Logins in the CRM.core Administrator Guide.

To add a user (login) without adding a rep:

1. Start the Configuration module, see Star ting Modules on page 13.

2. Click the New button.

The New update.CRM  User dialog box is displayed.
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3. Enter the user name to be used to log on to Aurea CRM in the Name field.

The name is limited to a maximum of eight characters and may not contain spaces
or special characters.

4. Enter a login password for the user in the Password field.

As administrator, you can assign passwords to each user. The maximum password
length is 128 characters. For details on configuring password options and security,
see Password Security in the CRM.core Administrator Guide.

Only the SU can change the SU password.

5. Click OK.

The user you added is displayed in the user list. A user directory with the same
name (including the necessary sub-directories) is created.

6. Make any additional settings, see Password Settings and Module Access Rights,
System Locks and Process Tracking in the CRM.core Administrator Guide.

Note:  Users (apart from the SU) added in the Configuration module can only
star t the Rebuild module.

7. Click OK to close the Configuration module.

To change existing user information:

1. Start the Configuration module.

2. Select the user you wish to edit from the list of Users.

3. Click Modify.

4. Make any desired changes.

5. Click OK.

6. Edit any additional settings, see Password Settings and Module Access Rights,
System Locks and Process Tracking in the CRM.core Administrator Guide.

7. Click OK to close the Configuration module.

To delete a user:

1. Start the Configuration module.

2. Select the user you wish to delete from the list of Users.

3. Click Delete.

4. Click OK.

5. Click OK to close the Configuration module.

Note: When you delete a user from the user list, the user is only removed from the
user list. The user directory is not deleted. You can thus reuse existing user-specific
settings for other users.
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Creating the Program Group

If you did not carry out the installation procedure locally, you need to provide the
user with corresponding icons and shortcuts on their local computer:

1. Start the Aurea CRM win main module on the user's local computer.

2. Log on with the user's name and password.

3. Select Help > Create Program Group.

The system adds the Aurea CRM win program group to the star t menu with links
to all modules that the current user has been granted access to.
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2
Import/Export
Use the Import and Export modules to exchange data between Aurea CRM and
external systems (databases, spreadsheets, etc.).

You can export Aurea CRM data to external files or to external databases directly.
The supported databases are Oracle and MSSQL. Exporting and Importing in gen-
eral follow the following steps.

1. Create an import or export format, see Defining an Import/Export format on page
19.

Note:  If you are importing data, you also need to verify that you have met all the
import requirements (see Import and Export Requirements on page 17) and define
your match-up settings (see Match-up on page 58). You require read access to
the data you wish to export.

2. Execute the import or export, see Executing the Import on page 79 and Executing
the Export on page 81.

You can also execute imports and exports from the command line.

Imports can also be carried out in Aurea CRM web and via a CRM.server to-do or
job, see Import in the Aurea CRM web Administrator Guide and CRM.server in the
CRM.core Administrator Guide.

Exporting all catalog values using the export module only exports variable catalog
values but not the fixed catalog values. Fixed catalog values are part of the data
model and are stored in the database as binary data and cannot be retrieved directly.

To export fixed catalog values, see Exporting Fixed Catalog Values on page 57.

Import and Export Requirements
Learn about importing and exporting to external database.

User Rights

All restrictions defined for a rep in the rights format also apply during the import or
export of data, see Rights and Import/Export in the CRM.core Administrator Guide.
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Import File/Import Database

The import file needs to meet the following requirements:

• The file must be stored in a supported format, see File Format on page 36.

• The lengths of the individual import fields can be fixed or variable.

If you are using fixed field lengths, you need to define the exact length of each
field in the import format in Aurea CRM.

If the field lengths are variable, you need to specify the separator character in
the import format (e.g. comma, semicolon) or delimiters (e.g. all field contents in
quotation marks).

• Records of variable length must be distinguished using a separator (e.g. line
break). For records of fixed length a separator between records is optional.

• If a field is empty, a field separator must be included (in this case a semicolon).
Example: Smith & Co;;London

• The contents of fields in the import file do not need to correspond to the usual
content in Aurea CRM. Text data can be transformed during the import process.

• If the import file contains fields whose content are not required in Aurea CRM,
you can suppress these fields in Aurea CRM by replacing the contents with
placeholders during the import process.

• Aurea advises against importing more than 300 fields at once.

• Imported records can only be added if data is available for all mandatory fields
defined in the data model; e.g. the Currency field in the Offer info area.

• Additional mandatory fields can be defined for individual reps in their access
rights. These mandatory fields are also tested for content during the import
process.

• You can define default values that are used if mandatory fields are empty.

• To match up (and merge) imported data with existing data in Aurea CRM, the
import file must contain unique key fields used to compare internal and external
records, see Match-up Logic for other Info Areas on page 65. This is not always
necessary for the Company, Person, Person in Company and Property info
areas, see Company Match-up on page 59, Person Match-up on page 61 and
Property Match-up (BTB only) on page 63.

The import database (external database) must meet the following conditions:

• The external database and Aurea CRM database must be of the same database
type (MS SQL or Oracle).

• For Oracle databases, the same character set (NLS_CHARACTERSET) must be
used as in the Aurea CRM database. The character set used by the Aurea CRM
database is specified in the mmdb.ini file using MM_NLS_CHARSET.

• MS SQL databases can use a different character set from the Aurea CRM
database. In this case, enable the Perform translation for character data option
in the ODBC connection. Aurea recommends that you exhaustively test the
transformations applied to the character data.
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Export to External Database

Before exporting to an external database, ensure that the following conditions are
satisfied:

• The external database and Aurea CRM database must be of the same database
type (MS SQL or Oracle).

• For Oracle databases, the same character set (NLS_CHARACTERSET) must be
used as in the Aurea CRM database. The character set used by the Aurea CRM
database is specified in the mmdb.ini file using MM_NLS_CHARSET.

• MS SQL databases can use a different character set from the Aurea CRM
database. In this case, enable the Perform translation for character data option
in the ODBC connection.

Note:  Aurea recommends that you exhaustively test the transformations applied
to the character data.

Import and Territory Management (BTB)

For information on the behavior of the City, Allocation and Sales Territory Man-
agement info areas, see Territory Management in the BTB Business Logic Manual.

Defining an Import/Export format
You need to define a format for the specific data you want to import or export.

The formats can be defined for importing from or exporting to files and databases.
The required format is defined in the corresponding module, see Defining an Import
Format for an External File on page 19, Defining an Import Format for an External
Database on page 21 and Defining an Export Format to an External File on page
26.

Note:  A format defined for an external file can be used in the Import and Export
modules, irrespective of where it is defined. A format defined for exporting to an
external database can only be used for exporting to that database. Similarly, A
format defined to import from an external database can only be used for importing
from that database.

Defining an Import Format for an External File
Before you can import data, you need to replicate the structure of the import file in
Aurea CRM as an import format.

To define an import format for an external file:

1. Start the Import module, see Star ting Modules on page 13.
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2. Select File Name from the context menu or double-click on the File Name
drop-down list field.

Note: You can use the variables $ InstallDir and $ UserDir to refer to Aurea
CRM's installation directory and user directory. If you do not enter a path, the file
is searched for under \system\db.For information on the import file's
requirements, see Import File/Import Database.

3. Select File Format from the context menu to determine the import settings
(separators, log files etc.), see File Format on page 36.

4. Select the import fields, see Selecting Fields on page 40.

The selected fields are listed in the Field Name column.

5. If you are using fixed field lengths, you need to enter the length of the external
fields in the import format, see Changing the Field Length on page 43.

6. If you wish to transform the contents of fields during the import process, define
the transformations, see Transforming Field Contents on page 43.

7. Select Info Area Properties and Field Properties from the context menu to
determine how data is imported into Aurea CRM, see Info area properties on page
47 and Field Properties on page 51.

8. You can define conditions that records need to meet to be imported, see Defining
Import/Export Conditions on Records on page 50. You can determine match-up
conditions that have to be met by records in Aurea CRM to match up records,
see Match-up Conditions on page 50.

9. Define or verify your match-up settings, see Match-up on page 58.

10.Select Test Imp/ Exp from the context menu to test the allocation of external
fields to Aurea CRM fields and the results of transformations and case conversions
(upper/lower), see Testing the Import on page 56. Import conditions, field links
and match-up options are not tested.
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11.To send an e-mail containing a status report or error message during/after the
import process, select one or more of the following options:

• E-mail Admin.: E-mails are sent to the selected rep (provided an e-mail address
is entered in either the E-mail 1 or E-mail 2 fields in the corresponding rep
record). If you do not select a rep, the e-mails are sent to the current rep.

• E-mail (Start): An e-mail is sent when the import beings.

• E-mail (Status in Min.): Enter the interval (in minutes) in which e-mails should
be sent containing status reports.

• E-mail (OK): An e-mail is sent when the import is successfully completed.

• E-mail (Error): An e-mail containing the error number is sent if an error occurs,
see Import/Export Error Codes in the CRM.core Administrator Guide.

12.Click  (Save), see Saving, Loading and Deleting Formats in the Aurea CRM win
User Manual.

Note:  Click on  (Load) to load an existing format for editing. Click on  (Delete)
to clear the current settings in the mask.

Defining an Import Format for an External Database
Learn to Define an Import Format for an External Database.

To define an import format for an external database:

1. Start the Import module, see Star ting Modules on page 13.
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2. Enable the Import table check box.

3. Enter the database connection settings in the following fields:

• DB connection: Database connection (e.g. ODBC or Oracle)

• DB user and DB password: Login details for the database

• DB name: Name of the database

Note: This option has no function for Oracle databases.

Note:  If you do not enter any details, the current Aurea CRM database is used.

4. MS SQL only: Alternatively, you can specify the database connection in the
Connection string field. Use the following syntax:
Driver=SQL Server;Server=mmdb;Database=UPDATE7;UID=mm;PWD=MM;

or
Driver=SQL Server;Server=mmdb;Database=UPDATE7;Trusted_Connection=Yes;

Any installed ODBC driver can be specified as the driver, e.g. Driver=SQL Server

Native Client 11.0.

Note:  If Connection string is undefined, the values in DB connection, DB user,
DB password and DB name are used.

22AUREA CONFIDENTIAL

Chapter 2: Import/Export



5. Enter the name of the table in the DB table field (max. 64 characters).

Note: MS SQL: If the DB connection or DB name fields are left empty, enter
the table using the following syntax:
[database].[schema].table

Oracle: Enter the name of the table in upper case.For information on the external
database's requirements, see Import File/Import Database.

When you leave the field (using either Enter or Tab), Aurea CRM verifies that it
can access the external database.

6. Other optional settings:

• Sort by index: Select a unique index for the selected table.

Note:  If you do not select an index, the first unique index in the table is used.If
no unique indices exist, error codes cannot be output.

• Error code column: Column in the database to which error codes are written.

Note:  Aurea recommends using a column of the type "int nullable" to store
error codes. You can also use columns of the type string (char, nchar), with a
minimum length of 32 characters and a recommended length of 64 characters.
No other data types are supported.

Existing error codes are not deleted following a successful import.

For more information on error codes, see General Error Codes and Import/Export
Error Codes in the CRM.core  Administrator Guide.

• SQL Where clause: Enter the SQL code (the portion of the statement following
"WHERE") to restrict the imported data using a condition. You can also use the
command line parameter -- sqlwhere.

Note:  External tables are imported with packet size = 32 by default. To change
the import packet size, add a comment after the WHERE clause: /*packet-
Size=500*/ changes the packet size to 500, /*packetSize=-1*/ imports all data
with one statement.

The maximum packet size is 1000. If there is not enough memory for this value,
half of the requested value is used.

• Only import rows without error codes: Only applies to tables with a unique
index. Rows that could not previously be imported and therefore contain an
entry in the error code column are not imported.
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Depending on the error code column's data type, an error code corresponds to
the following:

• type INT NULL (numeric): If the import is successful, the NULL value is
replaced by 0 (zero). Only records with a value of NULL in the error code
column are interpreted as being without errors and imported.

• type INT NOT NULL (numeric): Only records with error code 0 are interpreted
as being without errors and imported.

• type NCHAR NULL (string): If the import is successful, the NULL value is
replaced by 0 (zero). Only records with a value of NULL, space character or
empty in the error code column are interpreted as being without errors and
imported.

• Remove successfully imported rows: Only applies to tables with a unique
index. Successfully imported rows are deleted in the external database.

If the error code column is not empty before, the successfully imported rows
are not deleted. To also delete successfully imported rows with an error code
you can override this behavior with the Delete error code column beforehand
option.

• Clear field contents if DB value is NULL: If a database value NULL is
imported, the field becomes empty.

• Clear field contents if DB value is 'null': If a database string value 'null' is
imported, the field becomes empty.

• Ignore NULL values in DB: The database value NULL is ignored during import,
the field remains unchanged.

• Ignore 'null' strings in DB: The database string value 'null' is ignored during
import, the field remains unchanged.

• Ignore empty DB values: The empty value is ignored during import, the field
remains unchanged.

7. Select File Format from the context menu to define fur ther settings, see File
Format on page 36.

Note: The settings entered in the Character Set, Field Length, Separator and
Log Files sections are ignored when importing data from an external database.

8. Select the import fields, see Selecting Fields on page 40.

The selected fields are listed in the Field Name column.

9. Click in the Table Column column to select the fields you wish to import from the
external database.
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10.You can adapt the length of fields in the import format to the length in the external
database, see Changing the Field Length on page 43.

11.If you wish to transform field contents when importing, define the transformations,
see Transforming Field Contents on page 43.

12.Select Info area properties and Field Properties from the context menu to
configure the impact of the import on data in Aurea CRM, see Info area properties
on page 47 and Field Properties on page 51.

Note: The log settings defined in the info area properties (Log columns) are
ignored when importing from an external database. No logs are created.

13.You can define conditions that need to be met by records for the records to be
imported, see Defining Import/Export Conditions on Records on page 50. You can
define match-up conditions that need to be met by the Aurea CRM records for
them to be matched up, see Match-up Conditions on page 50.

14.Define or verify the match-up settings, see Match-up on page 58.

15.Select Test from the context menu to test the mapping of external fields to internal
fields and the effect of transformations and upper/lower case, see Testing the
Import on page 56. Import conditions, links between fields and match-up options
cannot be tested using this option.

16.To send e-mail containing a status report or error message during/after the import
process, select one or more of the following options:

• E-mail Admin.: E-mails are sent to the selected rep (provided an e-mail address
is entered in either the E-mail 1 or E-mail 2 fields in the corresponding rep
record). If you do not select a rep, the e-mails are sent to the current rep.

• E-mail (Start): An e-mail is sent when the import beings.

• E-mail (Status in Min.): Enter the interval (in minutes) in which e-mails should
be sent containing status reports.

• E-mail (OK): An e-mail is sent when the import is successfully completed.

• E-mail (Error): An e-mail containing the error number is sent if an error occurs,
see Import/Export Error Codes in the CRM.core  Administrator Guide.

17.Click  (Save), see Saving, Loading and Deleting Formats in the Aurea CRM win
User Manual.

Note:  Click on  (Load) to load an existing format for editing. Click on  (Delete)
to clear the current settings in the mask.

25AUREA CONFIDENTIAL

Defining an Import/Export format

https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-6_2_6-ImportExport-Error-_crm.html
https://help.aurea.com/crm/crm-win-user-manual/crm-win-user-manual/dita/topics/c_win_UsrMan-4_11_1-Saving-Loading-and-_upd.html


Defining an Export Format to an External File
An export format defines the data and the format in which it is exported to a file.

To create an export format:

1. Start the Export module, see Star ting Modules on page 13.

2. Either enter the path and name of the output file in the File Name field or click
on the small arrow to the right of the field to select the desired file.

Note:  If you do not enter a path, the file is output to the \system\db directory.

3. Select File Format from the context menu to define the format of the output file
(separators, log file etc.), see File Format on page 36.

4. Select the fields to export, see Selecting Fields on page 40.

5. If you are using fixed field lengths, enter the corresponding field lengths in the
table, see Changing the Field Length on page 43.

6. Enter any transformation to be applied to the selected fields, see Transforming
Field Contents on page 43.

7. Enable the Selection check box to restrict the companies or persons exported
to a specific selection instead of using the entire database. Click in the Sel. Name
field to select a selection format, see Selections in the CRM.win User Manual.

Note: You can also select a property selection in the BTB version using the
Property Selection check box.

8. You can also use conditions to restrict the data exported, see Export Conditions
on page 55.

9. Select a field from the Sort By field to sor t records in the first info area selected.
By default, records are sor ted in ascending order. Enable the Descending check
box to sor t in descending order.
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10.Updates since: Use this option to log the output time and date in the export
format. The next time you use this export format to export data, the log is used
as a basis, and all data edited after the date and time entered in the Date and
Time fields is exported.

11.Enable the External Key column to export the external key instead of the contents
of the field.

Note: When exporting rep fields, the external system entered in the File Format
dialog box must correspond with the value entered in the Ext. System field in the
rep record. The External Key column is disabled for rep ID fields. The external
key can only be output for fields containing rep names (Z fields), see Aurea CRM
Field Types in the CRM.core Administrator Guide.

12.Save the export format.

Note: Special Case - FS Vertical: If you export the Activity, Support Intensity
and Consultancy Items info areas in this order, the export file contains all activity,
support intensity and advice item records. If you change the order; for example,
Support Intensity, Advice Items, Activity, then the result includes all the support
intensity and advice item records, but no activities.

Defining an Export Format for an External Database
To export data to an external database you have to define a format and specify the
data you want to export.

To export to external database, follow the below steps:

1. Start the Export module in one of the following ways:

• From the Start menu

• From other Aurea CRM win modules by selecting Window > Modules from the
menu

• From the command line, see Aurea CRM Commands and Parameters on page
343.
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2. Select the Export to DB checkbox.

3. Enter the database connection settings as described below:

Any database:

• DB connection: Database connection (e.g. ODBC or Oracle)

• DB user and DB password: Login details for the database

• DB name: Name of the database

Note: This option has no function for Oracle databases.

Connection string (MSSQL Server only):
Alternatively, you can specify the database connection in the Connection string
field. Use the following syntax:
Driver=SQL Server;Server=DBserverNAme;Database=DBname;UID=mm;PWD=MM;

or
Driver=SQL Server;Server=DBserverNAme;Database=DBname;Trusted_Connection=Yes;
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Any installed ODBC driver can be specified as the driver, e.g. Driver=SQL Server

Native Client 11.0.

Note:  If Connection string is undefined, the values in DB connection, DB user,
DB password and DB name are used.

4. Enter the name of the table in the DB table field (max. 64 characters).

Note: MS SQL: If the DB connection or DB name fields are left empty, enter
the table using the following syntax:
[database].[schema].table

Oracle: Enter the name of the table in upper case.

For information on the external database requirements, see Export to External
Database.

When you exit the field, the connection details are verified to ensure that a con-
nection can be established.

5. Provide the following optional details:

• Sort by index: Select a unique index for the specified table.

Note:  If you do not select an index, the first unique index in the table is used.
If no unique indices exist, error codes cannot be output.

• Error code column: Name of the Column created in the external database
table to which error codes are written.

Note:  Aurea recommends using a column of the type "int nullable" to store
error codes. You can also use columns of the type string (char, nchar), with a
minimum length of 32 characters and a recommended length of 64 characters.
No other data types are supported.

Error codes generated during a previous export are not deleted.

For more information on error codes, see General Error Codes and Import/Export
Error Codes in the CRM.core Administrator Guide.

• Only Export rows without error code: Select this checkbox to ensure that
rows that could not previously be exported and contain error codes in the Error
code column are ignored.
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The type of the error code column determines the error codes rendered. The
error codes for each column type and their interpretation are listed below:

• type INT NULL (numeric): If the export is successful, the NULL value is re-
placed by 0 (zero). Only records with a value of NULL in the error code column
are interpreted as being without errors and exported.

• type INT NOT NULL (numeric): Only records with error code 0 are interpreted
as being without errors and exported.

• type NCHAR NULL (string): If the export is successful, the NULL value is
replaced by 0 (zero). Only records with a value of NULL, space character or
empty in the error code column are interpreted as being without errors and
exported.

• Remove successfully exported rows: Successfully exported rows are deleted
in the internal database. This works only if the table has a unique index.

If a successfully exported row contains an error code from a previous unsuc-
cessful attempt then it is not deleted. To delete such rows select the Delete
error code column beforehand option to ensure that the error code columns
are cleared before the exported rows are considered for deletion.

• Clear field contents if DB value is NULL: If a database field with a value
NULL is exported, the field in the exported table is rendered empty.

• Clear field contents if DB value is 'null': If a database field with a string value
'null' is exported, the field in the exported table is rendered empty.

• Ignore NULL values in DB: If a database field with a value NULL is exported,
the field in the exported table is left unchanged.

• Ignore 'null' strings in DB: If a database field with a string value 'null' is
exported, the field in the exported table is left unchanged.

• Ignore empty DB values: Any field with an empty value is ignored during
export, the field in the exported database remains unchanged.

6. To configure some additional settings in the File Format window, perform the
following:

a. Select File > File Format .
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b. You can configure the following options:

• Export documents (in the Export section): Documents in document records
(Document and Customer Document info areas) are exported.

Note:  Existing documents with the same name are overwritten if you repeat
the export, and a warning is written to the log file.

• Log export results: Select this option to enable logging of the export results.

• Log Files: Log files contain records that are matched up, added, identified
as similar or rejected by the export process, Logging is enabled in the info
area properties (Log* options), see Info area properties on page 47.

Enter the path and name of the log files (e.g. C:\import\log.dat):

• Matched up: This log file contains records for which corresponding external
records are found and which are merged (or would have been merged, if
you do not have the right to update records).

• New: This log file contains all new records added by the export process.

• Similar: This log file contains those records for which similar (but not
identical) records are found in the external database. These records are
either not similar enough to be updated automatically, or more than one
similar record is found.

• False: This log file contains those records that did not meet the export
criteria (e.g. a mandatory field is missing, user access rights are
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insufficient, import conditions are not met, supplementary information
cannot be assigned to a company, etc).

Depending on the settings under Info Area Properties, the log files store
the following information:

• Information on export processes that have been completed.

• Suggestions on how Aurea CRM would export individual records.

In this case, you can use the log file as the source for a fur ther export with
other settings. To preserve the log files, perform the following:

1. Copy the log file (as it might otherwise be overwritten by a new log file).

2. Import the copied file.

7. Select the fields you want to export, perform the following steps:

a. Click  in the level header. The Select Fields dialog box displays.

b. Select an info area under Info Area.

All the fields available in the info area are displayed under Fields.

c. Double-click on a field or select it and use the  button to select the field.
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The field is displayed under Selected Fields.

• Use the  button to add all fields in the info area.

• Double-click on a field or select it and click on the  button to remove it
from the list.

• Click on  to remove all fields from the list.

d. Continue until you have selected all the desired fields and info areas.

The fields you have selected are displayed under Field Order in the order you
selected them. You can change the order, see Changing the Field Order on
page 42.

e. Click OK. The fields are loaded to the table on the Export page.
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8. To change the length of a field, click on the Length column and enter the new
value.

Note:  If the field to export is longer than the field in the external database (e.g.
Company field: 120 characters in Aurea CRM; 130 characters externally) enter
the external length nonetheless. The characters that exceed the maximum field
length are not exported.

9. To apply transformations on fields before exporting follow the steps described in
Transforming Field Contents on page 43.

10.To define the conditions that apply before a record is exported follow the steps
described in Defining Import/Export Conditions on Records on page 50.

11.To export records that have been deleted, select Data > Export Deleted Records
.

34AUREA CONFIDENTIAL

Chapter 2: Import/Export



12.To send e-mail containing a status report or error message during/after the import
process, select one or more of the following options:

• E-mail Admin.: E-mails are sent to the selected rep (provided an e-mail address
is entered in either the E-mail 1 or E-mail 2 fields in the corresponding rep
record). If you do not select a rep, the e-mails are sent to the current rep.

• E-mail (Start): An e-mail is sent when the import beings.

• E-mail (Status in Min.): Enter the interval (in minutes) in which e-mails should
be sent containing status reports.

• E-mail (OK): An e-mail is sent when the import is successfully completed.

• E-mail (Error): An e-mail containing the error number is sent if an error occurs,
see Import/Export Error Codes in the CRM.core  Administrator Guide.

13.Click  (Save). The Save dialog box displays.

Enter a name for the format and click OK. The name is displayed in the Format
field.

Note:  Click on  (Load) to load an existing format for editing. Click on  (Delete)
to clear the current settings in the mask.

For more information, see Saving, Loading and Deleting Formats in the Aurea
CRM win User Manual.
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File Format
Select File Format from the context menu or select File > File Format from the
menu to determine the general settings used by the import/export process.

Character Set (only used when importing a file)

Character set used by the external file:

• PC-8: ASCII standard under DOS

• ANSI: Windows standard. Select the character set from the drop-down list (e.g.
Unicode).

Field Length (only when importing/exporting a file)

• Variable: Field lengths in the file are variable. Fields are delimited using
separators.

• Fixed: Each file in the import file has a fixed length.

Separator (only used when importing/exporting a file)

• Record: Separator used to delimit individual records in the file. You must specify
the separator for records with variable field lengths. For records of fixed length
the separator is optional.

• Field: Separator used to delimit individual fields in the file.

• Border: Fields in the file are surrounded by characters (e.g. an apostrophe in
DBase files).

Default Separator Abbreviations in the drop-down lists: Cr (carriage return), Lf
(line feed)
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Note: You can use any character in the character set as a separator. Ensure that
the separator cannot occur within a field. Pay special attention to the Participants
field in the Activity info area.Participants are separated from one another in the
field using a semicolon. If you export the contents of this field from Aurea CRM and
then import it, do not use semicolons as separators.

Field Format

Format in the external file/database used for date, time or numeric fields:

• Date: The format used by date fields.

Aurea CRM uses the format DD/MM/YYYY. You only need to specify the format
used externally if it differs from this.

• Time: The format used by time fields.

Aurea CRM uses the format HH:MM. You only need to specify the format used
externally if it differs from this.

• Decimal sep. : The character used to separate decimal places.

If Decimal sep. is undefined, floating point numbers are imported incorrectly. If
the integer and decimal places each take up a specific number of characters, you
need to transform the data, see Transforming Field Contents on page 43.

You can also define the separator when exporting data. If you do not enter a
separator, the separator entered in the user's regional settings is used.

First Record Starts…

• Byte offset: Enter the offset of the star t of the first record. For example, if your
file includes 40 characters of header data, enter "40".

• Record number: Enter the number of the first record that should be imported.
The numbering of records star ts with 0.

Export (Export module file only)

• Control record: The Aurea CRM field names are output at the star t of the file.

• Number records: The records are numbered sequentially.

• Right-align numbers: Numbers are aligned to the right with leading spaces
(default: left).

• Formatted numbers: Numbers are output using the current user's regional
settings.

• Export documents: Documents in document records (Document and Customer
Document info areas) are exported.

• Path: export directory (containing the export file)

• Document name: <info area abbreviation>_<StaNo>_<SerNo>_<title>

• OLE documents and private documents belonging to other users are not
exported. In this case, this is written to the log file, see Logs and Error Messages
in the CRM.core Administrator Guide.
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Note:  Existing documents with the same name are overwritten if you repeat the
export, and a warning is written to the log file.

Import (Import module only)

• Log import results: If enabled, import errors are logged in the Import Results
info area (C5), see Logging the Import/Export on page 82.

Note:  Creating Import Results records may affect the performance when
importing large amounts of data.

For imports executed in Aurea CRM web the Log import results option is always
enabled.

Options

• Manual match-up: Enable this option if you want to display and match up similar
records already in the Aurea CRM database manually. You can decide whether
to add the imported data as a new record or to merge it with an existing record,
see Executing the Import on page 79.

• Prompt new catalog entry: Enable this option to be prompted when new catalog
values are encountered. If new catalog values are encountered, these are
compared to existing entries.

• The external catalog value is displayed. Enter the value that should be imported
in the Change to… field.

• If you are using Aurea CRM in a language other than the catalog base language,
you need to enter the value in the catalog base language (Catalog Base Lang.
field) as well.

• Enable the Manual control off option to disable manual control for this catalog
during the current import procedure.
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• Click on the New button to add the catalog value (provided you have the
necessary access rights).

• Click OK. A list of catalog values is displayed. Select a value to replace the
value in the import file.

• Do not add to city table: Enable this option if cities entered in imported company
records should not be added to the City info area in Aurea CRM if not yet present,
see City Info Area in the CRM.core Administrator Guide.

Ext. System

Choose the external system from the drop-down list that should be used when im-
porting reps, see Field Properties on page 51 and Defining an Export Format to an
External File on page 26 (External Key column).

Log Files (Import module only, only used when importing a file)

Log files contain records that are matched up, added, identified as similar or rejected
by the import process, see Logging the Import/Export on page 82. Logging is enabled
in the info area properties (Log* options), see Info area properties on page 47.

Enter the path and name of the log files (e.g. C:\import\log.dat):

• Matched up: This log file contains records for which corresponding internal
records are found and which are merged (or would have been merged, if you do
not have the right to update records).

• New: This log file contains all new records added by the process.

• Similar: This log file contains those records for which similar (but not identical)
records are found in Aurea CRM. These records are either not similar enough to
be updated automatically, or more than one similar record is found.

• False: This log file contains those records that did not meet the import criteria
(e.g. a mandatory field is missing, user access rights are insufficient, import
conditions are not met, supplementary information cannot be assigned to a
company etc.).

Note:  If you do not enter a path, the log files are automatically written to the
same directory as the import file. If you do not enter a file name, the name of the
import file is used, with the following file extensions: *. abg (matched up), *.
neu (new), *.sim (similar) and *. fal (false).You can also use variables to
specify directories: $ InstallDir refers to the Aurea CRM installation directory
$ UserDir refers to Aurea CRM's user directory

Depending on the settings under Info Area Properties, the log files store the follow-
ing information:

• Information on processes that have been completed.

• Suggestions on how Aurea CRM would import individual records.

In this case, you can use the log file as the source for a fur ther import with other
settings:

1. Copy the log file (as it might otherwise be overwritten by a new log file).

2. Import the copied file.
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Selecting Fields
Learn how to select fields for import and export.

To select fields for the import or export:

1. Click on the  (Fields) button in the level header.

The Select Fields dialog box is displayed.

2. Select an info area under Info Area.

All the fields available in the info area are displayed under Fields.

3. Double-click on a field or select it and use the  button to select the field.

The field is displayed under Selected Fields.

• Use the  button to add all fields in the info area.

• Double-click on a field or select it and click on the  button to remove it from
the list.

• Click on  to remove all fields from the list.

Note:  If the external file for import contains fields that you do not wish to import
into Aurea CRM, select the Special Fields entry from the Info Area list (the last
entry in the list) and add the Placeholder field. You cannot apply conditions to
placeholders.

4. Continue until you have selected all the desired fields and info areas.
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The fields you have selected are displayed under Field Order in the order you
selected them. You can change the order, see Changing the Field Order on page
42.

5. Click OK.

You can select the same field several times to write data from different fields in the
import file into one field in Aurea CRM, see Field Properties on page 51. Fields that
have been selected more than once are numbered (e.g. FI-1-Street if FI-Street is
selected twice).

Catalog (KA)

To import language-dependent catalog values (Catalog info area), you also need
to select the Language No. field, see Catalog Info Area in the CRM.core Adminis-
trator Guide. For fur ther information on catalog values' external keys, see Importing
using External Keys on page 76.

History (H0)

Records' histories are saved in a BLOB (Binary Large Object), see History in the
CRM.core Administrator Guide. You can use the following vir tual fields to output
history records in XML reports or to export data in the history: ID, Stat.No ., Date,
Time, Rep ID, Rep, Windows User Name, Windows computer name, Version,
Module, Field Number, Field Name, Old Value, New Value, Time Zone.

Note: These fields are only available for XML reports and export purposes and
otherwise have no function.

To export the history for deleted records:

1. Enable the Archive History option in the access rights, see Enabling the History
in the CRM.core Administrator Guide.

2. Define an export format with the History info area as the first info area in the list,
see Info area properties on page 47.

No history is displayed or output in reports for fields that the current user is unable
to access due to their access rights.

You cannot import data into the History info area.

Item Master (AR) - BTB/OTC only

If available, StatNo + SerNo are used for matching up item master records during
import. If these keys are not available, item master records can be matched up by
Item No.

To import links to item master records you need to import their Item No. into the
link's reference field, e.g. AR_Link. The linked item master record's primary key is
automatically entered during import (AR_StaNo plus AR_SerNo).
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Login (US)

Use the Login info area to import/export users and their module access rights. Also
include the Rep info area in the import/export, and the Group Allocation info area
as necessary. Reps are linked to users using the rep ID (Rep/Group ID in the Rep
info area and No. in the Login info area).

Note:  If you have enabled the PW must contain upper and lower case option in
the Station configuration info area, you need to include the fields Password and
Encrypted Password in the import/export format.

When importing US records, make sure the import user has access to the CRM
process 1.5.2.2.1.6. "Manage Logins" (CRM process ID 70000310), see Logins in
the CRM.core Administrator Guide.

Participants

To import par ticipants e.g. into activity (MA) records, use the following syntax:
<name>|<group>|<participation type>

Example
John Doe|Marketing|optional|Simon Seller|Sales|Required

You need to import this string into the text field Participants (MA:119).

Changing the Field Order
Learn how to change the field order.

To change the field order:

1. Click in the Pos. cell of the field you wish to reposition.

2. Enter the desired position and press Enter.

The fields are reordered.

You can also change the field order using the mouse. Click the mouse button on
the entry you wish to move, hold down the mouse button for a couple of seconds,
and drag the field to the desired position.
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Changing the Field Length
The length of the field is automatically displayed in the Length column after selecting
a field.

If you are importing data with fixed field lengths, the length of the fields in the import
format need to correspond exactly to the lengths in the import file. You can determine
that only a cer tain number of characters are exported in your export format.

To change the length of a field:

1. Click in the Length column.

2. Enter the desired length.

3. Confirm your settings with either Tab or the cursor keys.

Note:  If the external field for an import is longer than the field in Aurea CRM (e.g.
Company field: 120 characters in Aurea CRM; 130 characters externally) enter the
external length nonetheless. The characters that exceed the maximum field length
are not imported. If you wish to import all characters into Aurea CRM, you need to
import these characters into another field.

Transforming Field Contents
To edit field contents before importing/exporting the data, you can define one or
more transformations per field.

The following steps describe the transformation applied to field being imported from
an external file or database. The same steps apply when transforming fields that
are being exported to an external database. The transformations in this case is ap-
plied on the internal fields.

To define a transformation for a field:

1. Click in the Transf. cell.
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The Field Transformation dialog box opens.

2. Click on  (New).

The Transformation dialog box opens.

3. Enter the field contents in the external file under External Value.

Note: You can use wildcards (see below) using the Wildcards option.

4. Enter the value to which the field contents should be transformed in the Internal
Value field.
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Note: To include a line break in internal value, use the code "\013\010" (\013 =
CR, \010 = LF).Double-click in the Internal Value field for catalog fields to access
the catalog entries.

5. Determine the following options:

• Ignore upper/lower case: Upper and lower case are ignored in the
transformation.

• Partial text: The system also searches for and replaces substrings.

Example: The import file contains "& Co.". You wish to change this to "& Co"
(without the final period). Enable the Partial text option and transform the ex-
ternal value "& Co." to the internal value "& Co".

• Wildcards ( * ?  ): Use this option to replace values that can differ from record
to record.

Note:  Note: You can use literal character values of ‘*‘ and ‘?’ using the escape
sequences ‘\*’ and ‘\?’.

Example for *: The external file uses multiple abbreviations such as "Fr." and
"Fra" that should be transformed into "France". Enable the Wildcards option
and enter "Fr*" as the external value, and "France" as the internal value.

Example for ? : The external file contains values such "12A34", "57B75",
"32A12". You only wish to import the last 2 digits. Enable the Wildcards option
and enter "???*" as the external value, and "*" as the internal value.

Transformations with ? text the text length exactly. If you wish to apply the
transformation ?? -> ? to texts longer than two characters, you need to enable
the Partial text option.

• Regular Expression: The external value contains a regular expression that
described the pattern to be replaced. In an internal value is entered, the value
is appended to the result of the evaluation of the regular expression. For more
information on the syntax used by regular expressions, see Regular Expressions
Syntax in the CRM.core Administrator Guide. An example can be found under
Regular Expressions in Transformations on page 46.

• Use for Import/Export: The regular expression is used when importing and
exporting. If the check box is disabled, the line is ignored.

6. Enter all the desired transformations in this manner. The transformations are
processed in the order they are displayed.

Note: The Ignore upper / lower case, Partial text and Wildcards settings are
saved separately for each transformation in the list.
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7. Save the format. You can use the same format for different fields.

8. Click OK.

Note: To define transformations that apply to all fields in the import file, select
Data > Global Transformation from the menu.

Conditions are only tested after values have been transformed.

The values in the Form of address field must be transformed into the values used
in Aurea CRM (Mr., Ms. and <empty>) to determine the title and greeting used in
letters and labels.

Regular Expressions in Transformations
Learn how to use regular expressions in transformation.

In the following example, a rep's e-mail address (e.g. john.doe@example.com) is
imported and the name of the rep is extracted from the e-mail address:

Regular expressions for the transformation:

Example resultsDuplicate previous
field

External valueField

johnNs,[a-z]+First Name

doeYs,[a-z]+,,,,2Last Name

john doeYt,([a-z]+)\.([a-
z]+),'$1 $2',,,1,

Name

john.doe@exam-
ple.com

YE-mail
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Info area properties
Select Info area properties from the context menu or select Data > Info Areas
from the menu to define if and how records are added to an info area.

• Format: The name of the saved format.

• Pos.: The order of the info area in the table, see Match-up Order on page 49.

• Info Area: The name of the info area into which data is imported.

• Match: Determines whether external data is matched up with internal data.

Company and person data can be matched up using a variety of methods (name,
address, company or person number). Supplementary information is matched up
using a fixed key.

If individual records are not matched up, they are added to the database if adding
new records is permitted.

Further information can be found under Match-up on page 58.

• New: The external records are added to the Aurea CRM database as new records.

• If new records are added without being matched up, external data is imported
into the system without checking for duplicates.

• Enable the Match cell to match up records before they are added to Aurea
CRM.

• Upd : Data in Aurea CRM is updated by the import process.

• Delete: Enable this option to import records with external delete codes. If this
option is disabled, records with delete codes set are not imported.

• Manual Control: Data is imported into this info area with or without manual
control.

• Log matches: Creates a log file containing records identified as identical to
records in the database.

• Log new: Creates a log file containing records that are added to the database.

• Log similar: Creates a log file containing records identified as similar (but not
identical) to records in the database.
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• Log false: Creates a log file containing records identified as false; i.e. records
that are not imported.

Note: The log file always includes the entire record including all fields in the
import file, even if one of the four Log Files options has only been enabled for
a single info area.

You can specify paths for the log files, see File Format on page 36.

The log settings are ignored when importing from an external database. No log
files are created.

• Match Options: Click in this cell to specify match-up options for companies and
persons, see Company Match-up on page 59 and Person Match-up on page 61.

• Cond. Active: Select Data > Define Condition from the menu to define import
conditions for individual info areas, see Defining Import/Export Conditions on
Records on page 50.

Enable the Cond. Active cell to enable the conditions defined for an info area.
Records in the import file need to meet these conditions in order to be imported.
Otherwise the record is rejected as "false".

• Match Active: Select Data > Define Match-Up Conditions from the menu to
define match-up conditions for individual info areas, seeMatch-up Conditions on
page 50.

Enable the Match Active cell to enable the match-up conditions defined for an
info area. Only those records that meet the conditions are matched up in Aurea
CRM.

• Default Values: If fields in the import file are empty or not present, you can
determine default values that are used instead, >> Defining Default Values on
page 49. For example, if all the companies that you are importing are located in
Germany, you do not need to specify the Country field in the import file, but can
simply set the default value of Country to "Germany".

• If the corresponding field in the import file is empty, the default value is entered
instead (even if the field already contains a different value in the database).

• If the corresponding field is not present in the import file, the default value is
only entered if the record is added to the database as a new record. Existing
fields in the database are unaffected in this case.

Note:  If the import format is also used to export data, the default values are
applied to fields that are exported, see Export Conditions on page 55.

• Package Processing: Records in the info area are imported in packages rather
than individually. This can improve performance.
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Note: Triggers are only executed after the entire package has been imported.
To prevent unwanted results, ensure that no triggers or workflows are star ted
that change or reference data in one of the info areas you are importing data into.
However you can execute triggers that only affect the imported data without any
side effects.

Package processing is not supported for the KP info area.

Package processing is not supported for imports using transactions.

Defining Default Values
Learn to define default values for info area properties.

1. Click in the Default Values cell or select Data > Default Values from the menu
to define default values for an info area.

A list of all fields in the selected info area is displayed.

2. Enter the default values in the corresponding fields.

3. Save.

Match-up Order
The order of the fields in the import format determines the order in which info areas
are matched up.

If you wish to change the order of the info areas, enter the desired position in the
Pos. column.
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Defining Import/Export Conditions on Records
You can restrict the data imported to the internal database or exported to an external
database using conditions.

Follow the below steps to define import/export conditions.

Note: While the steps to apply conditions on a record are the same, each format
for import or export has its own set of conditions defined.

1. Select Data > Define Conditions from the menu.

2. Select the info area to which conditions should be applied.

3. Define the condition, see Conditions in the CRM.Win User Manual.

Note:  Conditions can only be applied to fields that have been specified in the
import format or those selected for export to an external database. You cannot
apply conditions to placeholders.

If you have defined conditions that apply to catalog fields, the catalog values are
added first, and then the condition is tested. If the record is refused, the database
may therefore contain catalog values that are not used by any records.

Conditions are only applied after field contents have been transformed.

4. Select Data > Activate Conditions to activate the conditions for an info area.

Only those records that meet the conditions are imported to the internal database
or exported to an external database. All other records are rejected as false.

Match-up Conditions
Match-up conditions can be used to restrict the volume of data that is matched up
in Aurea CRM.

To use match-up condition, follow the below steps:

1. Select Data > Define Match-Up Conditions from the menu.

2. Select the info area to which the match-up conditions should apply.

3. Define the condition, see Conditions in the Win User Manual.

Note: The match-up conditions are ignored if the import format contains a unique
key.

4. Select Data > Activate Match-Up Conditions to activate the match-up conditions
for an info area.
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Field Properties
Select Field Properties from the context menu to access a list of the selected fields.

Alternatively, select Data > Field Properties.

• No Update: Enable this cell if you do not want the internal field contents
overwritten by the external value.

• Update -> control: Enable this cell to manually determine which contents to use
if the external and internal field contents are different.

• Update -> do not delete field: Enable this cell if you do not want the internal
field contents to be overwritten by an empty external value.

• Update -> no defaults: Enable this cell if you not want to replace empty fields
with default values.

• Update -> append field: The internal field contents are not overwritten. The field
data from the external file is appended to the internal value (without spaces).
This takes place, irrespective of whether the two values are identical or not.

This option is generally used to import notes.

• Update -> append spacing: The internal field contents are not overwritten. The
external value is appended to the internal value and separated by a space. This
takes place, irrespective of whether the two values are identical or not.

This option is generally used to import notes.

• Link with prev. field: Enable this option if you with to combine the contents of
multiple external fields in a single internal field.

• Link with prev. field + Space: Same as Link with prev. field, except that a
space is inser ted between the two field contents.

Note:  "Previous" refers to the previous identical field(s) selected. Use this to
import data from several external fields and collate the values in a single internal
field by selecting the same internal field for each of the external fields in the
import format. By enabling one of these two options, field contents are combined
and written to the same internal field. To include line breaks between field
contents, use a transformation, see Transforming Field Contents on page 43.

Example:
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ContentsLink with prev.
field (+ Space)

Field name in im-
port format

External field
name

OperngasseFI-StreetStreet

17-21activeFI-1-StreetNumber

ContentsLink with prev.
field  (+ Space)

Field name in im-
port format

External field
name

AureaFI-CompanyCompany

1040FI-PostalCodePostal Code

ViennaFI-CityCity

sales GmbHactiveFI-1-CompanyCompany 1

AustriaFI-CountryCountry

Aurea softwareactiveFI-2-CompanyCompany 2

• Duplicate in other fields: If several records are imported from one info area, a
(key) field may only be output once, but you may still wish to use this data for
other records.

Example: You import several activity records, all of which are entered on the
same day, into one record. However, the date is only included in the first activity
record. Enable this option to use the date for all following activity records that
have no date entered.

• Retain leading spaces: Leading spaces are not removed by are retained as part
of the imported field contents.

• Reduce spaces to 1: If spaces are present at the beginning of the field contents,
these are reduced to a single space.

• First letter caps: Field contents written in upper case (e.g. UPDATE SALES) are
written with an initial capital letter (e.g. Aurea Sales).

Note:  Note that field contents, such as abbreviations, that are written in capitals
is also converted (e.g. UNESCO -> Unesco).

• Duplicate previous field: Duplicates the previous field.
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Example: The telephone numbers in the import file are in the format xxxx/xxx-
xxx xxx. The number should be split amongst three fields (Country Code, Area
Code, Tel . 1).

Check Duplicate previous field to copy the telephone number into these fields:

Define transformations to strip the redundant information from each field,
see Transforming Field Contents on page 43.

InternalExternalField

**/*FI-Country Code

/**/*FI-Area Code

*/*-*

/*-**/*-*KP-Tel 1

*-*/*-*

-**-*

*-*

Result:
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• External Key: The External Key option is only available for rep and catalog
fields.

You have the following options when importing rep fields:

• Importing into the rep ID field (e.g. Rep 1 ID in the Company info area) using
the rep ID.

• Importing into the "normal" rep field using the External Key option.

To do so, select the external system (see File Format on page 36) and enable
the External Key option for the rep field.

Example: You wish to import a company record containing a rep. The rep should
be written to the Rep 1 field in the Company info area. When creating the import
format, enable the External Key option for the Rep 1 field in the Company info
area. Choose the corresponding external system in the File Format dialog box.

During the import process, the external key is searched for in the Aurea CRM
database (External Key and Ext. System fields in the Rep info area). If a rep
record is found containing the key, the corresponding rep is imported into the
company record.

If you enable the External Key option for catalog fields, the import values are
compared with variable catalogs' external keys and to fixed catalogs' internal
codes. (By default, the value is compared to the text in the current language, or
if no text is present, in the catalog base language.)

If no catalog value with the external key is found, the value is compared to the
text in the current/base languages in a second step.
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• Error -> Record false: This option is only available for variable catalog and rep
fields.

• Catalog fields:

• Error -> Record false enabled: If a catalog value is not found in the Aurea
CRM database and can not be created, the record containing the value is
not imported but rejected as false.

• disabled: If a catalog value is not found and can not be created, the record
is imported with an empty catalog field.

• Rep fields:

• Error -> Record false enabled: If no corresponding rep record is found in
the Aurea CRM database, the record referencing the rep is not imported but
rejected as false.

• disabled: If no corresponding rep record is found, the record is imported with
an empty rep field.

• Automatically add new catalogs: This option is only available for variable catalog
fields.

If this option is enabled, manual match-up is disabled for the corresponding field
(>> File Format on page 36). Catalog values are added without being matched
up manually if no matching value is found in the database.

If the External Key option is also enabled, the catalog value is added as a text
in the catalog base language and imported as an external key.

Export Conditions
Learn to define the conditions to be applied to exports.

To define conditions applied to the export:

1. Select Data > Define Conditions from the menu and define conditions applied
to one of the info areas in your export format, see Conditions in the CRM.Win
User Manual.

2. Select Info areas from the context menu.
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3. Enable the Cond. Active cell for an info area to activate the conditions defined
for that info area in step 1. Only those records that meet the conditions are
exported.

Note:  Alternatively you can select Data > Activate Conditions from the menu
to activate the conditions.

4. The condition defined in the first row also affects subsequent rows.

Example: First row: Person in Company info area; condition "Department =
Sales"; second row: Company info area, no condition. All persons with Department
= Sales are exported, and all companies that contain such a person are exported.

To change the row order enter the desired row number in the left-most column.
The rows are reordered accordingly.

5. To define that specific fields should be changed when exporting a record, enable
the Upd cell for an info area and click in the Default Values cell to enter the
desired field values. Changes to these fields may also initiate triggers.

Note:  Defining default values can impact negatively on performance.

If the export format is also used to import data, the default values are applied to
empty fields that are imported, >> Info area properties on page 47.

Testing the Import
Learn to test import settings.

To star t a test import:

• Select Test Imp/ Exp from the context menu.

• Select File > Test Imp/ Exp from the menu.
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The following settings are tested:

• Field contents in the import file

• Field transformations

• Case conversions

The following settings are not tested:

• Conditions (and their results)

• Duplicate fields (fields selected several times and used to combine data in one
internal field.

• Match-up options

Use the arrow buttons to navigate through all test results for the entire import file.

Numeric values that are not otherwise transformed are displayed using Aurea CRM's
internal format. This makes it easier to sport errors caused by incorrect decimal
symbols.

To change a transformation, click in the Transformed Content cell.

Exporting Fixed Catalog Values
Fixed catalog values are part of the data model and are stored as binary data in the
database.

This prevents a direct export of fixed catalog values. To export them using the export
module, you have to first populate the KX (Fixed Catalog (Export)) info area. Export-
ing the fixed catalog values after this follows the same steps as all infoareas.

To export the fixed catalog values, perform the following steps:

1. Run the following command from the command line shell:
mmba.exe --syncfixcattable
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The KX (Fixed Catalog (Export)) info area is populated with the fixed catalog
values for all languages.

2. Define the export format, see Defining an Export Format to an External File on
page 26.

3. Execute the export, see Executing the Export on page 81.

Match-up
New records should not simply be added to Aurea CRM; they should first be
compared to existing data in the database.

If an external record in the import file and an internal record in Aurea CRM are the
same, you need to define how the data should be merged.

To determine the match-up options for companies and persons:

• Select Data > Company Match-Up, see Company Match-up on page 59.

• Select Data > Person Match-Up, see Person Match-up on page 61.

• Select Data > Property Match-Up, see Property Match-up (BTB only) on page
63.

• Select Info area properties from the context menu and click in the Match Options
cell for the Company, Person or Person in Company info area.

Other info areas are matched up using fixed internal key fields, see Match-up Logic
for other Info Areas on page 65.

You can also match up records using external keys, see Importing with External
Keys on page 74.

Note:  If conditions are applied to the import file (Data > Define Conditions), these
are tested before data is matched up. If a record does not meet the conditions, it
is rejected as false.

When matching up records using the primary key, a record is rejected if an existing
record marked for deletion contains the same primary key. To import this record,
you first need to complete the communication cycle so that the record is physically
deleted from the database.

However, if you are not matching up records by primary key, a new record is added
instead.

You can save the match-up settings as part of the import format.

For information on external match-up options, see External Match-up in the CRM.core
Administrator Guide.
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Company Match-up
Indices are used to match up similar companies in Aurea CRM.

There are three indices: Company number, name and address.

Enable at least one of the following check boxes to carry out the match-up procedure.

• Match-up by company number / external key

Note: Important: Companies and persons are best matched up using the primary
key (company station and serial number). The company station number therefore
also needs to be imported or set as a default value.

Use this option without any additional options, if the company number identifies
the company record uniquely.

1. If Aurea CRM finds an internal and external record with identical customer
numbers or external keys (>> Importing with External Keys on page 74), both
companies are merged (even if the company names are not identical). Values
in the external file overwrite internal values. If you have enabled the Update
-> Control option for individual fields, you manually can determine whether to
use the internal or external values for this field during the import process.

2. If no identical company number is found, companies are matched up using their
name or address.

• If company no. found, compare name/address

This option is an extension of the Match-up by company number / external key
option. Use these options together if the company numbers in the import file are
not unique.
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In this case, the system should not merge records with identical company numbers,
but should match records up by name and address as well. You can then either
decide manually how data should be treated or output the data to a log file.

• If company no. not found, add new company

This option is an extension of the Match-up by company number / external key
option. Use both options if all company numbers are unique, and you can safely
assume that a company is not stored in Aurea CRM if the company number is not
found.

If no identical company number is found, the record is added to the database
without being matched up fur ther.

• Match-up by name:

Companies are matched up using the company name:

1. Only if the first 40 characters in the company name are identical or phonetically
similar, is the company matched up any fur ther. If not, the record is refused as
false.

2. If the name of a company is found in the database, the system compares the
addresses.

3. If both the company name and the address are similar, both records are
recommended for merging.

• Match-up by address:

Companies are matched up using the company address:

1. The Country, Postal Code and City are compared, followed by the Street. If
the two addresses are identical or phonetically similar, the search is continued.

2. The system checks whether the companies have a similar company number.

3. If both the company name and the address are similar, both records are
recommended for merging.

Note: To increase the performance for large volumes of data, Aurea recommends
only using the Match-up by address option, as the system only lists companies
with similar addresses (identical Country, Postal Code, City and Street) and
does not compare the company name and address phonetically.

• To match up the company by name only, without taking the address into account,
enable the Match-up by name and Ignore address (match-up by name) options.

Companies are returned if the first 40 characters of the company name are iden-
tical. This results in more companies being returned (e.g. Aurea sales AG in both
Germany and Austria), however, other similar companies might not be returned
(e.g. Aurea software AG and Aurea sales GmbH, both at the same address).
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• To only match up companies by address without taking the company name into
account, enable the Match-up by address and Ignore name (match-up by
address) options.

Companies at the same or a similar address are returned, even if their names
differ.

Note:  Using the Ignore-options (Match-up by name + Ignore address / Match-up
by address + Ignore name) is only supported when importing with manual
confirmation, i.e. if the Manual match-up option is enabled, see File Format on
page 36. Automatic match-up would lead to unwanted results.

• Match-up within one country only: Match-up according to addresses can be
fur ther restricted using this option. Only companies in the same country are
matched up.

• Post code must be identical: Match-up according to addresses can be fur ther
restricted using this option. Only companies with the same postcode are matched
up.

• Match-up by 'n' identical postcode digits: Company records are matched up
according to a specific number of identical postcode digits. If you do not enter a
value, the value entered in the Match Lgth . Field in the in the Country info area
in the Maintenance module is used (default: 3).

Person Match-up
Learn about the person match up steps.

Persons (KP and PE) are matched up in 3 steps:

1. A person is allocated to a company (KP only).

2. The system checks whether the person already exists.

3. If so, the records are merged. If not, the person is added as a new record.

If you have not determined any match-up criteria for persons, persons are matched
up (within the company) by last name, first name, form of address and address.

Note:  If you import KP records with their primary keys (KP- StaNo plus KP- SerNo),
the records are matched-up by this key irrespective of the selected match-up options.
If person numbers in the database are not unique, you may need to import PE_StaNo
or define a default value for it.
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• Match up by person number:

Only use this option if person numbers are unique.

If Aurea CRM finds a person with an identical person number (PE_SerNo), both
records are automatically merged (even if the surname is different). Values in the
external file overwrite internal values. If you have enabled the Update -> Control
option for individual fields, you can determine whether to use the internal or ex-
ternal values for this field during the import process.

If the person number is not found, Aurea CRM automatically matches up the
person (within the company) using the surname. When importing manually, you
can decide whether a new record should be added, the data should be merged,
or identified as similar. You can use the log files generated by the process as a
basis for fur ther imports. This option is especially useful for processing the data
rejected by an automatic import.

• If person number found, compare name:

This option is an extension of the Match-up by person number option.Use these
options together, if the person numbers in the import file are not unique.

The system compares the names of the persons with identical person numbers,
instead of merging them immediately. If the system cannot find the person number,
the person is matched up using surnames (within the company). If you are import-
ing manually, you can decide how to proceed. You can use the log files generated
by the process as a basis for fur ther imports. This option is especially useful for
processing the data rejected by an automatic import.

• If person number not found, add new person:

This option is an extension of the Match-up by person number option.Use these
options together, if the person numbers in the import file are not unique.

If no identical person number is found, the person is added to the database
without being matched up fur ther.
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• Match-up by name: The person is matched up using the surname with all persons
in the database.

• Match-up by address: The person is matched up using the address with all
persons in the database.

Note: To manually match up data by name and address, enable the Manual
Control column in the info area properties. If this option is not active, you can
enable the Log similar option to determine that all persons identified as being
similar are written to a log file. If this option is not enabled, similar persons are
added to the system without prompting. For more information on these options,
see Info area properties on page 47.

Property Match-up (BTB only)
The unique property key is composed of the station number and property number,
and is automatically assigned by the system.

You need to select at least one of the following options when matching up properties:
Match up by property number, Match up by name, Match up by address.

Match-up by property number

The system searches for similar properties based on the property number in the
import file and either using the station number defined in the import file or the default
value.

Only use this option if property numbers are unique.

1. If Aurea CRM finds records with an identical property number, the external and
internal records are merged (even if the property name is not identical). Values
in the external file overwrite internal values. If you have enabled the Update ->
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Control option for individual fields, you can determine whether to use the internal
or external values for this field during the import process.

2. If the property number is not found, the system continues matching up the property,
this time by name and address.

• If you have additionally enabled the option If  the property number is found,
compare name/address, Aurea CRM does not merge records if the property
numbers are identical, but matches up the property using the name and address
as well. Use this option if property numbers in the import file are not unique.

• If you additionally enable the option If  the property number not found, add
a new project, Aurea CRM adds external records to the database without
matching them up fur ther if no identical property number is found.

Match-Up By  Name

Properties are matched up by name.

1. Only if the first 20 characters of the property name are identical, is the property
matched up fur ther. The system tests whether the two names correspond by more
than 50%. If not, the record is refused as false.

2. If the name of a property is found in the database, the system compares the
addresses.

3. If both the property name and the address are similar, both records are
recommended for merging.

Match-up by address:

Properties are matched up by address.

1. The Country, Postal Code and City are compared, followed by the Street. If the
two addresses are identical, the search is continued.

2. Properties are then matched up using the name: If no similar record is found,
then the record to be imported is either rejected as "false" or added as a new
record.

3. If both the property name and the address are similar, both records are
recommended for merging.

Note: To increase the performance for large volumes of data, Aurea recommends
only using the Match up by address option, as the system only lists properties with
similar addresses (identical Country, Postal Code, City and Street) and does not
compare the property name and address phonetically.

Match-up within one country only: Match-up according to addresses can be fur ther
restricted using this option. Only properties in the same country are taken into ac-
count.
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Match-up by 'n' identical postcode digits: Property records are matched up ac-
cording to a specific number of identical postcode digits. If you do not enter a value,
the value entered in the Match Lgth . Field in the in the Country info area in the
Maintenance module is used (default: 3).

Note: You can also import objects using keys from external systems, see Importing
with External Keys on page 74.

Match-up Logic for other Info Areas
Learn how data from one infp area is matched with data in other info area.

Other data from other info areas is also matched up, see Match-up Rules for Depen-
dent Info Areas.

The system first attempts to match up records using the primary key. If the primary
key is not included in the imported record, there are three options:

• Data in cer tain info areas is matched up using specific indices, see Match-up
using Specific Indices.

• For cer tain info areas there are also specific match-up functions, see Info Areas
with Specific Match-up Logic on page 68.

• Data in other info areas is matched up using the indices, one after another. The
order of the indices can be found in the data model, see Index in the CRM.core
Administrator Guide.

If no duplicate records are found in this manner, the imported record is added to
the database as a new record.

Match-up Rules for Dependent Info Areas

When importing supplementary information, information needs to be provided with
which the external data can be linked to companies and/or persons already in the
Aurea CRM database. If the supplementary information is person-related, you need
information on both the company and the person. If the information is company-re-
lated, you only need information on the company.

• If new data should be added to dependent info areas when importing, this data
should either be matched up with data in the parent info area (with data in the
dependent info areas being added as new records) or the parent record must first
be added as a new record.

• If data is matched up in one info area, data in parent info areas is not updated.
All info areas that receive imported data need to be matched up separately using
a suitable match-up key.

• Some import keys are not tested by Aurea CRM to verify that they are unique. If
several records with the same key are stored in the system, the first record that
is found is used to match up the external data. In this case, the external system
needs to guarantee that keys are unique (e.g. Head Ext.Key in the Order info
area)
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• If a match-up key does not contain the key of the parent info area, but the key
has been defined in the import file, the external system needs to guarantee that
these keys match. Otherwise the record is imported incorrectly; e.g. an order by
company X is assigned to company Y after importing.

• If an info area is rejected as false in a match-up line, all subsequent dependent
info areas are rejected as false in this line.

• Data for several info areas can be imported in one line in the import file. If the
data in one info area is identical to the data in the line immediately above, the
info area is automatically recognized as identical to the one in the line above,
and is not displayed in the communication log file, irrespective of whether match-up
is activated for this info area. If even a single field differs, the data is treated as
a new record.

• If all of the fields in a line relating to a record are empty, the record is not included
in the log file. Subsequent records in this line cannot be matched up via this
record.

Match-up using Specific Indices

The following info areas are first matched up using the primary key. If the serial
number used to form the primary key is not included in the imported record, the
record is matched up using a specific index. If this index is not unique ([DUPLICATE]
in the Properties column in the data model), the first record that is found containing
the same index values is used to match up the imported record.

All indices for all info areas can be found in the data model, see Index in the
CRM.core  Administrator Guide. You can output all indices to a file using the -m or
-- writexmldef parameters, see mmba.exe Parameters in the CRM.core Administrator
Guide.

Index No.VerticalIDInfo Area

4FSKTAccount

1OTCSBAccount Manager

1OTCZUAllocation

6FSVWAsset Values

3FSBVBank A/C Details

4FSBSBuilding Society
Savings

1BTBKDConditions

2OTCKDConditions

1FSVVContract
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Index No.VerticalIDInfo Area

1BTBKKCredit Control

1BTB/FS/OTCBFDemand

2BTB/FS/OTCB2Expenses

3BTB/FS/OTCX1Info1

3BTB/FS/OTCX2Info2

3BTB/FS/OTCX3Info3

1BTB/FS/OTCITInterest

1BTB/OTCARItem Master

1OTCLSListing

4FSKRLoan

4FSKVMV Insurance

4FSVSPersonal Insurance

1FSPSProduct Master

1FSPMProduct Mix

4FSNVProperty Insurance

1BTBONProperty Note

2BTBOBProperty Participant

3OTCVGRefunding

4BTB/FS/OTCIDRep

1FSSURevenue Statistics

1BTB/OTCVFSales Area (Compa-
ny)
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Index No.VerticalIDInfo Area

1BTB/OTCVASales Area (Item)

1BTB/FSSBSales Group

2BTB/OTCVBSales Sector

1BTBBKSAP Company Code

4FSALSecurities Account

4FSWTSecurity Title

4FSDIService

1OTCATSpecial Offer

1BTBSPSpecialization

Info Areas with Specific Match-up Logic
This topic has the list of info areas with specific match-up logic.

If the primary key is not included in the imported record, records in the following
info areas are matched up as follows:

Activity/MA

All unique indices are tested in order.

If the system is unable to match up the data in this manner:

• Index 1 is used (FI_StaNo , FI_SerNo , KP_StaNo , KP_SerNo , Starts on,
Starts at).

• If the Type, AK_StaNo and AK_SerNo match, the rep is also tested. If the rep
is identical or empty in the imported record, the record is used to match up the
imported data.

Additional Address/ZA (BTB only)

• Index 4 is used to match up data (Ext. System, Ext.Key).

• If Ext. System and Ext.Key are empty, index 1 is used to match up the data
(FI_StaNo, FI_SerNo, PE_StaNo, PE_SerNo, Address Type, OJ_StaNo, OJ
_SerNo).
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Additional Address/ZA (FS and OTC)

• Index 3 is used to match up data (Ext. System, Ext.Key).

• If Ext. System and Ext.Key are empty, index 1 is used to match up the data
((FI_StaNo, FI_SerNo, PE_StaNo, PE_SerNo, Address Type).

Bank Code/BL (FS Only)

If the Country and Postal Code are included, index 1 is used (Bank Code)

The following fields in the imported sor t code record must correspond identically to
the data in the database:

• Bank Code and Country

• Branch No., if the Branch No. is imported.

• Branch, if the Branch is imported and the Branch No. is not imported.

• Both Branch and Branch No. must be empty if neither is imported.

Company Hierarchy/FB (BTB only)

• The system attempts to complete index 1 using the external key.

• Then index 1 is used to match up the data.

Competition Item/KU (OTC only)

• The system attempts to match up the record using the KK_StaNo and KK_SerNo
fields in the parent info area and using the Comp. Item No. field.

Installed Base/IB (BTB Only)

• The system attempts to match up using the Ext. Key Header (index 7), if the
external key is imported.

• If it is not possible to match up using the external key, and the Host No. is
imported, index 4 is used (Host No.).

• If the FI_StaNo and FI_SerNo are identical, the record is matched up.

Note:  By default, records are matched up using the Host No. across the entire
database. You can restrict this to only match up records within the same company
using a configuration entry (MC), see Import in the CRM.core Administrator Guide.
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Installed Base/IB (OTC Only)

• The system attempts to match up using the Ext. Key Header (index 5), if the
external key is imported.

Installed Base Item/KO (BTB Only)

• The system attempts to match up using the Ext. Key Header (index 3), if the
external key is imported.

• If the system is unable to match up the record using the external key, the record
is matched up using the IB_StaNo and IB_SerNo in the parent record and using
the SerNo field.

Inst. Base Item/IP (OTC only)

• The system attempts to match up using the Ext. Key Header (index 5), if the
external key is imported.

• The system attempts to match up the record using the IB_StaNo and IB_SerNo
fields in the parent info area and using the Inst. Base- PosNr . field. The first
record found is used to match up the imported data.

Mailing/BR

All unique indices are tested in order.

• If the system cannot match the data up in this manner, index 1 is used (FI_StaNo
, FI_SerNo , PE_StaNo , PE_SerNo , Date).

• If AK_StaNo and AK_SerNo match, the record is used to match up the imported
data.

Marketing Activity/AK

• If the Key field contains data, match up using index 4 (Key).

• If Key is empty, match up using index 3 (Marketing Activity, Level, Variant,
Starts on).

Note/NO

All unique indices are tested in order.

• If the system cannot match up the data in this manner, index 1 is used (FI_StaNo
, FI_SerNo , KP_StaNo , KP_SerNo , Date, Rep ID, Note Type).

• If the data in index 3 (generic link) is identical or not imported, the record is
matched up.
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Offer/PR (BTB only)

• The system attempts to match up using the Ext. Key Header (index 8), if the
external key is imported.

• If it is not possible to match up using the external key, and the PR- SerNo is
imported, index 4 is used FI_StaNo , FI_SerNo , Y2_PE_StaNo, Y2_PE_SerNo,
Offer  No.).

• The first record found is used to match up the imported data.

Offer/PR (OTC only)

• The system attempts to match up using the Ext. Key Header (index 5), if the
external key is imported.

• If it is not possible to match up using the external key, index 3 (Host No.) is used
instead.

Offer Item/AP (BTB only)

• The system attempts to match up using the Ext. Key Header (index 4), if the
external key is imported.

• If the system is unable to match up the record using the external key, the record
is matched up using the PR_StaNo and PR_StaNo in the parent record and using
the Item field.

Offer Item/AP (OTC only)

• The system attempts to match up using the Ext. Key Header (index 3), if the
external key is imported.

Offer Item Partial Delivery/AL (BTB Only)

• The system attempts to match up the record using the AP_StaNo and AP_SerNo
fields in the parent info area and using the Distribution No. field. The first record
found is used to match up the imported data.

Order/AU (BTB only)

• The system attempts to match up using the Ext. Key Header (index 5), if the
external key is imported.

• If this is not possible to match up using the Ext. Key Header and the Order No.
is imported, all orders with the same FI_StaNo and FI_SerNo are read. The first
record found with the same Order No. is then used to match up the imported
data.

Order/AU (OTC only)

• The system attempts to match up using the Ext. Key Header (index 6), if the
external key is imported.

• If it is not possible to match up using the external key, index 3 (Host No.) is used
instead.
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Order Comment/UN (OTC only)

• The system attempts to match up the record using the AU_StaNo and AU_SerNo
fields with the parent info area and using the Number field. The first record found
is used to match up the imported data.

Order Item/UP (BTB only)

• The system attempts to match up using the Ext. Key Header (index 2), if the
external key is imported.

• If the system is unable to match up the record using the external key, the record
is matched up using the AU_StaNo and AU_SerNo in the parent record and using
the Item field. The first record found is used to match up the imported data.

Order Item/UP (OTC only)

• The system attempts to match up using the Ext. Key Header (index 3), if the
external key is imported.

• If the system is unable to match up the record using the external key, the record
is matched up using the AU_StaNo and AU_SerNo in the parent record and using
the Order Item No. field.

Participant/RO (BTB only)

• The system attempts to complete index 1 using the external key.

• Then index 1 is used to match up the data.

Participant/PA (OTC only)

• The system attempts to complete index 1using the external key.

• Then index 1 is used to match up the data.

POS Monitoring Item/PP (OTC Only)

• The system attempts to match up the record using the PS_StaNo . and PS_SerNo
fields in the parent info area and using the POS Item No. field. The first record
found is used to match up the imported data.

Product/OP (BTB Only)

• The system attempts to match up the record using the OJ_StaNo and OJ_SerNo
fields from the parent info area and using the Ser  No. field. The first record found
is used to match up the imported data.

• The system searches for products with the same OJ_StaNo , OJ_SerNo , Product
Group and Ser  No. The first record found is used to match up the imported data.
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Product Detailing Definition Item/SP (OTC Only)

• The system attempts to match up the record using the SR_StaNo and SR_SerNo
fields in the parent info area and using the Line No. field. The first record found
is used to match up the imported data.

Receipt/B4 (BTB Only)

• The system attempts to match up the record using the B2_StaNo and B2_SerNo
fields from the parent info area and using the Receipt No. field. The first record
found is used to match up the imported data.

Receipt/B4 (OTC Only)

• The system attempts to match up the record using the B2_StaNo and B2_SerNo
fields from the parent info area and using the Expenses Item No. field. The first
record found is used to match up the imported data.

Refunding Item/VP (OTC only)

• The system attempts to match up the record using the VG_StaNo and VG_SerNo
fields with the parent info area and using the Refunding Item No. field. The first
record found is used to match up the imported data.

Relationship/PB

• The system attempts to complete index 1 using the external key.

• Then index 1 is used to match up the data.

Role/RL (FS Only)

• If the Prod.Ser.No . is entered, index 1 is used to match up data.

• If the Prod.Ser.No . is empty and the Prod.No . is entered, the first record found
with identical FI_StaNo, FI_SerNo, PE_StaNo, PE_SerNo, Role, Link to Info
Area and Prod.No . is used to match up the data.

Sales Area (Partner)/VP (BTB Only)

• The system attempts to complete index 1using the external key.

• Then index 1 is used to match up the data.

Sales Area (Partner)/VE (OTC Only)

• The system attempts to complete index 1using the external key.

• Then index 1 is used to match up the data.
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Special Offer Item/AA (OTC only)

• Records are matched up using the AT_StaNo and AT_SerNo fields in the parent
record and using the Special offer item no. field.

Stock Control Item/BP (OTC only)

• The system attempts to match up the record using the BV_StaNo and BV_StaNo
fields in the parent info area and using the Stock Cont. Item No. field. The first
record found is used to match up the imported data.

Importing with External Keys
Learn how to communicate and import using external keys.

The following fields are used by Aurea CRM as unique fields for communication and
importing:

• FI_StaNo and FI_SerNo for companies

• PE_StaNo and PE_SerNo for persons

• OJ_StaNo and OJ_SerNo for properties (BTB only)

You can store additional "external" keys for companies, persons or properties in
Aurea CRM that are used by external systems (e.g. accounting, mainframe) and
use them as match-up criteria when importing data. The external key needs to be
included in the import file to be able to identify the record. Any number of external
keys can be assigned to each record.

You can define external key fields for other info areas in the data model (field type
"ext.key"), see Aurea CRM Field Types in the CRM.core Administrator Guide.

Example: A company is maintained externally on 3 systems:

Company numberSystemCompany

12AS 400European Inc.

511AccountingEuropean Inc.

1100AddressesEuropean Inc.

The Ext. Company Key (XF) info area is used to match up the company imported
data from the different systems with the company in Aurea CRM.
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Ext. KeyExt. SystemFI_SerNoFI_StaNoCompany

12AS 400333KEuropean Inc.

511Accounting333KEuropean Inc.

1100Addresses333KEuropean Inc.

Note:  External keys for persons and properties are stored in the Ext. Person Key
(XP) and Ext. Property Key (XO) info areas. External keys for other info areas are
stored in the Generic external key (XG) info area.

You can also enter an external key for catalog values. However, there is no info
area for these external keys. You can therefore only define one external key,
see Editing Variable Catalogs in the CRM.core Administrator Guide and Importing
Catalog Values using External Keys on page 78.

Advantages of External Keys
Learn about the advantages of external keys.

No changes to the company key in Aurea CRM

The company key (FI_StaNo  + FI_SerNo), person key (PE_StaNo + PE_SerNo)
and property key (OJ_StaNo + OJ_SerNo) used in Aurea CRM does not need to
be changed if you use external keys.

Any number of external keys

Any number of external keys can be assigned to each company, person or property
(or other record, if defined).

If you are using several external sources (e.g. mainframe, address database etc.),
you can synchronize all the various data sources with Aurea CRM.

Defining External Keys
Learn how to define external keys.

To define an external key:

• Switch to a company and select Info > Ext. Company Key from the menu.

• Switch to a person and select Info > Ext. Person Key from the menu.

• Switch to a property (BTB) and select External Key from the context menu.

Switch to list view to display a list of all the external keys defined for the current
record:
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• Whenever a new external key is added, the following data from the current record
(company, person or property) is automatically included in the external key record:

• FI_StaNo and FI_SerNo for companies

• (FI_StaNo, FI_SerNo,) PE_StaNo, PE_SerNo for persons

• OJ_StaNo, OJ_SerNo for properties

• The combination of Ext. System + Ext.Key is unique; i.e. each combination can
only be used for exactly one person, company or property.

Note: The last key used when importing data is entered in the Ext. System and
Ext.Key fields in the record. Do not define the external key in these fields manually;
use the dedicated info areas instead.

Importing using External Keys
To import using external keys, include the Ext. System and Ext.Key fields in the
import format.

These two fields trigger the match-up procedure using the external key. If only the
Ext.Key is included in the import file, the Ext. System must be defined using a de-
fault value.

Note: To import property par ticipants using an external property key and external
company/person key, import the external keys into the Property and
Company/Person info areas. Import the other fields into the Property Participant
info area.To import only CP records (without the linked PEs), you need to use the
generic external key, i.e. you must add fields of type "ext.key" to CP in the data
model and include these fields in the import format.
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When matching up data using the external keys, the following steps are carried out:

1. If the Ext. System and Ext.Key fields are included in the imported record, Aurea
CRM searches for these values in its database. If a record is found, this record
is matched up.

2. Companies, persons and properties: If searching for the external key returns no
results, but the "normal" match-up procedure (e.g. by name and address) finds
a matching record, a new record is added to the corresponding external key info
area (Ext. Company Key, Person Key or Property Key) and the imported Ext.
System and Ext. Key are stored in this record.

Other records (generic external key): If searching for the external key returns no
results, but the match-up by station number and serial number finds a matching
record, a new record is added to the Generic external key info area using the
imported Ext. System and Ext. Key.

3. If no record is found using the normal match-up procedure, a new record is added.
A new record is also added to the corresponding external key info area (Ext.
Company Key, Person Key, Property Key or Generic external key) and the
imported Ext. System and Ext.Key are stored in this record.

Note: When importing using external keys, the corresponding external key info
area (e.g. Ext. Company Key for companies) does not need to be included in the
import format.

Caching External Keys on Import
By default, if an external key info area (X*) is used to match up records, a query
select count( *) applied to the respective X* table is applied at the beginning of
the import process.

The query returns the number of records in the external key table to determine
whether the external keys should be cached.

If the external key table contains a large number of external records (several million),
executing this query may take a long time.

To speed up the import process you can suppress this initial query for external keys
by adding a parameter to the SQL Where clause:

Syntax

Records in the corresponding external
key table are cached.

/*cache:< infoAreaId >*/

Records in the corresponding external
key table are not cached.

/*notcache:<infoAreaId>*/
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Available values for < infoAreaId >:

XG - Generic external key

XF - External company key

XP - External person key

XO - External property key (BTB version only)

X? - All of the above

Example
--sqlwhere "/*notcache:XG*/"

Records in the Generic external key (XG) info area is not cached.

Note: This option is available for both importing from a file or database table,
see Defining an Import/Export format on page 19. To use it when importing from a
file, you need to specify it in the --sqlwhere command line parameter.

Importing Catalog Values using External Keys
Learn how to import catalog values using external keys.

When matching up catalog fields using external keys, the following steps are carried
out:

1. If the External Key option is enabled for the field (e.g. Country in the Company
info area) in the field properties of the import format, the catalog value's external
key is used to match up the record, see Field Properties on page 51.

Note: You can use a different external key for different language versions of the
same catalog value if you star t the Import module in the corresponding language:
The system first matches up data using the external key of the catalog value in
the current language. If this key is not present, the external key of the catalog
base language is used instead. (If the key is not present in the catalog base
language, the keys entered for other languages are not used to match up data.)

2. If step 1 is not successful, the catalog value's text is matched up, first in the
current language and then in the catalog base language.

3. If step 2 is also unsuccessful, and the Prompt new catalog entry option is enabled
in the File Format dialog, new catalog values are matched up using the New
Catalog Values dialog, see File Format on page 36.
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• Select New to add the value as an external key and text entry in the catalog
base language.

• Select OK to select an existing value to be used instead of the imported value
or to enter a new value. The external key is not imported.

• Select Cancel to prevent the catalog value from being added.

Note: You can disable the manual match-up of catalog values for individual fields
by enabling the Automatically  add new catalogs option in the Field Properties,
see Field Properties on page 51.

Importing in the Catalog info area

The Text in base language field in the Catalog info area can store either the current
catalog value's external key or the text in the catalog base language (in which case
the content of the External Key is used to match up catalog values).

You can use the 1st Par. Cat. Text field to import dependent catalog fields (e.g.
Interest, dependent on the Interest Group) into the Catalog info area. This field
can store either the external key or the parent catalog text in the base language.
The parent key or text is first matched up, then the catalog value itself. If no corre-
sponding entry is found for the parent catalog, the record is rejected as false.

Executing the Import
Learn how to execute an import.

1. Click the Start ( ) button to star t the import process.

2. If you have determined that records should be matched up automatically, you
receive a confirmation message once the import is complete. You should then
examine the log files.
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3. If you have determined that data should be matched up manually, the following
mask is displayed if a similar record is found:

The upper section displays the record in the import file. The list below lists those
records in the Aurea CRM database that are similar to the imported record.

4. If one of the companies listed is the same as the imported company, select the

company in the list and click on  (Found). If the company is not listed, click on

 (Not Found).

The following options are available from the View menu:

• External Mask: Displays all the external data in the custom mask.

• Internal Mask: Displays all the internal data in the custom mask.

• Close Mask: Closes the external or internal mask.

• Define List Format and Load List Format: You can configure the list used to
display similar records in Aurea CRM, >> Lists in the User Manual.

5. If you have not specified any match-up control options for fields in the info area,
the companies are merged according to the defined match-up options. Internal
data is overwritten by the external data.

6. If you have defined match-up control fields, the following dialog box is displayed:

• Fields: The field that is defined as a match-up control field.

• Internal: The internal data (in the Aurea CRM database).

• External: The external data from the import file.
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7. Enable the Update cell if the external contents should be imported. Otherwise,
the existing value is retained.

8. Select Ignore All if you wish to retain the entire internal record. External values
are then ignored. The record is not rejected as false, however.

9. Select Record Is Wrong if you wish to reject the record as false. If you have
enabled the log files, the record is output to the *. fal log file. If numerical
values are imported which are too long for the internal fields, they are rejected
as false. Rejected records are displayed in red in the test run.

10.Once the import procedure has been completed, a confirmation message is
displayed and you can examine the log files.

The import procedure is also logged in the Communication Logs info area (C3),
see Logging the Import/Export on page 82.

Executing the Export
Learn how to execute the export.

Click Start ( ) to star t the export.

The data is exported to the selected file or database.

The number of records exported is displayed in the No. of Records field for each
info area.

Note:  Select Data > Export Deleted Records from the menu to include deleted
records in the export (i.e. those records where the DelCd field is enabled).

Exporting to a Database from the Command Shell
To export data from the command shell, create the export format for the external
database.

For fur ther details, see Defining an Export Format for an External Database on page
27. If the export format is already defined then you can find them in the FT infoarea.

Executing a single Export

If you wish to override the connection details of the external database defined in
the export format, then keep the new connection details ready.

To execute a single format from the command line use the following command:
mmim.exe -e -u <User> -p <Password> -f “<Format Name>”

If there are any errors they are displayed on the console. For example:
Error 509: ‘No import/export fields defined
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Executing a batch of exports

To execute a series of exports sequentially:

1. Create a text file with the sequence of export jobs one per line. See the sample
batch.txt file below:
-f export2db_Company
-f export2db_Activties
-f export2db_Person

2. Run the following command:
mmim.exe -u <User> -p <Password> -s c:\windows\batch.txt

Overriding the Connection Details

To override the connection details saved in the export format file, explicitly provide
the connection details on the command, see the following sample command:
mmim.exe -e -u <User> -p <Password> -f “AUREASPECS-1210 valid” --DBconn <DB
connection>
--DBpass <DB password> --DBname <DB name> --DBtable <DB table>

Where <DB connection>, <DB password>, <DB name>, <DB table> are the values that
override the corresponding connection parameter values saved in the export format.

Logging the Import/Export
Imports and exports are logged in the Communication Logs info area (C3).

For fur ther details, see Communication Logs on page 144.

Depending on your settings in the import or export format (Info area properties >
Log* options) log files containing records that are matched up, added, identified as
similar or rejected during the import are created on the server, see Info area prop-
er ties on page 47. You can specify a custom location for these files in the File
Format dialog (Log Files area), see File Format on page 36.

In addition, you can determine that errors occurred during import or export are
logged in the database. To do this, select the Log import results or Log export
results checkbox in the File Format dialog.

Note:  For imports executed in Aurea CRM web this option is always enabled.

If an error occurs during import, Import Results records (C5) are created and linked
to the corresponding C3 record.

One C5 record per error is created. If no errors occur, no C5 records are created.
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To view these records

• in Aurea CRM win: Select the context menu option Import Results in the
Communication Logs level.

• in Aurea CRM web: Click on Show log in the Import popup or select
Administration > Jobs & Logs > Communication Log and view the corresponding
sub-list.

For information on error codes, see General Error Codes and Import/Export Error
Codes in the CRM.core Administrator Guide.

Import and Export Errors
Learn about the reject reasons for import and export.

Records can be rejected as false for the following reasons:

• Data is missing in mandatory fields: check whether the rejected records have
anything in common (e.g. no entry in the Currency field for offer records). The
mandatory fields must either contain data or a default value must be defined.

• Import or Export conditions are not met by the imported records.

• User access rights: Verify that the user that carried out the import procedure
has the necessary access rights. The user may have been assigned access rights
that prevent the addition of new data.

You can improve performance when importing new companies and persons by
turning off the lead status log using the Do not log lead status changes configura-
tion option, see General Settings in the CRM.core Administrator Guide and Lead
Status in the Business Logic Manual.
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3
Communication
Communication is the exchange of data between different Aurea CRMstations (main
office, branch offices).

Communicating ensures that the necessary data is present on each station and is
up to date.

The station number is central to the communication process. Each station has a
unique station number used to identify the station when communicating. The station
number is also used to form records' primary keys (e.g. station number + serial
number for independent info areas), indicating which station the record is added
on, see Defining Stations.

A data stock download is used to initialize an empty Aurea CRM database with
data. The data stock download must be created on the main office and imported on
the branch office, see Configuring Communication on page 85.

All changes to data made on a station (adding, editing, deleting records) since the
last communication session are tracked by the system and must be communicated
to all other stations that work with the affected data. To communicate, a communi-
cation file is output by the source station and input on the target station,
see Communication Steps on page 120.

Communication files can be transferred from the source station to the target station
using telecommunications networks (LAN, FTP, e-mail (MAPI) etc.) or using external
media.

Data in the communication file is compared to and merged with the data in the target
database, see Match-up.

Communication formats and distributed logic define which data is output and
input by each station. For example, you can determine that the main office only
outputs companies assigned to a notebook owner when communicating with note-
books, see Communication Format on page 89 and Distribution Logic on page 110 .
The synchronization process ensures that data required by a station (based on
the communication format and distributed logic) is present on branch offices,
see Synchronization on page 131.

Communication can be star ted automatically (from the command line) or manually
(from the Station and Communication info areas), see Star ting Communication on
page 124.

Note: You can communicate with up to 1,000 stations in a single communication
process.
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Info Areas in the Communication Module

Stations are defined in the Station info
area. Important information regarding
communication processes (deletions,
synchronization, catalog maintenance)
is logged here see Station on page 87.

Define communication formats in the
C.Format info area to determine which
is communicated under what conditions,
see Communication Format on page 89.

Use the Distribution Logic info area to
fur ther restrict the data communicated to
this station, see Distribution Logic on
page 110.

Use the Communication info area to
define the data connections between
stations that should communicate with
each other, and assign a communication
format to the connection, see Communi-
cation Info Area on page 113.

Communication processes are logged in
the Communication Log info area,
see Communication Logs on page 144.

The Station Overview info area provides
a graphical overview of the communica-
tion setup, showing stations and connec-
tion, see Station Overview on page 148.

Configuring Communication
Learn the steps to configure communication.

To configure communication on the main office:

1. Switch to the Rights module:

a. Define the stations that should communicate with each other, see Station on
page 87.

Configure one station as the main office by enabling the Main Office field in
the station record. The data model can only be edited on this station.
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Configure one station as the catalog maintenance station by enabling the
Aut.Cat.Maintenance field in the station record. The Catalog Maintenance
(KW) info area is only maintained on this station. Changes to variable catalogs
are communicated to all other stations by the catalog maintenance station,
see Communicating Catalogs on page 139.

Define access rights for the remaining stations that prevent users from making
changes to the Catalog info area, to prevent data inconsistencies, see Defining
Access Rights for Variable Catalogs in the CRM.core Administrator Guide.

b. Define the languages available in Aurea CRM and assign the desired languages
to the stations, see Defining Languages and Assigning Languages in the
CRM.core Administrator Guide.

c. Define reps and logins, see Defining Reps in the CRM.core Administrator
Guide.

d. Define a communication user (e.g. "COM") and only assign this user (and the
SU) access to the Communication module to ensure that data cannot be
overwritten by concurrent communication processes, see Module Access Rights,
System Locks and Process Tracking in the CRM.core Administrator Guide.

2. Switch to the Communication module:

a. Use the C.Format and Distribution Logic info areas to determine which data
to communicate, see Communication Format on page 89 and Distribution Logic
on page 110.

b. Define the connections between stations in the Communication info area, and
assign communication formats to the connections, see Communication Info
Area on page 113.

3. Create a data stock download and input it on the branch offices, see Data Stock
Download on page 117.

Once the data stock download has been input on the branch offices, changes to
data can be automatically communicated between the stations, see Communication
Steps on page 120.
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Station
The Station info area stores information on the stations in your setup. Each station
corresponds to a computer that hosts an Aurea CRM database.

Each station requires a station record that refers to the station itself, and records
for all stations that the station communicates with:

1. Define all stations on the main office (see Defining Stations) and communicate
the station records as part of the initial data stock download, see Data Stock
Download on page 117.

The Station info area is available in both the Rights (see Station in the CRM.core
Administrator Guide) and Communication modules. The two info areas are iden-
tical except for the context menu:

• The context menu in the Rights module contains the entries Languages and
Distribution Logic, see Assigning Languages in the CRM.core Administrator
Guide and Distribution Logic on page 110.

• The context menu in the Communication module contains the entries Distribution
Logic, Input, Output, see Star ting Communication on page 124.

Defining Stations

To configure stations for communication:

1. Define the station as described in Defining a Station.

2. Set one station as the Main Office and one station as the catalog maintenance
station (Aut.Cat.Maintenance field), see Communicating Catalogs on page 139.

3. Enter the station's e-mail address in the E-mail addr . field on the Address tab
for stations that communicate via e-mail, see Communicating via E-mail on page
128.

4. The following settings are available on the General tab:
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• Verify the target station's number: Enable this option to determine that the
system should verify that the communication file is intended for this station
before inputting the file. If the station number in the communication file does
not match the current station's number, the process is canceled.

• Com.Mon  - Com.Sun: Enable these check boxes to determine the days of
the week on which data can be output to this station. All days are enabled by
default.

You can disable one or more days, for example to carry out maintenance.

Note: These days only affect communication initiated via the command line or
from the Station info area. Manual communication (star ted from the
Communication info area) is not affected, see Star ting Communication on page
124.You cannot use default values (View > Default Values) to enter the
communication days.

• Directory: By default, directories for communication files are named according
to the station number, >> Directory structure on page 9. You can specify a
different directory name here, e.g. to name directories according to the station's
name (e.g. .. \main office\del instead of .. \1\del etc.).

Aurea recommends retaining the default settings.

5. Information on the communication process and automatic catalog maintenance
is entered by the system on the Comm. Overview and Cat. Maintenance tabs,
see Comm. Overview Tab and Communicating Catalogs on page 139.

6. Use the Delete tab to configure how deleted records are handled:

• Delete automatically: Enable this option to automatically delete records with
an active delete code from the local database once the time period in the Delete
Cycle in Days field has expired, see Communicating Deleted Records on page
137.

• Delete Cycle in Days: Once the number of days entered here (default:7) have
expired, the system checks for records with an active delete code. If you do
not enter a value here, records are deleted each time communication takes
place.

• Last Deletion: The time records are last deleted is entered here automatically.
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7. Use the Synchronization tab to determine how often databases at branch offices
should be synchronized with the main office. Synchronization is used to ensure
that branch offices have all the data they require, see Synchronization on page
131.

Enter the synchronization interval in the Sync.Cycle ( Days) field in the branch
office station records (e.g. every 28 days). If you do not enter a value, the
databases are synchronized each time the stations communicate.

You only need to enter a synchronization interval for branch offices.

8. Select Distribution Logic from the context menu if you want to define conditions
applied to the communication data for each station, see Distribution Logic on
page 110.

Communication Format
The C.Format (Communication Format) info area is used to determine which data
is output or input on a station.

You then need to define a connection between the communicating stations in the
Communication info area and assign the communication format to the connection,
see Communication Info Area on page 113.You need to define the connection between
stations and a communication format before you can communicate.

The following general rules apply to communication:

• Data in an info area is only communicated if the Output and Input cells are
enabled for the info area in the communication format.

• Dependent records are only communicated if the parent record is communicated.

Examples:

• Activities are only communicated if the activity's parent person or company is
communicated.

• If the Person info area is not communicated, but the Activity and Company
areas are, only company-related activity records are communicated.

• The City info area (Maintenance module) is not updated when inputting data,
i.e. no new city records are added for the cities entered in communicated company
records, see City Info Area in the CRM.core Administrator Guide.

• Records in the WWW Interest info areas (and any dependent records) are only
communicated if company or person records have been generated based on the
record, see WWW Interest in the User Manual.
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If you do not wish to restrict the data that is communicated between stations, enable
the Output and Input cells for all info areas by clicking on the column headers.
Assign the communication format to all communication connections.

If you wish to restrict the communicated data (e.g. by area, rep, product group etc.),
you can define conditions in the communication format and/or the Distribution
Logic info area, see Defining a Communication Format on page 90 and Distribution
Logic on page 110.

Conditions in the communication format and Distribution Logic info areas can be
combined using a AND or OR, see Combining Communication Formats and Distribu-
tion Logic on page 112.

Defining a Communication Format
Learn how to define a C.Format.

To define a communication format:

1. Start the Communication module, see Star ting Modules on page 13.

2. Switch to the C.Format info area.

All available info areas are listed hierarchically in the Info Area column.

3. Click in a cell to define your settings, see Tables in the User Manual.

The following options are available:

• Output: Enable the Output cell for those info areas that should be output. Click
on the column header to enable or disable all cells.

Note:  Dependent records are only output and input if their parent record is also
output or input.

• Conditional Output: Enable this cell (in addition to the Output cell) and define
the conditions that determine which records in the info area should be output,
see Conditional Output on page 92.

• Bottom-Up Condition: Use this option to restrict the output of records from
parent info areas using conditions applied to child info areas. For example, you
could define that a field rep only receives those company records for which an
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activity exists where he is entered in the Rep field, see Bottom-Up Condition
on page 94.

• +Bottom-Up: Use this option to combine conditions applied to child info areas
with conditions applied to the parent info area using a logical OR (i.e. records
are output if they meet either the parent conditions or the child conditions),
see +Bottom-Up on page 96.

• Bottom-Up Indirect: Use this option to restrict the output of records in an
independent info area (e.g. Marketing Activity) based on conditions applied
to another independent info area (e.g. Company). Both info areas need to be
linked to the same dependent info area (e.g. Activity), see Bottom-Up Indirect
on page 97.

Note: Bottom-Up, +Bottom-Up and Bottom-Up Indirect conditions are not
applied to records marked as deleted (see Communicating Deleted Records on
page 137). At least one record in the child info area must not be marked as deleted
for the condition to be applied to the parent record.

• +Relationship: Use this option to output records that are linked to another
record in the same info area.

You can restrict the output records using conditions applied to the info area
that contains the link (Ticket, Relationship etc.).

• Input: Enable this cell for those info areas that should be input. Click on the
column header to enable/disable all cells.

• Conditional Input: Enable this cell and define a condition to restrict which
records are input in this info area, see Conditional Input on page 99.

• Field Properties: Enable this cell to configure communication settings for
individual fields, see Field Properties on page 99 .

By default, all fields in the info area are communicated. The Field Properties
cell contains a tick if the settings have been edited.

• Match-up Control: By default, companies, persons and properties (BTB only)
are matched up based on the primary key (as for all other records), see Match-
up. Use this option to define other match-up conditions for these records,
see Match-Up Control on page 101.

• Synchronization: By default, the output conditions are used to synchronize,
see Synchronization on page 131. Use the Synchronization option to additionally
determine that the synchronization should use the input conditions for specific
info areas, for example to remove outdated or redundant data from branch
offices, see Synchronizing using Input Conditions on page 136. Input conditions
need to be defined for the selected info area (Conditional Input column).
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Note:  Aurea recommends retaining the default settings (match up by primary
key) for companies, persons and properties.

4. Click on  (Save), see Saving, Loading and Deleting Formats in the User Manual.

Note:  Use  (Load) to load and edit an existing format. Click on  (Delete) to
clear the current settings. Select File  Print from the menu to print the
communication format, see Printing Communication Formats on page 109.

5. Assign the communication format to one or more communication connections,
see Communication Info Area on page 113.

Conditional Output
You can define conditions for each info area to determine which data in that info
area is output.

For example, to restrict the output to companies located in Germany:

1. Enable the Output cell for all info areas by clicking on the column header.

2. Click in the Conditional Output cell of the Company info area.

The Define Search Conditions dialog box is displayed.

3. Define the desired condition(s), e.g. Country = 'Germany', see Conditions in the
User Manual.

4. Click on OK.

5. Save the communication format.

Only companies in Germany and their dependent records (persons, activities) are
output.

The Conditional Output can also contain inactive conditions. As such, there are
three possible states:

• No conditions: The cell is empty. All records are output.

• Active conditions: The cell contains a tick. Only those records are output that
meet the conditions. This condition can also be used in Bottom-Up and
+Bottom-Up conditions, see Bottom-Up Condition on page 94 and +Bottom-Up
on page 96.
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Only those companies are output for which an activity record exists with rep
000100029, and only those activities are output where rep 000100029 is entered
as the rep.

• Inactive conditions: The cell contains a grayed out tick. The condition is only
used by Bottom-Up and +Bottom-Up conditions. All records are output for the
parent record:

Only those companies are output for which an activity record exists with rep
000100029, and all activities are output for these companies (irrespective of the
rep entered in the activity).

Applying Variable Conditions to the Target Station

You can define variable output conditions applied to the target station in communi-
cation formats.

For example, to only output those companies where the rep assigned to the target
station (i.e. the rep whose notebook is the target station) is entered as Rep 1.

1. Add a configuration entry to define that the Rep ID field in the Station info area
can be used in variable conditions (Variable default values for conditions option
in the Configuration info area), see General Settings in the CRM.core
Administrator Guide.

2. Start the Communication module and switch to the C.Format info area.

3. Enable the Output column for all info areas (by clicking on the column header).

4. Click in the Conditional Output cell of the Company info area.

The Define Search Conditions dialog is displayed.

5. Define the following variable condition (see Defining Variable Conditions in the
User Manual):
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Use the Target Station option to determine that the Rep ID is not taken from the
current station's record, but from the target station's record (i.e. the receiving
station).

Note: The Target Station option is only taken into account when outputting
communication data.

6. Click on OK.

7. Save the communication format.

Only those companies are output where the rep entered in the Rep 1 field is the
rep entered in the target station's record.

Bottom-Up Condition
Bottom-up conditions allow you to restrict the output of parent records by defining
conditions applied to child records.

For example, you could only output those persons for which a sales group record
exists that contains a specific rep:

1. Enable the Output cell for all info areas by clicking on the column header.

2. Click in the Conditional Output cell of the Sales Group (OTC: Account Manager)
info area.

3. Define the condition, e.g. Rep 1 ID = '000100029'.
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4. Click on OK.

5. Click in the Bottom-Up Condition cell of the Sales Group info area.

All parent info areas are listed. Records are only output from the info area(s) se-
lected here if the records meet the conditions defined in the corresponding info
area's Conditional Output cell.

For the Person info area (PE) you can choose between the default link and link
500 to read only person-related child records: When outputting PE records, by
default all child records linked to PE and KP are output. Use link 500 to output
PE-related data only.

6. Select the Person in Company info area.

7. Click OK.

8. Save the communication format.

The following records are output:

• All companies

• All sales group records where the rep with ID 000100029 is entered as Rep 1.

Note:  If you deactivate the conditions defined for the Sales Group info area
(indicated by a gray tick), all sales group records are output, irrespective of the
rep entered in field Rep 1, see Conditional Output on page 92.

• Persons are only output for which a sales group record exists where Rep 1 ID =
000100029.

• All the output companies and persons' child records (e.g. activities).

Conditions defined for the parent info area in the Conditional Output cell are
combined with the bottom-up condition using a logical AND, i.e. the parent records
need to meet both conditions to be output.
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Use the +Bottom-Up option to link the conditions using a logical OR instead,
see +Bottom-Up on page 96.

+Bottom-Up
If conditions are defined for a parent info area (Conditional Output cell), and you
wish to define a bottom-up condition to output additional records in the parent info
area, define a +Bottom-Up condition.

+Bottom-up conditions are applied to the parent info area using a logical OR, i.e.
records in the parent info area are output if they meet the conditions defined for the
parent info area and/or meet the conditions defined using the +bottom-up condition.

For example, to output all companies in Germany and all companies for which a
sales group record exists:

1. Enable the Output cell for all info areas by clicking on the column header.

2. Click in the Conditional Output cell of the Company info area.

3. Define the condition Country = 'Germany'.

4. Click OK.

5. Click in the Conditional Output cell of the Sales Group (OTC: Account Manager)
info area.

6. Enter the condition Rep 1 ID = '000100029'.

7. Click on OK.

8. Click in the +Bottom-Up cell of the Sales Group info area.

All parent info areas are listed.

9. Select the Company info area.

10.Click Ok.

11.Save the communication format.

The following records are output:

• All companies in Germany

• All sales group records where the rep with ID 000100029 is entered in the Rep
1 field
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Note:  If you deactivate the sale group's Conditional Output (indicated by a gray
tick), all sales group records are output, irrespective of the rep entered in the
Rep 1 field, see Conditional Output on page 92.

• All companies (in all countries) for which a sales group record exists where Rep
1 ID = '000100029'

• All the output companies' child records (persons, activities etc.)

Bottom-Up Indirect
Use Bottom-Up Indirect conditions to restrict the output of data in an independent
info area using conditions applied to another independent info area.

The two independent info areas must be linked to the same dependent info area.

Example

The Activity info area is a direct child of the Company and Person in Company
info areas and an indirect child of the Marketing Activity info area. All companies
in Germany should be output, as well as all companies for which an activity record
is added within the scope of a currently ongoing marketing activity.

Define the communication format as follows:

1. Enable the Output cell for all info areas by clicking on the column header.

2. Click in the Conditional Output cell of the Company info area.

3. Define the condition Country = 'Germany'.

4. Click on OK.

5. Click in the Conditional Output cell of the Marketing Activity info area.

6. Define the condition Status = 'In Progress'.

7. Click on OK.

8. Click again in the Conditional Output cell of the Marketing Activity info area.

The tick is displayed in gray indicating that the condition is only applied when
using Bottom-Up, +Bottom-Up or Bottom-Up Indirect conditions, see Conditional
Output on page 92.

9. Click in the Bottom-Up Indirect cell of the Marketing Activity info area.

All info areas are listed that are linked to the Marketing Activity info area.

10.Select the Activity info area.

11.Click OK.

12.Click in the +Bottom-Up cell of the Activity info area, see +Bottom-Up on page
96.

13.Select the Company info area.

14.Click OK.
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15.Save the communication format.

The following records are output:

• All companies in Germany

• All companies (in all countries) for which an activity exists that is added for a
marketing activity whose current status is 'In Progress'

• All the output companies' dependent records (persons, activities etc.)

• All activities

+Linked Via...
Aurea CRM contains several info areas that include multiple links to the same info
area.

Use the +Relationship option to determine that all records linked in this manner
should be output. You can restrict the records that are output by defining a condition
applied to the info area containing the links.

By default, the +Relationship option is only available for the Company and Rep
info areas:

• You can output companies entered in a ticket for a company that is output based
on the conditions applied to the Company info area.

• You can output reps that are allocated to the same group (Group Allocation info
area) as a rep that is output based on conditions applied to the Rep info area.

You can define additional links in the data model to extend this feature, see Link in
the CRM.core Administrator Guide.

For example, to output all companies in Germany, as well as all companies linked
to German companies via the Relationship info area:

1. Enable the Output cell for all info areas by clicking on the column header.

2. Click in the Conditional Output cell of the Company info area.
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3. Define the condition Country = 'Germany'.

4. Click on OK.

5. Click in the +Relationship cell of the Company info area.

All info areas are listed that include more than one link to the Company info area.

6. Select the Relationship info area.

7. Click OK.

8. Click in the +Relationship cell of the Relationship info area.

9. Define the conditions for the relationship type, e.g. Relationship type = 'Corporate'

10.Save the communication format.

The following records are output:

• All companies in Germany

• All companies linked to a company in Germany via the Relationship info area
and where the Relationship type is 'Corporate'

• All these companies' child records (persons, activities etc.)

Conditional Input
Click in the Conditional Input cell to define a condition used to restrict the records
that are input.

This option is generally used on the main office to filter data received from branch
offices.

The Conditional Input is otherwise similar to the Conditional Output option,
see Conditional Output on page 92.

You can additionally determine (per info area) that data should be synchronized
using the input conditions, for example to remove redundant or outdated data on
branch offices, see Synchronizing using Input Conditions on page 136.

Field Properties
Use the Field Properties cell to configure the communication settings for each
individual field in an info area.

By default, all fields are communicated. The Field Properties cell only contains a
tick if you have changed the settings from the default.
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To define field properties:

1. Click in the Field Properties cell of the desired info area.

A list of all fields in the info area is displayed.

2. Enable or disable the following options for the fields:

• Output: Enable this option to output the field contents.

• Input: Enable this option to input the field contents.

• Edit: Enable this option to update the field contents if the input file is more
up-to-date.

If you disable this option, the field contents is never updated on this station.

Use the Update priority configuration option to prevent fields contents from
being overwritten by newer contents, see Communication in the CRM.core
Administrator Guide.

• Update Control: Enable this option to determine that a dialog box should be
displayed if the field content is changed when inputting data. You can then
decide whether to retain the existing field contents or overwrite the contents
with the data in the communication file, see Communication with Change Control.

Only enable this option in communication formats used to communicate manu-
ally, >> Manual Communication on page 129. This option is ignored when com-
municating automatically and field contents are always updated.

Note:  Star t communication from the command line using the k parameter to
determine that the change control prompt should be displayed, see mmco.exe .

The Output, Input and Edit options are enabled by default.

3. Click on  (OK).

4. Save the communication format.
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Match-Up Control
You can define specific match-up conditions for companies, persons and properties
(BTB only).

These conditions can extend or replace the default behavior (match-up by primary
key), see Match-up.

You can define rulesets used to match up records automatically or determine that
similar records should be matched up manually.

Note:  Aurea recommends using the default settings (match up by primary key) for
companies, persons and properties.

To define your own match-up conditions:

1. Switch to the C.Format info area.

2. Load the communication format you wish to define the settings for or define a
new format, see Defining a Communication Format on page 90.

3. Click in the Match-up control cell of the desired info area (Company, Person,
Person  in Company or Property).

4. Click on  (New).

The Match-up Control dialog box is displayed, see Match-Up Control Options
on page 102.

5. Click on OK (without changing the settings) to define the default behavior (match
up by primary key) as the first line.

6. Define additional lines containing the desired settings, see Match-Up Control
Options on page 102.

The lines are processed in the order they are listed. Edit the number in the first
column to change the order of the lines.

7. Return to the C.Format info area.

8. Save the communication format and assign it to the desired communication
connection, see Defining Communication Connections.
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Note: The match-up settings for FI and KP must be identical.

Match-Up Control Options
Learn about the Match-up controls options.

The Match-Up Control dialog box contains the following options:

Internal/External

• Group: The station number (company/person group). (Not available for PE.)

If you are matching up records by number, you do not need to enter any values
in these fields.

If you are using a different match-up option, you can determine that external
records with a cer tain group are compared to internal records in another group.

• From no, / To  no.: Currently no function.

Match-up By

Select the desired match-up type from the drop-down list, see Match-up Types on
page 103.

No Manual Control

Enable the No Manual Control option to execute the communication process without
manual control, irrespective of the execution type entered in the Execution field in
the Communication info area, see Defining Communication Connections and Auto-
matic Communication on page 125.

New / Update

Currently no function.
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Deny Deletion

• By external: External company or person records that have been marked for
deletion do not cause the deletion of (identical) internal records, see Communi-
cating Deleted Records on page 137.

• By internal: Internal records marked for deletion are deleted. They cannot be
restored by inputting identical external records.

If Deny Deletion by Internal is enabled, internal records are physically deleted.
External records are added as new records and data linked to these records is
requested again.

Use external no./Retain internal no.

• Use external no.: If an identical company is found with different external and
internal keys when matching up by name/address, the internal record is updated
with the external key.

• Retain internal no.: If an identical company is found with different external and
internal keys when matching up by name/address, the key is retained.

Priority during update

Determines which record is to be retained:

• Date: Default value; the more recent record has precedence.

• External: If the records have the same date, the external record has precedence.

• Internal: If the records have the same date, the internal record has precedence.

Note:  Aurea recommends always using the Date option.

Match-up Types
Learn about the match-up types.

Select the desired match-up type from the Match up By drop-down list.

No. Found -> Change

The primary key of the external record is searched for in the local database.

• If a record is found with the same primary key, the external and internal records
are merged, i.e. the internal record is updated with the most recent field contents.

• If no record is found with the same primary key, a new record is added. If fur ther
match-up conditions have been defined, these are applied.

Usage: Unique primary keys, no duplicates expected.

No. Found -> Compare Name/Addr.

The primary key and name and address of the external record are searched for in
the local database.

• If a record is found with the same primary key, the name and address in the
external and internal records are compared. The records are only merged if the
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record is judged to be identical after comparing the name and address. Otherwise
the record is rejected.

• If a record is found with the same primary key where the name and address does
not match the data in the external record, the record is handled differently based
on the execution type (Execution field in the Communication info area):

• The record is rejected as false if the communication process is automatic and/or
the option No manual control is enabled.

• If the communication process is star ted directly from the Communication info
area using manual and/or manual/automatic execution, and the option No
manual control is disabled, you can merge the record with the internal record
with the same primary key, see Communication with Manual Match-up.

• If no record is found with the same primary key, a new record is added.

Usage: No unique primary keys.

No. not found -> New

The primary key of the external record is searched for in the local database.

• If a record is found with the same primary key, the external and internal records
are merged, i.e. the internal record is updated with the most recent field contents.

• If no record is found with the same primary key, a new record is added without
matching up the records fur ther.

Usage: Unique primary keys, no duplicates expected.

Name/addr. identical -> Change

The name and address of the external record is searched for in the local database.

• If a record is found with the same name and address as the external record, the
records are merged, i.e. the internal record is updated with the most recent field
contents.

• If no record is found with the same name and address as the external record, the
record is treated as follows depending on the execution type (entered in the
Execution field in the Communication info area):

• If the communication process is star ted automatically and/or the No manual
control option is enabled, the record is added without a prompt.

• If the communication process is star ted directly from the Communication info
area, or the execution type is "Manual/Autom.", similar internal records are
listed, see Communication with Manual Match-up.

Name/addr. identical -> New

Use this option to check for records with the same name and address, and to add
the record even if an identical record is found.

Usage: When individual companies should be present in the database multiple times
(e.g. for billing purposes).
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No. Similar -> Log

If the external and internal keys are identical but the name and address are different,
the record is saved to a log file (sim.*). This file then needs to be manually imported
and matched up, see Inputting SIM files.

Name/Address Similar -> Log

If internal records are found with a similar name and address to the external record,
the external record is saved to a log file (sim.*)

-> Log

Records are not matched up any fur ther, but are immediately written to a log file
(sim.*).

Communicating System Tables
For Aurea CRM to work correctly on all stations, info areas containing configuration
settings need to be communicated.

Apply the following settings to your communication formats:

• Key: Enable the Output and Input cells to ensure that serial numbers are assigned
correctly, see Key Info Area.

• Language: Output the Language info area to all branch offices to ensure that all
languages are available on all stations, see Multi-Language Catalogs in the
CRM.core Administrator Guide. Deny access to the Language info area on branch
offices in the Rights module, see Defining Rights at the Info Area Level in the
CRM.core Administrator Guide.

• Text: Enable the Output and Input cells. Texts can be added and translated on
branch offices, see Text in the CRM.core Administrator Guide.

• Tenant and Additional Tenant: Enable the Output and Input cells if you are
working with tenants, see Tenants in the CRM.core Administrator Guide.

• Configuration: Always communicate the Configuration info area to branch
offices, see Configuration Info Area in the CRM.core Administrator Guide.

• Exchange Rate Table: Enable the Output and Input cells if you work with multiple
currencies, see Working with Several Currencies in the ver tical-specific manuals.

• Station and dependent info areas/Station Configuration: Enable the Output
and Input cells for the Station info area and child info areas, as well as for the
Station Configuration info area. If your communication setup includes multiple
tiers, communicate the main office's Station and Station Configuration to all
branch offices, otherwise you are prompted to register your license, see Aurea
CRM License in the CRM.core Administrator Guide.

• Rep and dependent info areas: Enable the Output and Input cells for the Rep
info area and its child info areas. Use the Central Login Configuration info area
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to define logins for users at branch offices, see Central Login Configuration in
the CRM.core Administrator Guide.

To communicate logins, include the corresponding records in both the Central
Login Configuration (ES) and Rep (ID) info areas in your communication format.
The data in the Central Login Configuration (ES) info area is transferred to the
Login (US) info area on the target station, and the corresponding users' directories
are added.

The Login (US) info area itself is not communicated.

• User Tracking: Input the User Tracking info area from all branch offices,
see User Tracking in the CRM.core Administrator Guide.

• Country and City: Enable the Output and Input cells. These info areas are also
updated when adding new companies on branch offices, see Country Info Area
and City Info Area in the CRM.core Administrator Guide.

• Relationship Level: Enable the Send and Receive cells if reciprocal relationships
should be added automatically, see Relationships in the User Manual.

• Format: The Format info area contains a significant por tion of Aurea CRM's
configuration options (access rights, masks, triggers etc.), see Formats in the
User Manual. Always output the Format info area to all branch offices.

Note:  Save conditions and transfer formats as global formats so that users at
branch offices can also use them, see Global Formats in the User Manual. The
data model is always communicated to branch offices if it is changed (irrespective
of your communication settings), see Communicating Data Model Changes in the
CRM.core Administrator Guide.

If you want to communicate specific formats to specific branch offices, use the
Distrib . code fields in the Format info area to fur ther restrict the communication
of cer tain format types (e.g. conditions).

• History: Input the History info area on all branch offices, see History in the
CRM.core Administrator Guide.

Note: The Catalog Maintenance and Catalog info areas are always
communicated. They are not available in the C.Format info area, see Communi-
cating Catalogs on page 139.

• CRM Process: Enable the Input and Output cells for the CRM Process info area
to ensure the system-wide CRM process configuration functions correctly on all
stations, see CRM Process Configuration in the CRM.core Administrator Guide.

• Stock, Stock Control etc.: If you are using the stock-related info areas, you need
to communicate all info areas containing stock-relevant data, see Inventory
Management in the Business Logic Manuals.
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The Stock History (BTB only) info area is not communicated; it is used to record
changes to local stocks.

• WWW Interest (II), WWW Interest Configuration (I9): Enable the Input and
Output cells for these info areas to ensure that user-specific settings of <offline>
users are correctly synchronized between online and offline mode, see web <of-
fline> Installation & Technical Guide.

Key Info Area

The Key info area stores the highest existing serial number for each info area and
station (in this example for the Company info area):

No2No1IndexInfo Area Code

20011FI

101011FI

31031FI

11041FI

12001FI

• Info area code: Info area ID

• Index: Access index, see Link in the CRM.core Administrator Guide.

• No1: Station number

• No2: The current highest serial number on this station

The Key info area must always be communicated for serial numbers to be assigned
consistently, see Communicating System Tables on page 105.

Note:  Primary keys can only be changed in the Maintenance module once data
has been communicated successfully. If you change the primary key after having
communicated, records may be output with the new key and may be duplicated.

Communicating Document (D1)
Learn how to control the sending of documents.

You have the following means of restricting the communication of Document (D1):

• Define conditions applied to the Document info area, see Conditional Output on
page 92.

• Restrict the communication of general documents using the Document Link (D3)
info area.
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By default, D3 links are only communicated if the record entered in the link field is
also communicated. A D3 link to an activity record is only communicated if the ac-
tivity record meets the applicable communication conditions. Use the D3DontCheck
parameter to disable this behavior, see mmco.exe Parameters on page 343.

To communicate documents based on the D3 link, you need to define the following
settings applied to the Document Link info area in the communication format:

1. Bottom-Up or +Bottom-Up condition applied to the Document info area.

2. Bottom-Up Indirect condition applied to the Document info area.

Examples:

• To only output documents for which a D3 link exists:

• To fur ther restrict the communication of documents with D3 links:

In this case, documents are only output if a D3 link exists OR the Doc. Class is
"Offer".

• To output documents for which a D3 link exists OR whose Doc. Class is "General:

Use this format to output general documents (e.g. mass mailing documents) with
no D3 link, in addition to documents with D3 links.

• To only output documents for which a D3 link to a specific info area exists:

In this case, documents are only output if a D3 link to an activity record exists.

• To restrict the output of documents with D3 links based on the parent info area
of the link record:
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Documents with D3 links are output under the following conditions:

If a D3 link exists to an activity record for a company in the UK or USA, the D3
link and corresponding document are output.

If the D3 link references an activity for a company in France, the link is not output
(and consequently, neither is the document).

Note:  Communicating documents based on D3 links can have a negative impact
on performance.

Printing Communication Formats
Learn how to print a communication format.

To print a communication format:

1. Load the desired communication format, see Saving, Loading and Deleting Formats
in the User Manual.

2. Select File > Print from the menu.

3. Choose Print Overview to print an overview, or print One  page per info area.

4. Select the details to be included in the printout from the Output pane: The
Conditions defined in the communication format, the Match-up Control settings
and the defined Field Properties.

5. Click on OK.

109AUREA CONFIDENTIAL

Configuring Communication

https://help.aurea.com/crm/crm-win-user-manual/crm-win-user-manual/dita/topics/c_win_UsrMan-4_11_1-Saving-Loading-and-_upd.html


Distribution Logic
Use the Distribution Logic info area to define conditions used to output records
to a specific station.

These conditions and output conditions in the communication format can be combined
using a logical AND or OR, see Combining Communication Formats and Distribution
Logic on page 112.

AND use case: You can define a general communication format for multiple stations
and define conditions that differ between stations (e.g. applied to Rep fields) in the
Distribution Logic info area, see Defining the Distribution Logic.

OR use case: You can define that companies are only output for reps if the rep is
entered in the company record (communication format); but that all companies in a
group leaders area of responsibility (country, area or similar) are output (distribution
logic record using and OR link).

In contrast to communication formats, you can import distribution logic records,
making them easier to administrate.

Defining the Distribution Logic

To define a distribution logic record:

1. Switch to the desired target station in the Station info area.

2. Select Distribution Logic from the context menu.

3. Select the Info Area you wish to apply conditions to.

You need to add a record for each info area you wish to apply conditions to.

4. Select the name of the field you wish to apply a condition to from the Field Name
field.

5. Enter the condition in the Condition field, see Distribution Logic Conditions
Syntax.

Note: You can define conditions applied to multiple fields in a single distribution
logic record. Use the Field Name or Field Number fields to look up the field
numbers. The values selected in these fields are for your information only and
not used in any conditions.

6. Click on  (Save).
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In the above example, company records are only output to station 101 if John
Smith is entered in the Rep 1 field. This corresponds to defining the condition
Rep 1 = 'John Smith' in the Conditional Output cell in the communication format.

You can also define similar conditions using variable output conditions in the
communication format. For this to work, each station needs to be assigned to a
single rep (e.g. notebooks for field staff), see Applying Variable Conditions to the
Target Station.

Distribution Logic Conditions Syntax

Use the following syntax to define conditions in the Distribution Logic info area:

• F<Field Number> = 'Value', e.g. F132 = 'John Smith'.

Values that contain spaces must be enclosed in single quotes. If several values
are linked using AND/OR, the values must also be enclosed in single quotes.

• The following operators are supported:

=, >, <, <>, >=, =<, [] (included), ][ (not included).

Aurea CRM automatically ensures that a single space is present prior to and fol-
lowing operators when saving the record.

• You can use placeholders:

* represents any number of characters, ? represents a single character.

• Conditions can be combined using AND and OR, e. g. F5 = 'US' OR F5 = 'UK'.

• You can use brackets to group conditions, e.g. F5= 'US' AND (F7 > '90000' AND
F7 < '91000') for US companies with a postal code between 90000 and 91000.

• Use a point as the decimal separator (e.g. '3.1416').

• Format for date values: 'YYYYMMDD'

• Format for time values: 'HHMM'

• Format for Boolean fields: 'Y' = true; 'N' = false.

• Format for dependent catalog values: 'Catalog Value~Parent  Catalog Value',
e.g. 'Ink jet printer'~'Printer'.

• Syntax for tenant catalog values: 'Catalog Value{ {Tenant Number}}' e.g.
'Printer{{300}} for the "Printer" catalog value assigned to tenant 300, see Tenants
in the CRM.core Administrator Guide.

• Syntax for tenant numbers in dependent catalog values: 'Catalog Value{{Tenant
Number}}~Parent Catalog Value{{Tenant Number}}', e.g. 'Ink jet
printer{{300}}~Printer{{3}}' for the catalog value 'Ink jet printer' assigned to tenant
300, and whose parent catalog value is 'Printer' assigned to tenant 3.

Note:  If no tenant number is specified for catalog values in conditions, the catalog
value is searched for in the following order:

1. A matching catalog value with the same tenant number as is entered for the
communicating rep.

2. A matching catalog value with no tenant number.

3. No matching value. The search is terminated.
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• Syntax for external keys for variable catalog values: '#External Key', e.g. '#4711'
for catalog value 'Ink jet printer' with the external key '4711'.

• Syntax for fixed catalog values: 'Catalog Value~Code ', e.g. 'Day~1' for Monday.
These codes can be determined in the data model, see Editing Predefined Fixed
Catalogs in the CRM.core Administrator Guide.

Combining Communication Formats and Distribution
Logic
You can use a combination of communication formats and distribution logic to
minimize administrative overheads when making changes to communication settings.

Following settings can be used:

• Define a general communication format (e.g. for all field staff) which communicates
configuration settings and rep- and territory-independent data, see Communicating
System Tables on page 105 and Defining a Communication Format on page 90.

• Add distribution logic records for the laptops used by field staff. Use the distribution
logic records to distribute records based on companies, territories, sales group
etc., see Defining the Distribution Logic.

The output conditions in the communication format and distribution logic record are
combined using a logical AND by default (i.e. records are only output if the meet
both sets of conditions). Enable the Link with OR fields in the Distribution Logic
info area to change this behavior.

You can define bottom-up conditions, for example, using distribution logic records.
To do so, enter the desired bottom-up condition in the communication format and
define the condition applied to the dependent info area for each station in the Dis-
tribution Logic info area.

In this example, the following data should be output for all reps:

• all companies where the rep is entered in a sales group

• all these companies' dependent records

• the expenses records of the rep

• all ongoing activities

Define the following settings:

1. Switch to the C.Format info area.

2. Enable the Output and Input cells for all info areas by clicking on the column
header.

3. Click in the Conditional Output cell of the Marketing Activity info area.

4. Define the condition Status = 'In Progress'.

5. Click on OK.

6. Click in the Bottom-Up Condition cell of the Sales Group info area.
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7. Select the Company info area.

8. Click on OK.

9. Save the communication format.

10.Switch to the Station info area.

11.Add two distribution logic records for each of the desired stations (i.e. the
notebooks used by field staff), see Defining the Distribution Logic:

• For the Sales Group (SB) info area: F97 = '<Rep>' (determines that the
specified rep must be entered in the Rep 1 field)

• For the Expenses (B2) info area: F64 = '<Rep>' (determines that the specified
rep must be entered in the Rep field)

Communication Info Area
Use the Communication info area to define the communication connections between
stations.

You need to define a record for each direction in which data is communicated (i.e.
one record from station A to B, and one from B to A), see Defining Communication
Connections.

Use the Output and Input context menu entries to store the communication process,
see Star ting Communication on page 124.

Defining Communication Connections

To define a communication connection between two stations:

1. Switch to the Station info area in the Communication module.

2. Switch to the source station's record (e.g. the main office).

3. Open the Communication info area.

4. Click on  (New).
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5. Enter the number of the target station in the Dest . Stat. No. (in this case
notebook "NB 1" with station number 101).

6. Click in the Comm.Format field and select the desired communication format
(e.g. the communication format defined in Combining Communication Formats
and Distribution Logic on page 112).

7. The Output and Input check boxes are enabled by default. You can only star t
communicating using this connection from the command line or the Station info
area if the Output and Input check boxes are enabled.

Note: These settings do not affect communication from the Communication info
area (using the Output and Input buttons).

You can add separate communication records for input and output, if you wish to
use different communication formats for input and output.

8. Enable the Synchronization check box to synchronize the database on the target
station with the source station, see Synchronization on page 131.

9. Enable the E-mail check box if the stations should communicate via e-mail,
see Communicating via E-mail on page 128.

Note:  Only enable this check box once you have output the initial data stock
download(s), or use the – oe parameter to output the data stock downloads,
see mmco.exe Parameters on page 343.

10.Enter the number of days that the source station should wait for data from the
target station in the Reminder Cycle in Days field, see Reminder Cycle on page
151.

11.Enter the number of days that the source station should wait for a receipt
confirmation from the target station in the Days to Reception field, see Confirma-
tion on page 124. If this time period is exceeded, the communication process is
automatically repeated, see Automatically Repeating Communication.
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12.Use the Execution field to determine how companies, persons and properties
(BTB only) that are input should be matched up, see Match-Up Control on page
101.

• Manual/ Autom . (default): The type of match up is determined by the mode
of communication (manual or automatic). If communication is manual, records
are matched up manually; if communication is automatic, similar records are
written to SIM files.

• Manual: Data is matched up using manually.

Note: You cannot initiate "Manual" communication from the command line.

• Automatic: Records are not matched up manually. Similar records are saved
to a SIM file.

When communicating automatically, communication connections defined with the
execution type "Automatic" are used. If no such communication connection exists,
communication takes place using a communication connection defined as "Manu-
al/Autom.", see Automatic Communication on page 125.

13.Click on  in the E-mail Admin field and select a rep to send communication
logs to via e-mail, see Communication Logs on page 144. If no e-mail address is
entered for this rep, the logs are not sent.

14.Enable the E-mail (Error) and E-mail (Ok) fields to determine that logs should
also be sent if errors occur or the communication is successful respectively.

15.Save.

The main office (station number 1) can now output data to and receive data from
branch office "NB 1" (station number 101). The communication connection in the
opposite direction now also needs to be defined:

1. Switch to the target station's record in the Station info area (in this case notebook
"NB 1" with station number 101).

2. Define the connection to the main office (in this case station number 1).
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Note: The Synchronization check box does not need to be enabled for
communication connections from branch offices to the main office, as only data
on branch offices is synchronized, see Synchronization on page 131.

3. Click in the Comm.Format field and select the desired communication format. If
you choose a different communication format from the one used to communicate
in the other direction, data input on the target station may be restricted fur ther.

If you defined all input and output conditions in the communication format assigned
to the connection from the main office to the branch office, the other direction
only requires a communication format where the Output and Input cells are en-
abled for all info areas, as the data need not be filtered fur ther on the branch of-
fice.

4. Save.

Switch to the Overview tab to display a graphical overview of the connections you
have defined, see Overview Tab.

Overview Tab

The Overview tab in the Communication info area provides a graphical overview
of all communication connections defined from the currently selected station:

In this example, communication connections are defined from the main office to 3
notebooks:

• Synchronization is enabled for all 3 connections, see Synchronization on page
131.

• All 3 connections use the same communication format ("MAIN OFFICE to/from
Notebooks"). Data is then fur ther restricted using distribution logic records,
see Combining Communication Formats and Distribution Logic on page 112.

1. Right-click on the overview and select Vertical, Horizontal, Circular or Centered
to change the appearance of the overview.

Note:  If you define fur ther connections on the Communication tab, you need to
restar t the Communication module for these changes to be reflected in the overview.

The Station Overview info area displays a graphical overview of the connections
between all stations, see Station Overview on page 148.

116AUREA CONFIDENTIAL

Chapter 3: Communication



Data Stock Download
To initialize an empty database at a branch office, a data stock download needs to
be output on the main office and input on the branch office.

Prerequisites:

• Aurea CRM win must be installed on the branch office and a database connection
must be configured, see Installation Guide.

• The database on the branch office must be empty, see Troubleshooting on page
162.

To output a data stock download (e.g. for notebook "NB 1", station number 101)
and input it on the target station:

1. Define all the necessary communication settings on the main office (station number
1), see Configuring Communication on page 85.

Ensure that the communication format includes all data necessary to communicate
with the main office, see Communicating System Tables on page 105.

On the main office, define the reps that works on the branch office, see Defining
Reps in the CRM.core Administrator Guide. Add logins for these reps in the
Central Login Configuration info area, see Central Login Configuration in the
CRM.core Administrator Guide. Once the data stock download has been input on
the branch office, the reps can log on to the branch office and work with Aurea
CRM win.

2. Start the communication module with the following command line (see mmco.exe
Parameters on page 343):

mmco.exe -u com -p <Password> -k o,101,u

The Communication module is star ted and the \101\ directory (corresponding
to the branch office) is added to the data directory, see Directory Structure. The
communication file containing the data stock download is created and saved in
the \101\out directory, see File Names.

Note: You can output data stock downloads for several stations at once (-k o

,101,102,103,u). Use -k o ,u to create a data stock download for all stations
for which a communication connection exists. Use the --oe parameter to output
data stock downloads for stations that are configured to communicate via e-mail,
>> Communicating via E-mail on page 128.

3. Add the directory \1\in to the data directory on the branch office.

4. Transfer the communication file to this directory, see Transferring Communication
Files on page 122.

117AUREA CONFIDENTIAL

Configuring Communication

https://help.aurea.com/crm/crm-win-install-guide/crm-win-install-guide/dita/topics/c_win_install-1-webIntroduction_crm.html
https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-2_6_1-Defining-Reps_crm.html
https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-2_6_1-Defining-Reps_crm.html
https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-2_6_2-Central-Login-Config_crm.html


5. Start the Communication module with the following command line on the branch
office:

mmco.exe -u com -p <Password> -k i,1,+

6. The data stock download is input: System data (station numbers, catalog values,
formats, languages, stations, reps etc.) is input first, then customer data.

Once the input is complete, the branch office is ready for operation.

All communication sessions are logged in the Communication Logs info area,
see Communication Logs on page 144.

Changes to data can now be communicated automatically, see Communication
Steps on page 120.

Note: The access rights defined in the Rights module are ignored when
communicating, see Rights and Communication in the CRM.core Administrator
Guide.

Directory Structure

The first time you output communication on a station, several directories are added
to the data directory.

Example: The main office (station number 1) outputs data to notebook "NB 1"
(station number 101). The following directories are automatically added to the data
directory on the main office:
101 \del

\err
\in
\out
\sim

del : Currently no function.

err : If input is canceled due to an error, the communication file that caused the
error is saved in this directory, see Failed Communication Sessions on page 163.

in : Communication files from "NB 1" (station 101) that should be input on the main
office (station 1) must be copied to this directory, see Communication Steps on
page 120.

out : Communication files for "NB 1" (101) are output to this directory.

sim : Log files generated when using the match-up options No. Similar -> Log,
Name/Address Similar -> Log and ->Log are stored in this directory, see Match-
up Types on page 103.

Before you can input data on the target station, you need to add an in directory to
the corresponding source station's directory (e.g. in this case \1\in).

The communication file output on the main office to the directory \101\out must
be copied to the \1\in directory on "NB 1" and vice versa:
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File Names

• Communication files are named according to the output date with a serial number
(star ting from 0) appended: For example, 20090331.1 is the second communica-
tion file output on 31 March 2009.

Communication files are saved using the extension .part until the output is
complete (these are known as "temporary communication files").

• Notification files, created each time files are input, are named as follows:
N0000143.2 is the 143rd Notification created by a station confirming the receipt
of the 2nd communication file received on this day on this station, see Confirmation
on page 124.

• Log files generated when using the match-up options No . Similar -> Log,
Name/Address Similar -> Log and ->Log are named as follows: sim.0, sim.1
etc., >> Match-up Types on page 103 and Inputting SIM files.

Quick Mode

If large amounts of data need to be available on offline stations, the time needed
to create initial data stock download files for all stations may increase to more than
a day.

To shorten the duration of outputting and inputting initial data stock download files,
add the following setting to the global mm.ini file:
[Communication]
FastLoad=*

To create initial data stock download files for specific stations, specify the station
numbers:
FastLoad=1000,1001,...

Using this entry shortens the time needed for outputting the communication files.
Inputting these tuned files on the target stations also needs less time.

Note: The actually achievable gain of time depends on the environment and amount
of data.

Please note the following restrictions:

• No other process must be active while inputting the communication file on the
target station.

• Calculations are copied "as is": Info areas where calculations done by the business
logic occur (e.g. all offer items for an offer) cannot be exported conditionally, i.e.
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the communication format must not contain output conditions on info areas that
are children of FI, KP or OJ (BTB only) and in which calculations occur.

• If a specially tuned file is input, the new quick input method is used only if the
target database is empty (i.e. at least FI, KP and OJ (BTB only) must be empty)
and if the + parameter is used (mmco.exe -u com -p <Password> -k i ,1 ,+).

Communication Steps
Once a branch office has been initialized using a data stock download, the branch
office can communicate with the main office.

The communication process involves the following steps:

• The main office inputs changes received from branch offices (see Input on page
122).

• The main office outputs changes for branch offices (see Output on page 121). The
communication files are transferred to the branch offices (see Transferring Com-
munication Files on page 122).

• The branch offices each input the changes received from the main office
(see Input on page 122).

• The branch offices output changes made to data on the branch offices for the
main office. These communication files are transferred to the main office.

• The main office inputs changes received from the branch offices etc.

Note: You can communicate with a maximum of 1,000 stations in a single
communication session.

Communication processes can be completely asynchronous: data stored in the
Communication module determines which data needs to be output in the next
communication session, see Output on page 121.

Communication logs are created each time data is input or output, see Communica-
tion Logs on page 144. The logs also include information on whether output commu-
nication files are input successfully (see Confirmation on page 124), whether records
are missing (see Synchronization on page 131) and whether the output needs to be
repeated (see Troubleshooting on page 162).

Note: The access rights defined in the Rights module are ignored when
communicating, see Rights and Communication in the CRM.core Administrator
Guide. Consequently, no triggers are initiated when inputting communication files,
see Database Events in the CRM.core Administrator Guide.
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Output
Once a data stock download has been input on a branch office, only changes to
data (new, edited and deleted records) since the last communication session are
communicated.

This delta information is determined from the following:

• The Station info area stores the following information for each station:

• The date, time and success of the last input and output (Comm. Overview tab),
see Comm. Overview Tab.

• The ID of the last catalog maintenance record communicated to the station
(Cat. Maintenance tab), see Communicating Catalogs on page 139.

• The date on which deleted records are last communicated (Delete tab),
see Communicating Deleted Records on page 137.

• The date of the last synchronization (Synchronization tab), see Synchronization
on page 131.

• The date and time of communication logs for output files are used to determine
which changes have occurred in the database since the last communication file
is output, see Communication Logs on page 144.

• System fields in each record store information on when, where and by whom the
record is added or edited, and whether the record has yet been communicated,
see System Fields in the CRM.core Administrator Guide.

Star t the output as described in Star ting Communication on page 124.

Comm. Overview Tab

The date, time and success of the last input and output is stored for each station
that communicates with the current station on the Comm. Overview tab in the
Station info area.

For example, the station record for "NB 1" (station number 101) on the main office
could be similar to the following:
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The main office last output data to "NB 1" on 11/02/2010 at 12:04:00. The output is
successful.

The main office last input data from "NB 1" on 11/02/2010 at 12:03:57. The input is
successful.

Transferring Communication Files
Once output, communication files need to be transferred to the target stations.

You can transfer the files over a network (LAN, FTP, e-mail (MAPI) etc.) or use ex-
ternal media. Note that additional settings are required in Aurea CRM to be able to
communicate via e-mail (MAPI), see Communicating via E-mail on page 128.

Ensure that the communication files are copied to the correct in directories on the
target station (see Directory Structure):

Delete the communication files from the out directory once the file has been
transferred to ensure that the same file is not inadvertently communicated and input
twice.

Input
Learn about the input step of communication.

Inputting communication files on a branch office

1. Transfer the communication files to the directory \<source station num-
ber>\in on the target station, see Transferring Communication Files on page
122.

2. Start the input, see Star ting Communication on page 124.

3. Data is input in the following order:

a. The data model, if it has changed, see Communicating Data Model Changes
in the CRM.core Administrator Guide.

b. Catalog maintenance records missing on the branch office (based on the entry
in the (In. ) Cat.Maint . ID field in the station record), see Communicating
Catalogs on page 139.

c. All other data as determined by the communication format.

The input records are matched up with the records in the local database, see
Match-up.

4. If the communication format has changes since the last synchronization, a
synchronization request is output, see Synchronization on page 131.
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5. If records are to be deleted according to the delete cycle, they are now deleted,
see Communicating Deleted Records on page 137.

6. Once the input is complete, a notification file is output which must be input on
the source station to complete the communication cycle, see Confirmation on
page 124.

Inputting communication files on the main office

1. Transfer the communication files to the directory \<source station num-
ber>\in on the target station, see Transferring Communication Files on page
122.

2. Start the input, see Star ting Communication on page 124.

The input records are matched up with the records in the local database,
see Match-up.

3. If a synchronization request is sent by the branch office, the requested records
are output in a separate communication file, see Synchronization on page 131.

4. If records are to be deleted according to the delete cycle, they are now deleted,
see Communicating Deleted Records on page 137.

5. Once the input is complete, a notification file is output which must be input on
the source station to complete the communication cycle, see Confirmation on
page 124.

Note: When inputting values in combined date and time fields (type: "date,time"),
the values are converted to the station's local time zone (TIMEZONE entry in the
mmdb.ini file). Values in simple date or time fields are not converted, see Data
Model in the CRM.core Administrator Guide.Use mmba.exe –- writeDateTime to
output a list of all combined date and time fields, see mmba.exe Parameters in the
CRM.core Administrator Guide. To disable the automatic conversion of times, enter
v in mmdb.ini, see mmdb.ini and mmodbc.ini Files in the CRM.core Administrator
Guide.

Match-up

When inputting records from the source station, these records are matched up with
the records on the target station. By default, records are matched up using the pri-
mary key. If records with identical keys are found, the records are merged. If no
matching record is found, the record is added to the database.

Aurea CRM saves the modification date and time for each record and each field.
When merging records with identical primary keys, these time stamps and the set-
tings in the communication format determine which data is retained, see Conditional
Input on page 99 and Field Properties on page 99.

Select View > All Mask Fields and click on  (Show last change) to display these
time stamps for a record.

Use the Update priority configuration entry to prevent the contents of individual
fields from being overwritten by newer contents, see Communication in the CRM.core
Administrator Guide. This allows you to prevent data that is synchronized with ex-
ternal systems from being overwritten from data resulting from the communication
with branch offices, for example.
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You can define specific match-up settings for companies, persons and properties
(BTB only) in the communication format, see Match-Up Control on page 101. Aurea
recommends retaining the default settings (match up by primary key) for the Com-
pany, Person, Person in Company and Property (BTB only) info areas and to
subsequently merge any duplicate records in Aurea CRM's main module, see Man-
aging Companies and Persons in the Aurea CRM win User Manual.

Confirmation
One or more notification files are generated in the out directory whenever
communication files are input.

For fur ther details, see File Names.

These notification files must be transferred to the source station and input there to
confirm receipt of the communication file.

Once the notification file has been input on the source station, the Destination:
received and Destination: input check boxes in the communication logs are enabled
for the corresponding communication session, see Communication Logs on page
144.

If an error occurs while inputting data, only the Destination: received check box
is enabled and the corresponding error number is entered in the Destination: error
field, see Failed Communication Sessions on page 163.

Starting Communication
Learn how to star t communication from command line and from CRM Win.

You can star t communication as follows:

• From the command line, see mmco.exe Parameters on page 343, or automatically,
see Automatic Communication on page 125.

• From the Station info area in the Communication module:

1. Switch to the station record in the Station info area.

2. Select Input or Output from the context menu.

Doing so star ts communication with all stations that are configured to commu-
nicate with the current station (e.g. selecting Output on the main office creates
communication files for all branch offices that communicate with the main office),
see Manual Communication on page 129.

Note:  Aurea recommends that you always communicate with all stations. You
can only communicate via the command line or from the Station info area on
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those days for which communication is allowed (Com.Mon  – Com.Sun fields in
the Station info area), see Defining Stations.

• From the Communication info area in the Communication module:

1. Switch to the current station's record in the Station info area.

2. Switch to the desired record in the Communication info area.

3. Select Output or Input from the context menu.

This allows you to communicate with a single station, see Manual Communica-
tion on page 129.

Note:  Stations can only communicate if a communication connection is defined
between the stations, see Communication Info Area on page 113.

Automatic Communication
Once a branch office has been initialized using a data stock download, the branch
office can communicate with the main office automatically.

To use automatic communication without manual match-up requires:

• Always use the COM user to prevent concurrent communication sessions from
overwriting data.

If you use the SU for automatic communication, you need to use the option q
(mmco.exe -u su -p <Password> -k o,q ), see mmco.exe Parameters on page
343. Otherwise you are prompted to register your license and the communication
process is canceled.

• Use communication formats that require no user interaction:

• Disable Change control, see Field Properties on page 99.

• If you have customized the match-up behavior (default is match up by primary
key, see Match-up), you need to enable the No manual control for each
match-up line you define for the line to be applied, see Match-Up Control on
page 101. Use match-up settings that log similar records, see Automatic Com-
munication with SIM Files on page 129.

Note:  Use the m and k parameters to communicate automatically with manual
control. Messages are output, changes can be verified manually and records can
be matched up manually, see Communication with Change Control and Commu-
nication with Manual Match-up.
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• Select Automatic or Manual/ Autom . as the Execution type (Communication
info area) in communication connections that should support automatic
communication, see Defining Communication Connections.

• Star t automatic communication sessions from the command line, see mmco.exe
Parameters on page 343 and Automatic Communication Examples on page 126.

Use batch files that star t mmco.exe with the desired parameters and transfer
communication files to where they can be accessed by the target station.

• Use time-controlled software (e.g. Windows' Task Planner) to star t communication
automatically.

• You can automate the transfer of communication files with update.transfer 2.0.

Automatic Communication Examples
An Example of automatic communication.

3 notebooks (101, 102, 103) communicate with the main office (1):

A data stock download has been input on all 3 notebooks. Automatic communication
between the stations could be implemented as follows:

Outputting communication files on the branch offices

The output on each of the branch offices (101, 102, 103) is star ted using the follow-
ing command line (>> mmco.exe Parameters on page 343):
mmco.exe -u com -p <Password> -k o,1 -c x:\move_com_files.bat

• The Communication module (mmco.exe) is star ted using the COM user (-u, -
p).

• Changes to data are output for the main office (1), see Output on page 121. The
communication files are written to the 1\out\ directory on each branch office.

• A batch file is used to transfer the communication files to a repository where the
main office retrieves the files, see Transferring Communication Files on page 122.

Inputting communication files on the main office

The communication files from the branch offices need to be moved to the correspond-
ing in directories on the main office:

..\101\in\20090907.0 etc.
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..\102\in\...

..\103\in\...

Input the communication files using the following command line:
mmco.exe -u com -p <Password> -k i

,101,102,103,l

• The Communication module (mmco.exe) is star ted using the COM user (-u, -
p).

• The communication files from stations 101, 102 and 103 are input (i),
>> Transferring Communication Files on page 122.

Note:  If you do not explicitly specify station number, available communication
files are input for all stations for which a communication connection exists.

• Records marked as deleted are deleted (l), see Communicating Deleted Records
on page 137.

Communication files that are input successfully are automatically deleted from the
in directories.

A notification file is output to the corresponding out directories (\101\out etc.),
>> Confirmation on page 124.

Output communication files on the main office

Output the communication files using the following command line:
mmco.exe -u com -p <Password> -k o,101,102,103 -c x:\move_com_files.bat

• The Communication module (mmco.exe) is star ted using the COM user (-u, -
p).

• The communication files are output for stations 101, 102 and 103 (o), >> Output
on page 121.

Note:  Use the parameter -k o to output communication files for all stations for
which a communication connection exists.

• The communication files are written to the following directories:

..\101\out

..\102\out

..\103\out

• A batch file is used to transfer the communication files to a repository where the
branch offices retrieve the files, >> Transferring Communication Files on page
122.

Note: You cam combine input and output operations:
mmco.exe -u su -p <Password> -k i,l -k o
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The station inputs communication files from all connected stations (i). Records
marked as deleted are automatically deleted in the process (l). The station then
outputs communication files for all connected stations (o).

Input communication files on the branch offices

The communication files and notification files need to be transferred to the \1\in
directory on the branch offices.

The input is star ted using the following command line:
mmco.exe -u com -p <Password> -k i,1,l

• The Communication module (mmco.exe) is star ted using the COM user (-u, -
p).

• The communication files from the main office (1) are input (i), see Input on page
122.

• Records marked as deleted are deleted (l), see Communicating Deleted Records
on page 137.

• The information in the notification files is entered in the corresponding
communication logs records, see Confirmation on page 124.

Communication files that are input successfully are automatically deleted from the
in directories.

A notification file is written to the main office's out directory (\1\out).

Communicating via E-mail
You can send communication files using an e-mail client that supports MAPI.

The communication files are sent via e-mail. The receiving station identifies the
files and inputs them automatically.

Prerequisites for communication via e-mail:

• Enter the corresponding e-mail address of the communicating stations in the
station records (E-mail addr . field on the Address tab), see Defining Stations.

• Enable the E-mail check box for the corresponding communication connections
in the Communication info area, see Defining Communication Connections.

Note:  Only enable the E-mail check box once you have output the initial data
stock download(s), or use the – oe parameter to output data stock downloads,
see mmco.exe Parameters on page 343.

• If communication should be time-controlled (without any manual interaction), you
need to define a settings that can be used by Aurea CRM to log on to the e-mail
client. These settings depend on your e-mail client and version of Aurea CRM.
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For fur ther information, contact Aurea's support, see Aurea Global Support topic
in the Introduction on page 9.

• You need to define a default profile that can be used by Aurea CRM to log on to
your e-mail client.

Note:  Errors that occur when communicating via MAPI are logged in the System
Event info area, see System Event Info Area in the CRM.core Administrator Guide.

Automatic Communication with SIM Files
If you are using match-up settings that deviate from the default (match up by primary
key) and wish to communicate automatically, use match-up settings that log similar
records, and enable the No manual control option for each line in the match-up
settings.

For fur ther details, see Match-Up Control on page 101.

When inputting communication files, a log file containing similar records is written
to the sim directory, for example to \1\sim\sim.0, sim.1 etc. on the main office
(station number 1).

These sim files need to be input manually (using a communication format with
manual match-up), see Inputting SIM files.

Note:  Input the sim files before the next automatic input.

Manual Communication
Leanr about manual communication in Win CRM.

Use manual communication:

• With communication formats where the Change control option is enabled,
see Field Properties on page 99 and Communication with Change Control.

• If you want to match up records manually, see Match-Up Control on page 101 and
Communication with Manual Match-up.

• To input sim files, see Inputting SIM files.

Prerequisites for manual communication:

• Select Manual or Manual/ Autom . as the Execution type (Communication info
area) in communication connections that should support manual communication,
see Defining Communication Connections.

• If you are deviating from the default match-up behavior (match up by primary key,
see Match-Up Control on page 101), ensure that the No manual control option is
disabled if you want to match up records manually, see Match-Up Control on page
101 and Communication with Manual Match-up.
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Start the manual communication session from the Communication or Station info
areas, see Star ting Communication on page 124.

Communication with Change Control

If you input using a communication format where the Change control option is en-
abled (see Field Properties on page 99), a dialog is displayed for each change to
a field's contents:

Disable the Upd cell to prevent a change from being applied to the local database.

Click  (OK) to continue inputting the communication file.

Click  (Cancel) to cancel the input process. The communication file is retained
in the in directory and can be input at a later time.

Communication with Manual Match-up

If Aurea CRM finds a similar company (according to the match -up settings) when
inputting data, the Match-up info area is opened:

Compare the external record (mask) with the internal records (list):

• Click External Mask or Internal Mask to display all fields in the external or
internal record.

• Use the Name and Address buttons to display records with similar names or
addresses.

• Select a record in the list and click on  (Found) to merge the external record
with the selected record.

• Click on  (Not Found) to add the external record as a new record. (If you are
using the No. Found -> Compare Name/ Addr . match-up option, the record is
rejected as false instead of being added.)

• Click on  (Cancel) to cancel the match-up process.
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Inputting SIM files

Similar records that are logged as a result of automatic communication (No. Similar
-> Log, Name/Address Similar->Log, ->Log options) must be input and matched
up manually, see Automatic Communication with SIM Files on page 129.

1. Transfer the SIM files to the corresponding in directory. For example, if records
from a branch office (station 101) have been logged on the main office (station
1), they need to be transferred from the \1\sim directory to the \101\in
directory.

2. Switch to the corresponding communication connection in the Communication
info area, see Manual Communication on page 129.

3. Select Input from the context menu.

4. Match up the records as described in Communication with Manual Match-up.

Note:  Input the sim files before the next automatic input.

Synchronization
The synchronization function regularly verifies that data stored on branch offices is
complete.

The system checks that the branch office's database contains all the required
companies, persons etc. and whether data needs to be deleted or requested. Syn-
chronization takes place automatically at fixed intervals (Sync.Cycle ( Days) field
in the Station info area) within the scope of "normal" communication.

Independent info areas are synchronized if output conditions are applied to the info
area in the communication format, see Configuring Synchronization on page 132.
(Info areas used to manage stocks are subject to additional requirements,
see Synchronization and Stocks on page 136).

The Stock Control info area (OTC) requires all stock-related data to be present on
branch offices to correctly track the inventory. For this reason, records (e.g. compa-
nies) linked to stock-relevant data are not deleted when synchronizing.

Synchronization is required:

• if field contents are edited on the main office, and these fields are used as the
basis for conditions defined in communication formats or distribution logic records

• if communication formats or distribution logic records are edited

Field changes

If the communication format contains the condition "Company, Rep = Smith", com-
panies are only output to stations using the communication format where "Smith"
is entered in the Rep field.

If the entry in the Rep field is changed from "Smith" to another rep, changes to these
records are no longer communicated to branch offices.
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Synchronization ensures that these records are nonetheless updated. Otherwise
you would need to completely delete the database on the branch office and input a
new data stock download to update the records.

Edited communication format

A communication format could be extended so as to communicate additional records
to a station, e.g. the condition "Company, Rep = Jones" is added to the format and
combined with the condition "Company, Rep = Smith" using a logical OR.

Company records that fulfill the condition "Rep = Jones" added before the commu-
nication format is changed can only be communicated to branch offices using the
synchronization function.

Without synchronization, only newly added records and field changes would be
output in the next communication session.

Configuring Synchronization
Learn how to configure synchronization.

To configure synchronization:

1. Start the Communication module, see Star ting Modules on page 13.

2. Switch to the main office's record in the Station info area.

3. Switch to the Communication info area, see Defining Communication Connections.

4. Enable the Synchronization check box for the desired connections.

Note:  Branch offices area always synchronized by the station directly above
them in the communication hierarchy. The Synchronization check box must
always be enabled for connections to branch offices, but not in the opposite
direction.

5. Enter the synchronization interval in the Sync.Cycle ( Days) field on the
Synchronization tab in the station records corresponding to the branch offices
(e.g. every 28 days), see Defining Stations.

If you do not specify an interval, synchronization occurs with each communication
session.

6. Define conditions in the communication format that should be applied to the info
areas to be synchronized, see Defining a Communication Format on page 90.

You can use dummy conditions (e.g. New <> <empty>, which is always true) to
determine that info areas only restricted using distribution logic records should
also be synchronized, see Distribution Logic on page 110.
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Synchronization Process
In the following example, only companies in Germany are output to a branch office.
The communication format is subsequently updated so that companies in both
Germany and Switzerland should now be communicated to the branch office.

The next synchronization takes place according to values in the Sync.Date and
Sync.Cycle ( Days) fields in the branch office's record on the main office (or the
branch office's immediate parent).

Note: The Sync.Date is not entered on branch offices.

Synchronization occurs whenever a station communicates and the synchronization
cycle has been exceeded:

1. The communication format output by the main office also includes synchronization
data containing the keys of all records that should be present on the branch office
according to the communication format in addition to the normal communication
data.

The synchronization data and the number of records to synchronize are written
to the communication logs, see Communication Logs on page 144.

2. The communication file is input on the branch office. The "normal" communication
data is input first, followed by the synchronization data. (In this example, 10
companies should be present on the branch office.)
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The keys output by the main office are compared to the keys on the target station:
Records that should not be present on the target station according to the synchro-
nization data are deleted immediately, see Deleting Records when Synchronizing.

3. A communication file is output which includes a synchronization request for
those records missing on the branch office. (In this example, the 3 missing Swiss
companies are requested.)

4. Transfer the communication file to the main office, see Transferring Communication
Files on page 122.

5. The synchronization request is received by the main office when this
communication file is input:

6. The missing records (and their dependent records) are automatically output by
the main office:
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7. Transfer the communication file to the branch office.

8. Input the communication file including the requested records on the branch office:

Synchronizing the branch office is now complete.

Deleting Records when Synchronizing

When synchronizing, the keys in the synchronization data are compared to the keys
in the database on the branch office. All records whose keys are not included in the
synchronization information are deleted from the database. Dependent records are
also deleted. These records are only deleted on the branch office; no delete codes
are set, see Communicating Deleted Records on page 137.

The following security mechanism is in place to handle records added on the branch
office that meet the communication conditions but are not yet present on the main
office:

• Records that have not yet been communicated (the CmCd field is disabled) are
not deleted.

• If records have been communicated, the system checks when they are last
communicated to the main office (Date, Time and Status of the last output log
on the branch office, see Communication Logs on page 144): The record is only
deleted if it has not been updated on the branch office since the last
communication session.
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Exceptions:

• The change or addition cannot have taken place on the same day as the
synchronization is input.These records cannot be deleted by the synchronization
process.

• The change takes place after the system checks for deleted record, as a result
of inputting data from another station (in a multi-tier communication setup).
These records are not deleted by the synchronization process.

Redundant or outdated data on branch offices can be deleted via synchronization
by using input conditions, see Synchronizing using Input Conditions on page 136.

Synchronizing using Input Conditions
When synchronizing data using output conditions, dependent records can be retained
on branch offices that should no longer be present according to the communication
format.

Use the Synchronization option in the communication format to determine (per info
area) that data at branch offices should be synchronized based on the input condi-
tions to remove these redundant records.

1. Define an input condition in the communication format for the branch offices. For
example, no activities should be input that are older than 3 months, see Condi-
tional Input on page 99.

2. Enable the Synchronization cell for the Activity info area.

3. Save the communication format and assign it to the desired communication
connection(s), see Defining Communication Connections.

4. Enable the Synchronization field in the communication connection(s).

Synchronization takes place at predefined intervals (value in the Sync.Cycle ( Days)
field defined for the target station).

The branch office only inputs records that meet the input conditions. Records on
the branch office that do not meet the input conditions are automatically deleted
during the input process. Records added on the target station that do not meet the
input conditions are automatically deleted the next time data is input.

Synchronization and Stocks
Aurea CRM's stock management features () require all stock-relevant data to be
present locally on all branch offices to track stocks correctly.

For details on stock management, see Inventory Management in the Business Logic
Manuals.
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This is taken into account when synchronizing:

• Orders (BTB, OTC), material orders (FS), Refunds (OTC) etc. are only deleted
by the synchronization process if stocktaking has been performed.

• Companies and persons for which stock-relevant records exist (i.e. orders etc.
that have not been subject to stocktaking) are not deleted by the synchronization
process.

You can disable this behavior using the No Inventory configuration entry,
see Communication in the CRM.core Administrator Guide. If this configuration
entry is active, data that directly affects stocks is also deleted during synchronization.

Alternatively, you can completely disable stock management by locking the "Inven-
tory Management" process (see CRM Process Configuration in the CRM.core Ad-
ministrator Guide). This is the approach recommended by Aurea.

Communicating Deleted Records
Learn how to delete records on stations that do not communicate.

If a station does not communicate with any other stations, records are deleted im-
mediately. Child records are also deleted immediately.

Exceptions:

• The station number has been changed: The Added on StNo . field (number of
the station the record is added on) in the deleted record does not match the station
number. In this case, the delete code (DelCd field) is enabled and the record is
not deleted physically, as with communicating stations (see below).

• A value has been entered or imported into the CmCd field (communication code)
of the record: The record is treated as having been communicated. The delete
code (DelCd field) is enabled and the record is not deleted physically.

If you enable the Do Not Communicate Deleted Records option in the Delete info
area (Maintenance module), records are deleted physically. Records are always
deleted without setting the delete code, even if the CmCd field in the record is en-
abled, or a station other than the current station number is entered in the Added
on StNo . field.

Deleting records on stations that communicate

On stations that communicate with other stations, records that have already been
communicated (CmCd field enabled) are not deleted physically, but instead the
delete code (DelCd field) is enabled. Child records are deleted immediately.

The delete codes are then communicated to other stations as part of the next com-
munication session. Dependent records are also deleted immediately on these sta-
tions.

Once the delete code has been communicated to all stations and the stations have
confirmed receiving the record, the record is deleted on the main office, see Deleting
Records Automatically.
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If you want to prevent companies, persons and properties (BTB only) from being
deleted when communicating, enable the Deny Deletions > By  external option in
the match-up control settings, see Match-Up Control on page 101.

Select Data > Display Deleted Records from the menu to display all records marked
as deleted.

If the record has not yet been communicated, you can undelete the record by disabled
the DelCd field in the record.

Disabling the DelCd field does not restore identical records marked for deletion on
branch offices. Manually restoring records by changing the delete code can therefore
lead to inconsistent data. A record can be present on one station, whilst marked for
deletion or even physically deleted on another.

Note:  Under no circumstances should records be deleted by enabling the DelCd
field manually.

You can change the default behavior and determine that records are never deleted
physically for specific info areas in the access rights (Mark as Deleted column).
Instead of deleting the affected records, the delete code (DelCd field) is enabled
in the record and the records are retained in the database even after communicating.

Deleting Records Automatically

The delete cycle determines when records are physically deleted on a station.

Define the delete cycle for each station on the Delete tab in the Station info area
(see Defining Stations):

• Delete Automatically: Enable this check box to automatically (physically) delete
records marked as deleted from the local database after the time period entered
in the Delete Cycle in Days field has expired.

• Delete Cycle In  Days: Once the time period entered here has expired (default:
7), records marked as deleted are deleted the next time records are communicated
on this station.

• Last Delete after Cycle: The data on which records are last deleted is
automatically entered here.

Records are deleted as follows:

1. A record is deleted on a station, the DelCd field is enabled.

2. The record is communicated to the other stations.

3. A delete prompt is displayed when star ting the Communication module on
communicating stations at the time determined by the entries in the Delete Cycle
in Days and Last Delete after Cycle.

4. Answer the prompt with Yes to physically delete all records marked as deleted
on this station (branch office).
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Note:  Always use the –l option when communicating automatically to ensure
that the prompt is automatically confirmed, see mmco.exe Parameters on page
343 and Automatic Communication on page 125.

5. A record marked as deleted is only deleted on the main office once it has been
physically deleted on all branch offices.

Communication logs from the last 12 months are used to determine whether the
record can be deleted on the main office. If no receipt confirmation is received,
the record is not deleted.

If a branch office confirms the receipt of a (new) data stock download, all prior
communication logs for this branch office are ignored.

Deleting Logins on Branch Offices

Logins configured at the main office and communicated to branch offices cannot be
deleted using the delete code as this does not delete the login record (Login (US)
info area) on the branch office.

To delete logins on branch offices from the main office:

1. Switch to the desired record in the Central Login Configuration info area.

2. Delete the record.

3. Add a new record for the rep with the same login name.

4. Enable the Remove login check box on the Password tab.

5. Save.

6. The next time the main office communicates with the branch office the
corresponding login record is deleted.

Communicating Catalogs
Learn about the fixed and variable catalogs.

Fixed catalogs are part of the data model and are therefore communicated automat-
ically, see Communicating Data Model Changes in the CRM.core Administrator
Guide.

Variable catalogs are stored in the Catalog info area, see Catalog Info Area in the
CRM.core Administrator Guide. Catalog values can be added, edited and deleted
in the Catalog info are, see Editing Variable Catalogs in the CRM.core Administra-
tor Guide.

Changes to catalogs are stored in the Catalog Maintenance info area on the catalog
maintenance station and are automatically transferred to other stations during
communication, see Automatic Catalog Maintenance on page 140. The Catalog
Maintenance info area is not updated on all other stations.

Note:  Aurea recommends that you never add catalog values to the database directly,
and that you prevent users from editing and deleting catalog values on all stations
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other than the catalog maintenance station, see Defining Access Rights for Variable
Catalogs in the CRM.core Administrator Guide.

If your communication hierarchy includes multiple tiers, stations on the second tier
communicate catalog maintenance data to stations on the third tier etc.

When communicating, catalog values are matched up using the catalog value in the
catalog base language and the tenant number. If catalog values can also be added
on branch offices, new entries are communicated to the catalog maintenance station
using the Catalog info area. The catalog maintenance station then communicates
the changes to all other stations using the Catalog Maintenance info area.

Automatic Catalog Maintenance
The current status of catalogs is logged on the Cat. Maintenance tab in the Station
info area for each station.

The system determines which catalog maintenance records need to be communicated
to each station based on the entries in the (Ext. ) Cat.Maint . ID, (Ext. ) Cat.Maint
. Date and (Ext. ) Cat.Maint . Time fields.

Note:  If this information is missing for a station, all catalog maintenance records
are output the next time communication is initiated.

In this example, a few catalog values in the Catalog info area on the catalog main-
tenance station are edited (in this example the main office with station number 1):

1. Start the Maintenance module on the catalog maintenance station, see Star ting
Modules on page 13.

2. Switch to the Catalog info area, see Catalog Info Area in the CRM.core
Administrator Guide.

3. Edit a few catalog values. (In this example, a value is added to the Country
catalog, while an existing entry is edited and another deleted.)

Corresponding records are added to the Catalog Maintenance info area:

KW Re-
placed

KW TextKW Modifi-
cation

KW Cat. No.KW CatalogKW ID

SpainN2Country11

USAUnited
States

U2Country12

MoroccoL2Country13
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These changes are communicated to branch offices (in this example "NB 1", station
number 101) by the catalog maintenance station. The catalog maintenance process
is logged on the Cat. Maintenance tab in the Station info area.

1. Outputting on the Catalog Maintenance Station

The catalog changes are included in the next communication file generated by the
catalog maintenance station, see Output on page 121.

The Cat. Maintenance tab for stations 1 and 101 on the catalog maintenance station
contains the following data after outputting the communication file:

(In.)Cat.
Maint .
Time

(In.)Cat.
Maint .

Date

(In.)Cat.
Maint . ID

(Ext.)Cat.
Maint .
Time

(Ext.)Cat.
Maint .

Date

(Ext.)Cat.
Maint . ID

------1

--1012:17 (out-
put to 1)

16.2.201013101

2. Inputting on the Branch Office

The catalog changes are applied to the branch office when the communication file
is input, see Input on page 122. The catalog maintenance data is input first, and then
the normal communication data.

141AUREA CONFIDENTIAL

Communication Steps



The Cat. Maintenance tab for stations 1 and 101 on the branch office contains the
following data after inputting the communication file:

(In.)Cat.
Maint .
Time

(In.)Cat.
Maint .

Date

(In.)Cat.
Maint . ID

(Ext.)Cat.
Maint .
Time

(Ext.)Cat.
Maint .

Date

(Ext.)Cat.
Maint . ID

12:18 (in-
put to 101)

16.2.201013---1

------101

The notification file created when inputting the communication file confirms that the
catalog values have been updated on the branch office, >> Confirmation on page
124.

3. Outputting on the Branch Office

The contents of the Cat. Maintenance tab for stations 1 and 101 on the branch office
remain unchanged after outputting the communication file.

4. Inputting on the Catalog Maintenance Station:

The notification file is input as par t of the next input process on the catalog mainte-
nance station, see Input on page 122.

The Cat. Maintenance tab for stations 1 and 101 on the catalog maintenance station
contains the following data after inputting the communication file:

(In.)Cat.
Maint .
Time

(In.)Cat.
Maint .

Date

(In.)Cat.
Maint . ID

(Ext.)Cat.
Maint .
Time

(Ext.)Cat.
Maint .

Date

(Ext.)Cat.
Maint . ID

------1

--1312:17 (out-
put to 1)

16.2.201013101

Once the (Ext. )Cat . Maintenance ID is the same as the (In. )Cat . Maint . ID, the
catalogs on the branch office are up to date.

Note: The catalog maintenance station continues outputting catalog maintenance
records (i.e. each time the station communicates) until a notification file is received
confirming input on the other stations.

Catalog Maintenance and Data Stock Download
A data stock download only includes the most recent catalog maintenance record.

For fur ther details, see Data Stock Download on page 117.
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The ID of the last catalog maintenance record is sufficient to track the current status
of catalogs on branch offices in the corresponding station records. All catalog values
are output (Catalog info area).

You can use the w parameter to output all catalog values when communicating au-
tomatically ("catalog data stock download"), see mmco.exe Parameters on page 343.
If you output data for several stations, and data has not previously been output for
any of these stations (the corresponding fields are empty in the station records), a
catalog data stock download is created automatically, even if you do not specify the
w parameter.

Changing the Catalog Maintenance Station

To change the catalog maintenance station in a live system:

1. Ensure that the new catalog maintenance station contains up to date information
on catalogs and catalog maintenance records, see Automatic Catalog Maintenance
on page 140.

2. Disable the Aut.Cat.Maintenance check box in the station record of the old
catalog maintenance station, see Defining Stations.

3. Enable the Aut.Cat.Maintenance check box in the station record of the new
catalog maintenance station.

Communicating Multi-language Catalog values
New catalog values should always be added in the catalog base language on the
catalog maintenance station with translations entered in the corresponding columns.

For fur ther details, see Multi-Language Catalogs in the CRM.core Administrator
Guide.

If catalog values can also be added on other stations, they may not be added in the
base language on those stations and need to be translated into the catalog base
language on the catalog maintenance station.
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In the following example, "Suisse" is added in French to the Country catalog on a
branch office:

1. After inputting the communication file on the catalog maintenance station, the
catalog value is displayed in the catalog base language's column in the Catalog
info area:

2. Click on the catalog value.

3. Click on  (Edit) and enter "Switzerland".

4. Click on OK.

5. Select Apply Changes from the context menu to apply the change to all records
using this catalog value, see Applying Changes to Catalogs in the CRM.core
Administrator Guide.

6. Enter translations in the other columns, see Editing Variable Catalogs in the
CRM.core Administrator Guide.

The catalog value in all languages is communicated to branch offices the next time
the catalog maintenance station communicates, see Automatic Catalog Maintenance
on page 140.

Communication Logs
Communication logs are stored in the Communication Logs info area for each
communication session and import for each station.

To display the communication logs:

1. Switch to the desired station in the Station info area in the Communication
module.

2. Switch to the Communication Logs info area.

Communication logs are displayed for all communication sessions and imports
involving the selected station. Records in the Communication Logs info area
can only be deleted by the administrator (SU).

The communication logs contain information on the date, direction, communication
format, errors etc. for each communication session. The number of records input
or output is displayed for each info area in the table.
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Depending on the type of process (input, output, import), the table contains different
columns:

Output

If the Output check box is enabled, records are output to the target station (Stat.
No. field, in this case station 200) from the info areas listed in the Info Area column.

If synchronization information is output, "Synchronization" is displayed in the field
below Output, see Synchronization on page 131.

Out: Number of records output.

Synchronization: Number of records that meet the conditions defined in the com-
munication format, see Synchronization Process on page 133.

Base Date/Time: Time at which data is last output for the target station. All changes
since this point in time are output.

Input

If the Output check box is disabled, records are input from the source station (Stat.
No. field) in the info areas listed in the Info Area column.
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In: Number of records input.

New: Number of new records added.

Upd .: Number of updated records.

Delete: Number of deleted records.

False: Number of records rejected as false. The following records are rejected as
false:

• Dependent records for which no parent record exists on the target station.

• Records marked as deleted that are not already present on the target station.

Sim F: Number of records written to the SIM file, see Match-up Types on page 103.

Denied: Number of unprocessed records. Unprocessed records are:

• Records marked as deleted that are already marked as deleted on the target
station.

• Records that should not be input according to the communication format.

• After inputting changes to the data model ("new DM checked" is entered in the
Error field), the data model format is rejected during the actual input process.

Import

A communication logs record is also added when data is imported, see Logging the
Import/Export on page 82. In this case, "Import" is entered in the field below Output.
The import format is entered in the Format field and the import file is entered in the
File Name field.

Match: The number of records that are compared with existing data based on your
match-up settings. The number of records actually changed as a result is displayed
in the Upd column.

Result

The Result field (select View > All Mask Fields from the menu to access the field)
contains a summary of the communication logs and can be output in an XML report,
see XML Format in the User Manual.
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The following fields in the Communication Logs info area contain information on
the success or failure of the input/output procedure:

• File deleted: Boolean field. If true, the input file has been deleted. The
communication file is automatically deleted from the IN directory if the input
process is successful.

• If false, the input file is not deleted. The input process is terminated or the file
may be corrupt, see Troubleshooting on page 162.

• Error No.: Number of any error that occurred, see Communication Error Codes
in the CRM.core Administrator Guide.

• Error: A description of the error.

• Status: Status of the communication process (OK, Aborted, Error, Not relevant)

• Retry date: The date of the last retry.

• Retry no.: The number of times the system has retried outputting the file. The
output process is repeated until the number of days entered in the Days to
reception field in the Communication info area is exceeded, see Automatically
Repeating Communication.

• Destination: received: If this check box is enabled, the target station has received
the output file (receipt confirmation).

• Destination: input: If this check box is enabled, the target station has input the
output file (input confirmation).

• Destination: error: If an error occurred on the target station when inputting the
file, the error number is written to the output logs on the source station,
see Communication Error Codes in the CRM.core Administrator Guide.

Sending Communication Logs via E-mail

To send communication logs via e-mail:

1. Switch to the Communication info area.

2. Enable the E-mail (Error) and/or E-mail (Ok) fields for the desired connections
to send logs via e-mail if errors occur or the communication is successful.

3. Click on  (Rep List) for each connection, and select the rep that should receive
the logs. If no e-mail address is entered for this rep (in the Rep info area), the
logs are not sent.

Note: This function requires an e-mail client that supports MAPI.
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Station Overview
Stations and communication connections between stations are displayed graphically
in the Station Overview info area

1. Right-click on the overview and select Vertical, Horizontal, Pie Chart (Circular)
or Centered to change the appearance of the overview.

2. Select an entry from the Info: drop-down list (All Stations, Input/Output Date,
Reminder Cycle, Failure) to display the selected information.

Station Icons

The station that you are currently logged on to.

The main office.

 All other stations.

You can add stations and define new communication connections in the Station
Overview info area, see Adding Stations and Defining Communication Connections.
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All Stations
Select "All Stations" from the Info drop-down list in the Station Overview info area
to display all stations (including those for which no communication connections have
been defined).

The text displayed for the connections contains information on the connection:

• Station numbers of the communicating stations.

• Communication formats used.

• "E-mail" is displayed if communication is conducted via e-mail, see Communicating
via E-mail on page 128.

• "Synch" is displayed if synchronization is enabled, see Synchronization on page
131.

Double-click on the text to switch to the corresponding connection's record in the
Communication info area, see Communication Info Area on page 113.

Double-click on a station to switch to the corresponding station's record in the Station
info area, see Station on page 87.

Adding Stations

To define a new station in the Station Overview info area:

1. Click on  (New).

2. Select New Station.

The Station info area is opened in new mode.
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3. Add the new station, see Defining a Station in the CRM.core Administrator
Guide.

4. Save.

You are returned to the Station Overview info area and are asked if you want to
add a communication connection, see Defining Communication Connections.

Adding a Communication Connection

To define a new communication connection in the Station Overview info area:

1. Click on  (New).

2. Select New Communication.

The mouse cursor changes.

3. Click on the source station in the overview.

A line is drawn between the station and the mouse cursor.

4. Click on the desired target station.

The Communication info area is opened in new mode.

5. Add the communication connection, see Defining Communication Connections.

6. Save.

7. You are asked whether you wish to add a fur ther communication connection.

8. Define the connection in the opposite direction.

Input/Output Date
Select "Input/Output Date" from the Info drop-down list to display when the stations
for which a communication connection exists last communicated with one another.

The text displayed for the connections contains information on the connection:

• First line: Date on which data is last input from this station.

• Second line: Date on which data are last output to this station.

• "inp" or "ack" is displayed for output processes if the target station has received
the file or input it correctly.
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Double-click on a connection's text to display the communication session's log in
the Communication Logs info area, see Communication Logs on page 144.

Double-click on a station to switch to the corresponding station's record in the Station
info area.

Reminder Cycle
Select "Reminder Cycle" from the Info drop-down menu to display which stations
have exceeded the reminder cycle.

The reminder cycle interval is entered in the Reminder Cycle Field in Days in the
Communication info area, see Defining Communication Connections. A station
must communicate within the time period entered here.

The connection texts containing the following information:

• The time period defined in the Reminder Cycle in Days field for this connection.
If the station has communicated successfully within the defined time period, "ok"
is displayed.

• If the specified time period has been exceeded without communicating, the station
blinks and the date of the last input is displayed.

• If data has never been input from a specific station, the station blinks and "No
data" is displayed.

Double-click on a connection's text to display the last communication session's log
in the Communication Logs info area, see Communication Logs on page 144.

Double-click on a station to switch to the corresponding station's record in the Station
info area.
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Errors Encountered
Select "Errors encountered" from the Info drop-down list to display communication
errors.

The connection texts containing the following information:

• Date: If an error occurred in the last 4 weeks, the date the error occurred is
displayed and the station blinks.

• If no errors have occurred when communicating with a station, "ok" is displayed.

Double-click on a connection's text to switch to the corresponding communication
log, see Communication Logs on page 144.

Double-click on a station to switch to the corresponding station's record in the Station
info area.

Configuring Stations Automatically
You can largely automate the process of adding reps and their stations (offline
stations) so that local administrators can set up users and stations for Aurea CRM
web offline without requiring access to Aurea CRM win.

To do so, the following steps are required in Aurea CRM win:

1. Define communication formats used to communicate between the server and
offline station, see Communication Format on page 89.

2. Configure the server to automatically add new offline stations, see Configuring
the Offline Server on page 153.

3. Define station access rights for the offline stations and default values for the
Station, Central Login Configuration and Communication info areas,
see Defining Access Rights and Default Values on page 153.

4. Define the Z5 variable update_OfflineSyncDefinition, see Defining a Synchro-
nization Variable on page 154.

Enable the Offline user field in the Rep info area to trigger the automatic creation
of all necessary records required for the station (station, login, communication
connections), see Adding Offline Users on page 154.

152AUREA CONFIDENTIAL

Chapter 3: Communication



A data stock download is created the next time communication data is output,
see Configuring Offline Stations on page 161.

Configuring the Offline Server
Define the station number range for offline stations in the station record of the server
used to add and administrate offline users and stations.

To define station number range for offline stations, do the following:

1. Switch to the offline server in the Station info area.

2. Select View > All Mask Fields from the menu to display all fields and enter the
desired number range in the Offline Station No. from and Offline Station No.
to fields.

If you do not specify an upper limit, free station numbers up to 9,999 are assigned.

3. Save.

When automatically adding offline stations, the next free station number in the defined
number range is assigned to the new station, see Adding Offline Users on page 154.
If no station numbers are available, the process is canceled.

Further configuration is required on the server for Aurea CRM web offline users and
stations, see Aurea CRM web Offline Installation & Technical Guide.

Defining Access Rights and Default Values
Learn how to define access rights and set default vaklue for the rights.

Define access rights and default values for the branch offices:

1. Define station access rights for the branch offices containing the necessary
restrictions, see Defining Access Rights in the CRM.core Administrator Guide.

2. Define the necessary default values in the server’s station access rights
(see Default Values when Adding Records in the CRM.core Administrator Guide):

• for the Central Login Configuration info area:

1. Determine which modules should be available to offline users (e.g. Aurea
CRM and web).

2. Enter the server's station number in the Template (Station No.) field

3. Save the default values.

4. Click in the Central Login Configuration 's Create Default cell again.

5. Enable the Manage password globally check box.

• for the Station info area: Select the Station Access Rights defined in step 1.

• for the Communication info area: Select the communication format use to
communicate between the offline station and server in the Comm.Format
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field. If you have defined input conditions in the communication format used to
synchronize data (see Synchronizing using Input Conditions on page 136), you
also need to enable the Synchronization field.

3. Define any additional default values, triggers and workflows used to add records
in these info areas.

4. Save the access rights.

When automatically adding offline users, stations and communication connections,
corresponding records are added based on the defined default values, see Adding
Offline Users on page 154.

Defining a Synchronization Variable
Define the variable update_OfflineSyncDefinition in the Variable (Z5) info area
for the Comm.Format field in the Communication info area.

For fur ther details, see Variables in the CRM.core Administrator Guide. Define a
value that contains the name of the communication format used to communicate
between the server and offline station (Var. Text field).

The variable must be defined so as to be applicable by all users that can add offline
stations (e.g. a condition applied to the offline server’s station number).

When automatically adding offline users, stations and communication connections,
the communication format for the communication connection server -> offline station
is read from this variable, see Adding Offline Users on page 154.

Adding Offline Users
Learn how to ass an offline user and user's station.

To add an offline user and the user’s offline station:

1. Switch to the desired rep in the Rep info area.

2. Enable the Offline user field (select View > All Mask Fields from the menu to
access the field).

3. If no login record exists for the rep, you need to enter a User name (select View
> All Mask Fields from the menu).

4. Save the record.

5. Aurea CRM automatically adds the following records:

• A record in the Station (AS) info area for the new offline station:

If a station number is entered in the rep record (Offline Station No. field) and
this station already exists, the existing station record is used. Exceptions: Main
office, catalog maintenance station, current station, stations marked as deleted
and stations where another rep is entered.
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If a matching station is found, the offline user is entered as a rep and no new
station is added.

Otherwise a new station is added: The next free station number in the number
range is assigned to the new station, see Configuring the Offline Server on
page 153. The station number is entered in the Offline Station No. field in the
rep record.

If no station numbers are available, the process is canceled.

• One or more records in the Station Languages (01) info area, see Offline
Station Languages on page 160.

• Two communication connections in the Communication (C1) info area: server
-> offline station (communication format entered in the variable
"update_OfflineSyncDefinition") and offline station -> server (communication
format entered in the default values)

If one of the communication formats is missing, the corresponding record is
not added.

If a corresponding communication connection already exists, the Input and
Output fields in the record are enabled.

• If not already present (see above), a record is added to the Login (US) info
area using the User Name entered in the rep record.

• Two records in the Central Login Configuration (ES) info area: One for the
current station (server) and one for the offline station. The user name is taken
from the offline user's login and rep records (see above), see Default Values
and Fallback Values for Offline Users and Stations on page 156. The template's
station number and all other values are taken from the default values you have
defined, see Defining Access Rights and Default Values on page 153.

Note:  If a login record (US) already exists for the rep, the values (including empty
values) in this login record overwrite the default values when adding a new ES
record for the current station (server).

The domain and Windows user in the ES record for the offline station can be
edited despite a template station being defined (Template (Station No.) and op-
tionally Manage password globally), and the domain and Windows user are not
overwritten by the values in the main office's ES record if changes are made.

When adding records, the defined access rights are ignored with the exception
of the default values. The default values also apply to the SU in this context.

If corresponding records exist, no new records are added. Existing records are
not edited.

6. Aurea CRM enables the Initialize offline station in the offline user’s rep record.
This determines that a data stock download is automatically created for the offline
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station the next time data is output, see Configuring Offline Stations on page 161.
The field is automatically disabled once the output has taken place.

Note: When importing via CRM.cockpit, this function is ignored.

Default Values and Fallback Values for Offline Users and
Stations
This topic has the list default and fallback values for offline users and stations.

Changes in the offline user’s rep record (ID)

CommentFieldSource info
area

Field in Rep
info area

ID

Automatically
enabled when
the Offline user
field is en-
abled.

Initialize offline
station

116

Transferred
from the offline
station’s station
record (see be-
low).

Stat.No.ASOffline Station
No.

117

NameIDOffline station118

If no login
record is
present and no
value has manu-
ally been en-
tered in the
field in the rep
record, the pro-
cess is can-
celed.

user nameUSuser name119
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2 new central login configuration records (ES) for the offline user

CommentFieldSource info
area

Field in Cen-
tral Login Con-

figuration

ID

User nameUS, IDName9

New station record (AS) for the offline station

CommentFieldSource info
area

Field in Sta-
tion info area

ID

Generated auto-
matically based
on the number
range defined
for offline sta-
tions, see Con-
figuring the Of-
fline Server on
page 153.

Stat.No.0

DirectoryASDirectory1

Always left
empty

Main Office2

Always left
empty

Aut. Cat. Main-
tenance

3

NameIDStat. Name6

CountryIDCountry7

Postal CodeIDPostal Code8

CityIDCity9

StreetIDStreet10

Country CodeIDCountry Code11

Area CodeIDArea Code12

Tel 1IDTel 113
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CommentFieldSource info
area

Field in Sta-
tion info area

ID

Tel 2IDTel 214

FaxIDFax15

Com.MonASCom.Mon18

Com.TueASCom.Tue19

Com.WedASCom.Wed20

Com.ThuASCom.Thu21

Com.FriASCom.Fri22

Com.SatASCom.Sat23

Com.SunASCom.Sun24

Mon Time1ASMon Time125

Mon Time2ASMon Time226

Sun Time4ASSun Time452

Delete automat-
ically

ASDelete automat-
ically

70

Delete Cycle In
Days

ASDelete Cycle In
Days

71

Verify the tar-
get station’s
number

ASVerify the tar-
get station’s
number

80

Sync.Cy-
cle(Days)

ASSync.Cy-
cle(Days)

82

Sync.DateASSync.Date83

(Pas-
sive)Sync.Sta-
tion

AS(Pas-
sive)Sync.Sta-
tion

84
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CommentFieldSource info
area

Field in Sta-
tion info area

ID

(Pas-
sive)Sync.Date

AS(Pas-
sive)Sync.Date

85

E-mail 1IDE-mail addr.86

Desktop FormatASDesktop Format100

Search order:
default values
> ID > AS
> tenant access
rights

AS-TenNoID, ASAS-TenNo101

Default Tele-
phone Profile

IDDefault Tele-
phone Profile

105

Telephone Pro-
files

IDTelephone Pro-
files

106

Rep/Group IDIDRep ID109

Note: The data for the new station record is taken from the current station’s
station record or from the offline user’s rep record.

2 new communication connections (C1)

CommentsFieldSource info
area

Field in Com-
munication in-

fo area

ID

taken from the
source station’s
station record

Stat.No.ASSource Stat.
No.

0

taken from the
target station’s
station record

Stat.No.ASDest. Stat. No.1

Always "Manu-
al/Autom."

Execution3

Always enabledInput4

Always enabledOutput5
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CommentsFieldSource info
area

Field in Com-
munication in-

fo area

ID

Server -> offline
station: taken
from the vari-
able "update_Of-
flineSyncDefini-
tion", see Defin-
ing a Synchro-
nization Vari-
able on page
154.

Offline station -
> server: taken
from the default
values,
see Defining
Access Rights
and Default Val-
ues on page 153.

Comm.format6

Server -> offline
station: always
enabled

Synchronization7

E-mail 1IDE-mail8

Offline Station Languages
Learn about the languages generated when offline stations are automatically added.

When adding an offline station automatically, Aurea CRM generates the following
station languages (Station Language (01) info area):

• The language assigned to the rep (Language field in the Rep info area) and its
parent language (if applicable).

• The catalog base language.

• You can assign an additional language (and its parent language) to the station
using the "update_OfflineLanguageCopy" variable:

1. Define the variable "update_OfflineLanguageCopy" in the Variable info area
for the Language No. field in the Station Language info area, see Variables
in the CRM.core Administrator Guide.

2. Select Variable values from the context menu and define a variable value with
the desired language number (Var. Number/Catalog field). The variable must
be defined so that it applies to all users that may add offline stations (e.g. apply
a condition to the offline server's station number).
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The language is assigned to the offline station when automatically adding an
offline station.

Configuring Offline Stations
After automatically adding all necessary data, a data stock download is output the
next time data is output for the offline station (i.e. you can star t communication
without needing to specify the –u parameter).

The Initialize offline station check box in the offline user’s rep record is disabled
once the data is output. All subsequent outputs thus generates "normal" communi-
cation files.

Setting up the offline station for Aurea CRM win is then identical to the process
described in Data Stock Download on page 117.

When inputting a data stock download on the offline station, any existing data is
deleted before the input process begins. Any older communication files that are
present are also deleted.

Resetting existing offline stations

1. Enable the Initialize offline station in the offline user’s rep record. (The Offline
user field must also be enabled.)

When next outputting communication data for the station, a data stock download
is created.

2. Output data from the offline station to the server before inputting the data stock
download.

3. Input the data stock download. The database on the offline station is automatically
deleted in the process.

Disabling offline users

If the Offline user check box in a rep record is disabled or if such a rep is deleted,
the Output field in the corresponding communication connection (server -> offline
station) is disabled automatically. Data is no longer output for the station.

The Input field remains enabled to be able to input the offline station’s final data.

If a rep is set as Inactive, the Offline user field is also automatically disabled.
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Troubleshooting
Troubleshooting communication issues.

Problems with Data Stock Downloads
Troubleshooting data stock downloads issue.

Data Already Present on Target Station

When inputting a data stock download on a branch office, Aurea CRM checks whether
records are already present in the Company, Person in Company and Property
(BTB only) info areas.

• If no records are present, the data stock download is input as per usual, see Data
Stock Download on page 117.

• If records are present in one of these info areas, the + parameter is ignored, and
records are match up during the input process, see Input on page 122.

Target Station not Present or has been Deleted

If the station record corresponding to the target station is not present on the target
station itself or is marked for deletion, the input process takes place in two stages:

1. The Stations, Communication, Languages, Formats and Catalog Maintenance
info areas are input, and a log file is created (the communication file is not
deleted).

2. The remaining records are input.

Outputting a new Data Stock Download for an Existing Station

To output a data stock download for a station that is already in operation:

1. Delete all communication logs referring to the target station on the main office.

2. Switch to the target station in the Station info area.

3. Delete the contents of the Last Output Date and Last Output Time fields.

4. Start the Communication module with the following command line (see mmco.exe
Parameters on page 343):
mmco.exe -u com -p <Password> -k o,101,r

A data stock download is generated for station number 101. Only the most recent
catalog maintenance record is included, see Communicating Catalogs on page
139.

5. Transfer the communication file to the target station and input it as follows:
mmco.exe -u com -p <Password> -k i,1,+

Note:  Only input the communication file that contains the data stock download. Do
not input communication files from previous communication sessions.
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Partial Data Stock Download

You can create a data stock download that only contains data from specific info ar-
eas:
mmco.exe -u com -p <Password> -k o,101,u:FI:KP:MA

The above example generates a par tial data stock download for station number 101:

• All records in the specified info areas (Company, Person in Company, Activity)
are output (according to the settings in the communication format or distribution
logic).

• All child records of these companies, persons and activities are also output,
provided that Output is enabled for the child info areas in the communication
format, see Defining a Communication Format on page 90.

• Only those records that have been changes since the last communication session
are output from other info areas – as for "normal" communication sessions.

Input the partial data stock download as for the full data stock download:
mmco.exe -u com -p <Password> -k i,1,+

If you create a par tial data stock download that only includes dependent info areas
(e.g. - u :MA:BR for activities and mailings), the records are assigned to their parent
records (in this case companies and persons) during the import process. If the
parent record cannot be found in the local database, the record is rejected as false,
see Communication Logs on page 144.

Also output the Format (FT) info area in par tial data stock downloads if the info
areas in the data stock download can contain formats. This prevents data inconsis-
tencies.

Failed Communication Sessions
Learn how to troubleshoot failed communication session.

You need to generate the communication file anew in the following situations:

• If the communication process is aborted (e.g. one of the communicating stations
crashed).

• If an erroneous communication file cannot be input. Error codes (in the
communication logs) provide information on the cause of the error, see Commu-
nication Error Codes in the CRM.core Administrator Guide.

• If a communication file is not transferred successfully.

If the source station has not received confirmation that the communication file has
been input on the target station within the time period defined in the Days to recep-
tion field (see Confirmation on page 124), the communication process is treated as
having failed, and the communication file is automatically output again, see Auto-
matically Repeating Communication.

You can also repeat the communication process manually to resolve these problems,
see Manually Repeating Communication.
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Automatically Repeating Communication

If the source station has not received confirmation that the communication file has
been input on the target station within the time period defined in the Days to recep-
tion field (see Confirmation on page 124), the communication process is treated as
having failed, and the communication file is automatically output again.

• The system determines which records need to be output again based on the
communication logs on the source station. Logs older than 6 months are ignored.

• The format entered in the communication logs must be selected in the current
communication connection, i.e. communication is only repeated for formats which
are in current use.

• For each communication connection and format, a "repetition file" is output, unless
the communication file originally sent is still available and not older than 7 days.

• The new communication file is named according to the current date. This ensures
that files are input on the target station in the correct order.

• New communication logs are added for any "repetition files". The status of
unconfirmed communication logs is set to "not relevant" and these are no longer
taken into account by the system.

If the data models on both stations are not identical (error 46), the communication
process is also repeated automatically, see Outdated Data Model at Branch Offices.

Outdated Data Model at Branch Offices

If a branch office communicates with the main office and the data model on the
branch office is outdated, the data in the communication file may not be input on
the target station (e.g. if fields and info areas in the data model have been deleted
on the target station). Instead, the file is moved to the ERR directory.

The input process' communication log is assigned the Status "Error" (Error No.
46). The notification file requests that the data be resent by the branch office.

The main office automatically outputs the current data model for the target station
in the next communication process, see Communicating Data Model Changes in the
CRM.core Administrator Guide.

When inputting the file on the branch office, the data model is updated first. Once
the input process is complete, all changes since the last successful outbound com-
munication process are output. The new communication file therefore includes both
the changes in the communication file rejected by the main office and all changes
made since then on the branch office.

Once the communication file is successfully input on the main office, the error has
been resolved and the communication file that caused the error can be deleted from
the ERR directory.

Once the branch office has input the confirmation receipt from the main office, the
Status of the log referring to the failed communication session is set to "not relevant"
on the branch office. The Destination: received and Destination: input fields are
enabled and the date of the new output process is entered in the Retry date field.

As of versions 7.0.6.214 and 7.0.7.72, branch offices also automatically output their
data model. Based on this information, data in info areas that have been changed
in the data model on the target station can also be input, provided no fields or info
areas have been deleted.
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Manually Repeating Communication

To manually repeat a failed communication session:

1. Search for the last successful output process in the Communication Logs info
area on the source station (Status: OK).

2. Navigate to the penultimate output to the affected target station.

3. Make a note of the values in the Dateand Time fields.

4. Switch to the target station in the Station info area.

5. Enter the values you noted down into the Last Output Date and Last Output
Time fields.

6. Output the file for the target station again.

A communication file containing all missing records since the last successful
communication session is created.

Error Accessing the Temporary Communication File
Learn to troubleshoot errors thrown while accessing the temporary communication
file.

Access to temporary communication files (*.par t) can be denied if the file is being
used by another application or your anti-virus software.

This error is logged at log level "Error" or above in the <User>_6.log file in the
\system\ db directory (see Logs and Error Messages in the CRM.core  Administrator
Guide):
...com-out: tmp-file:'%s', cannot open"...

%s: Name of the temporary communication file.

Rectify the problem and repeat the output process.

Communication between Different Aurea CRM win
Versions
Aurea does not recommend communicating between different release versions or
service packs.

WWW Interest Info Area

WWW interest records cannot be communicated between versions containing the
WWW Interest info area and versions not containing the WWW Interest info area.

In this case, communication is only possible between identical versions (same release
and service pack).
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Events Info Area

The Events info area is an independent info area that can be linked to the Marketing
Activity info area, >> Events in the User Manual. Event records cannot be commu-
nicated between versions containing the Events info area and versions not containing
the Events info area.

In this case, communication is only possible between identical versions (same release
and service pack).

Inputting Communication Files from Version 7.0.03 in Version 7.0.02

Prior to version 7.0.02.63

Communication files input from version 7.0.03 are rejected. The communication file
is moved to the ERR directory, see Directory Structure.

From version 7.0.02.63

Communication files input from version 7.0.03 are rejected. The communication file
is retained in the IN directory and can be input after installing Service Pack 3.

Inputting Communication Files from Versions 7.0.01 and 7.0.02 in Version
7.0.03 in Version 7.0.03

Communication files are input. The synchronization request is generated in a format
that can be input on stations using version 7.0.01 or 7.0.02.

Error Messages
Learn how to troubleshoot different error messages.

Error Messages in the Station Info Area

Missing communication x -> y.

No communication connection has been configured from station x to station y.

• Define the communication connection, see Communication Info Area on page 113.

No input files found

The IN directory does not contain any communication files to be input on this station.

• Transfer the communication files to the target station, see Transferring Commu-
nication Files on page 122.

• Ensure that the communication files are stored in the correct IN directories on
the target station.

Error Messages in the Communication Info Area

Already Exists
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This error occurs if you try and add a communication connection between stations
for which a connection has already been defined. Note that records marked for
deletion but not yet physically deleted are also taken into account.

• Use an existing connection.

• Only one communication connection can be defined for each execution type.

Communication format missing or faulty

Enter a communication format for the connection or define a new one, see Defining
Communication Connections and Defining a Communication Format on page 90.

Destination is Station No. x. Communicate anyway?

The communication file being input is meant for another station. This error only oc-
curs if the Verify the target station's number option is enabled in the target station's
record and you are inputting the communication file manually, see Defining a Station
in the CRM.core Administrator Guide. Otherwise the (possibly incorrect) data is
input without a prompt.

Common Error Messages in the Communication and Station Info Areas

No destination defined in mask

The IN directory contains a file that is not a communication file (e.g. a text document).

Data error in input file

The communication file you are trying to input is faulty. Communication logs Status:
"Error".

Repeat the output process, see Failed Communication Sessions on page 163.

Automatic Communication Error Messages

Errors that occur during automatic communication are written to the file <US-
ER>_6.log in the \system\ db directory, see Logs and Error Messages in the
CRM.core Administrator Guide.

If automatic communication is aborted, the message "No station to communicate
with found. Current station no. is 1" is written to the log file.

• Verify whether communication is enabled for the current day of the week in the
station record of the target station, see Defining a Station in the CRM.core
Administrator Guide.

• Verify that a connection has been defined with the target station and whether the
Output option is enabled for the connection, see Defining Communication Con-
nections.
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4
User Interface
You can customize Aurea CRM's interface to reflect your company's processes and
the needs of your users.

The following options are available:

• Users can configure the appearance of Aurea CRM by selecting View > Desktop
Properties form the menu, see Configuring the Display in the User Manual.
Settings are automatically saved for each user in a format of the type "User
Settings", see Formats in the User Manual.

You can deny users access to these options in the interface settings, see User
Rights Tab on page 241.

• Users can select Extras > Other Options from the menu to configure settings
relating to the header icons and popup notifications displayed for reminders and
messages, see User Interface in the User Manual. These settings are saved for
each user in the mm.cfg file.

You can deny users access to these options in the desktop settings, see Config-
uring Menus on page 222.

• Users can display data in mask and list view, configure lists, load custom masks
etc., see Masks and Lists in the User Manual. These settings are saved for each
user and module in the pro*. cfg files in the user directories. List settings can
also be saved as formats.

You can prevent users from loading user-defined list settings for specific levels
in the desktop settings (Level Properties > Mask/List > Do not load last set-
tings).

• Users can save dashboards as formats, see Dashboards in the User Manual.

You can deny users access to the dashboard menu option in the desktop settings,
see Configuring Menus on page 222.

• Use the Mask Generator to create and edit masks and lists, see Mask Generator
on page 169. Masks and lists are saved as formats.

• Use the desktop settings to configure elements in the user interface, levels and
info areas, as well as to define new levels, see Desktop on page 214. These settings
are saved in formats.

Use access rights to prevent users, groups or stations from defining new levels,
and accessing the Mask Generator and desktop settings, see Defining Further
Settings in the CRM.core Administrator Guide.
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Note:  User-specific settings take precedence over dashboard and desktop settings.

Mask Generator
Use the Mask Generator to create and edit masks and lists in Aurea CRM win.

Masks and lists are saved as mask formats and can be integrated in desktop formats.

You can prevent users, user groups or stations from accessing the Mask Generator
using access rights, see Defining Further Settings in the CRM.core Administrator
Guide.

For more information on masks and lists, see Masks and Lists in the User Manual.

General Approach
Learn about the general approach for defining masks in the Mask Generator.

The general approach when defining masks in the Mask Generator is as follows:

1. Switch to the level whose mask/summary index card/list you wish to edit.

2. Select either Extras > Edit Mask or Extras > Edit Summary Index Card from
the menu.

Note: These options are disabled if View > All Mask Fields has been selected
in the level.If a mandatory mask has been defined for a level (see Masks/Lists
Tab on page 252), only the SU can access the Mask Generator for that level.

The mask or list is displayed in the Mask Generator.

Select File > New Mask from the menu to define a new mask, see Defining a New
Mask on page 173 and Defining a New List on page 173.

3. You can:

• Edit the mask properties, see Mask Properties on page 175.

• Edit existing elements, see Resizing and Moving Elements on page 178 andEle-
ment Properties on page 182.

• Add new elements, see Adding Elements on page 179.

• Delete elements, see Deleting Elements on page 181.

• Layout the mask automatically, see Automatic Layout on page 208.
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4. Select File > Save to save the mask, see Saving, Loading and Deleting Formats
in the User Manual.

5. Select File > Close and Test to close the mask generator and to display the mask
in the current level. Changes that have not been saved are still applied to the
current mask, but is not present if the mask is loaded.

Select File > Exit to close the mask generator and to revert to the previous mask.
Changes that have not been saved are lost.

Select View > Load Mask or View > Load SIC from the menu in the Aurea CRM
win main module to load a previously defined mask, list or summary index card.

Select View > Original Mask or View > Original Pre. Mask to load the mask, list
or summary index card defined for the level in the desktop settings.

Note:  Mask formats are saved for specific info areas. You can only load a mask if
the current level contains the corresponding info area.

You need to install the corresponding Windows language packages (in the regional
settings) to be able to use double byte characters in masks and lists.

If you edit an original mask, all masks that are loaded using buttons in the mask
also need to be redefined. For example, if you edit the Company Search mask, you
also need to save the extended search mask and enter it as the target for the Ex-
tended Search button. Otherwise no mask is loaded when you click on the button.

Toolbars

The Mask Generator includes the following toolbars:

• Coordinates

This toolbar displays the coordinates of the mask or currently active element in
either pixels or grid units. To switch between pixels and grid units, click on the 
symbol at the top left of the toolbar and select either Pixel or Grid Unit from the
menu.

• Mask Elements

This toolbar contains buttons used to add elements to the mask, see Adding Ele-
ments on page 179.

You can also add elements using the Elements menu.

• Mask Toolbar
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This toolbar contains the following buttons: Load mask, Save  mask, Save mask
as...and New mask.

These options are also available from the File menu.

You can hide and show the toolbars using the View menu.

Grid Units

Use the Grid window to determine whether and how the grid is displayed on the
mask to help you position elements. The settings in this window only affect the grid
lines and have no effect on the units used for positioning elements. The grid units
used to position elements are defined in the Mask Properties window (Horizontal
Grid and Vertical Grid panes), see Mask Properties on page 175.

Select View > Grid from the menu to open the Grid window.

• Display on: Use these options to determine whether the grid should be displayed
on the mask and tabs groups.

• Type: Grids can be displayed as either Dotted lines or solid Lines.

• Horizontal Unit / Vertical Unit: Defines whether the distance between the grid
lines should be the entire, half or quarter of the font width. The font used to
determine the size is taken from the following:

• For masks, the largest font defined for either field names or contents is used.
These fonts are defined in the following areas:

Mask Properties window, Text and Contents fields.

Tab Group Properties window, Field Text and Field Contents buttons.

• For column type lists (see Defining a New List on page 173), the larger of the
fonts defined for the list header and cell contents (List Properties window,
Header Font and Cell Font buttons).

• The following values are valid for mask type lists (see Defining a New List on
page 173):

Font Width: Taken from the cell font (List Properties window, Cell Font button)

Font Height: The value entered in the Minimum field under Horizontal grid in
the List Properties window. If this value is smaller or equal to 0, the cell font
size is used instead (Cell Font button).
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Grid units cannot be smaller than the specified minimum value (Minimum field
in the Horizontal Grid and Vertical Grid panes).

• Current Grid Unit: Enable this check box to use the grid units defined in the
Mask Properties window.

Screen Resolution

The current screen resolution is used automatically when defining a mask. If problems
occur displaying the mask, open the Screen Resolution window to display the
resolution the mask is defined with.

Select Options > Screen Resolution to open the Screen Resolution window.

The following options are available:

• Do not adjust mask: The mask is not adjusted and is always displayed in the
same size.

• Available screen resolutions:

• If no changes are made, the resolution the mask is defined for is used.

• If you select a lower resolution (e.g. 640x480 instead 1280x1024), the mask
size is scaled down accordingly.

• If you select a higher resolution, the mask size is scaled up accordingly.

Use 640x480 for masks that should work under all resolutions.

Masks are only adjusted to the screen resolution if the Full Screen Mask option is
enabled in the interface settings of the current desktop format, see Masks Tab on
page 234 (General pane).

Note:  For an optimal conversion between resolutions, enable the Field text and
Field contents check boxes under Length in Grid Units in the Mask Properties
window when defining a new mask.
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Defining a New Mask
Learn how to define a new mask.

To define a new mask:

1. Switch to the level you wish to define a new mask for.

2. Click  (Mask) to switch to mask view.

3. Select either Extras > Edit Mask or Extras > Edit Summary Index Card from
the menu.

The Mask Generator is opened.

4. Select File > New Mask from the menu.

5. Configure the mask properties, see Mask Properties on page 175.

6. Add the desired elements, see Adding Elements on page 179.

7. Save the mask format.

Defining a New List
Learn to define a new list.

To define a new list:

1. Switch to the info area for wish to define a new list for.

2. Click  (List) to switch to list view.

3. Select Extras > Edit Mask from the menu.

The Mask Generator is opened.

4. Select File > New Mask.

5. Configure the mask properties, see Mask Properties on page 175.

6. Click on  (List).

The New List window is displayed.

7. Select the type of list:

• Select Mask type to display a list of records with individual masks for each
record.
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• Select Column type to define a standard list.

8. Click on OK.

9. Configure the list properties, see List Properties on page 196.

10.Configure any fur ther settings:

• For column type lists: Select Options > Define List Format, see Defining Lists
in the User Manual.

• For mask type lists, see Defining Mask Type Lists.

11.You can also include mask elements (e.g. a tab containing fields) in the list, as
in the following mask list:

The company search is an example of a column type list that includes mask ele-
ments.

Note: The individual elements (fields, tabs etc.) can only be added to the mask
outside of the list element.

12.Save the mask format.
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Defining Mask Type Lists

To define a mask type list:

1. Switch to the info area for you wish to define a new list for.

2. Click  (List) to switch to list view.

3. Select Extras > Edit Mask from the menu.

The Mask Generator is opened.

4. Select File > New Mask.

5. Configure the mask properties, see Mask Properties on page 175.

6. Click on  (List).

The New List window is displayed.

7. Select Mask type and confirm with OK.

8. Configure the list properties, see List Properties on page 196.

• Enter the desired Row height under Rows and Columns.

• Click on Header or Total Line to define the desired Height of these elements.

You can also determine whether the header or total line is displayed as a User-
defined text or Mask, see Header Properties on page 200 and Configuring the
Total Line on page 200.

9. Select Options > List Sub-unit > Header/Line/Total Line to define masks for
these elements.

10.Add the desired fields.

11.Select Options > Mask Properties to define the font type and size etc. used by
field names and field contents, as well as the units used to determine the length
of texts and fields (grid units or characters).

12.Select Options > Mask to return to the list.

13.Save the mask format.

Mask Properties
Learn how to set mask properties.

To open the Mask Properties window:

• Select Options > Mask Properties from the menu (Alt+Enter keyboard shortcut).

• Click on the mask to select it, and select Elements > Properties from the menu.

• Double-click on the mask.

• Right-click on the mask and select Properties.
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The following settings can be defined in the Mask Properties window:

Display

• Center horizontally: The mask is centered horizontally within the level.

• Horizontal scroll bar: Determines whether a horizontal scroll bar is displayed if
the window containing the mask is smaller than the value in the Max. width field.

• Vertical Scroll Bar: Determines whether a ver tical scroll bar is displayed if the
window containing the mask is smaller than the value in the Max. height field.

• Without header: Enable this option to minimize the header. The header can be
opened by double-clicking on it.

Layout

The options in the Layout pane apply to the automatic layout function, see Automatic
Layout on page 208.

Horizontal Grid

Use these settings to define the horizontal grid units, see Grid Units. These values
are used when an element is placed or moved on the mask.

• Font width: The font width is used as the horizontal grid unit.

• ½ width: Half the font width is used as the horizontal grid unit.

• ¼ width: A quarter of the font width is used as the horizontal grid unit.

• Minimum (pixels): Determines the minimum size of the horizontal grid units in
pixels.

Vertical Grid

Use these settings to define the ver tical grid units, see Grid Units. These values
are used when an element is placed or moved on the mask.

• Font size: The font height is used as the ver tical grid unit.

• ½ size: Half the font height is used as the ver tical grid unit.
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• ¼ size: A quarter of the font height is used as the ver tical grid unit.

• Minimum (pixels): Determines the minimum size of the ver tical grid units in
pixels.

Position and Size (Grid Units)

These options determine the size and position of the mask.

• Pos  X: Horizontal distance of the mask from the left border of the window. If the
Center horizontally check box is enabled, this value is determined automatically
by the system.

• Pos Y: Vertical distance of the mask from the top border of the window.

• Min. width: The minimum width of the mask in grid units.

• Min. height: The minimum height of the mask in grid units.

• Max. width : The maximum width of the mask. A scroll bar is displayed if this
value exceeds the size of the window (and the Horizontal scroll bar check box
is enabled).

• Max. height : The maximum height of the mask. A scroll bar is displayed if this
value exceeds the size of the window (and the Vertical scroll bar check box is
enabled).

Note: The optimum values are calculated upon exiting closing this window. Select
Options > Adjust Mask Size (F7) from the menu at any time to reduce the size
of the mask to the minimum size to fit all elements.

• Use default alignment: The horizontal and ver tical positions of the mask are
taken from the desktop settings, see Masks Tab on page 234 (General pane).

Length in Grid Units

These settings determine whether grid units are used for the length of field names
and field contents.

• Field text: Enable this option to calculate the length of field names in grid units.

• Field contents: Enable this option to calculate the length of field contents in grid
units.

If the check boxes are disabled, the number of characters is used to determine the
length instead.

Do not show tables

Enable this option to prevent tables from being displayed, e.g. to disable the table
containing the times in the Contact Times info area (FS and OTC only).
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Free-floating Fields

These settings apply to fields that are placed directly on the mask (i.e. outside of
a tab group).

• User-defined text: The font type, size etc. used for field names.

• Contents: The font type, size etc. used for field contents.

• Colors: Click on this button to select from a number of predefined color schemes.

Background

• Color: Color of the mask.

• Pattern: Background pattern.

• No background: Enable this option to ignore the Color and Pattern settings.

• Use default colors: Enable this option to use the color settings defined in the
current desktop format, see Colors Tab on page 224 and Skins Tab on page 226.

Resizing and Moving Elements
Learn to resize and move elements.

Resizing the Mask

The black frame represents the outline of the mask. Select Options > Mask Prop-
erties or double-click on the mask to enter the size in the Max Width and Max
Height fields. Alternatively, drag the squares at the corners of the mask to the de-
sired position.

Select Options > Adjust Mask Size (F7) from the menu to reduce the size of the
mask to the minimum size to fit all elements.

Resizing Elements

1. Click on an element to select it.

2. Click on the squares at the corners and use the mouse to drag the element to the
desired size.

This method cannot be used to alter the size of icons and lists.

Resizing Lists

Double-click on the list and edit the size of the list in the List Properties window,
see List Properties on page 196.

Repositioning Elements

To reposition an element within the mask:

• Drag it to the desired position with the mouse.

• Click on the element and use the cursor keys to move it.

• Click on the element and select Elements > Enter Position from the menu.
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• PosX : Distance from the left border of the mask.

• PosY : Distance from the top border of the mask

• Width: Width of the element

• Height: Height of the element

• Right-click on the element and select Enter Position from the popup menu.

An element cannot be placed on another element (exception: tab groups, see Tab
Groups on page 201).

When moving a tab group, all tabs in the group are moved.

Note:  Use the Esc key to cancel resizing and moving an element.

Adding Elements
Learn how to add elements.

To add an element:

1. Use the Elements menu (Field, Tab, Button, Text, Icon and List options).

Or click on one of the following buttons in the Mask Elements toolbar:

 New field, see Adding Fields

 New tab

 New button, drop-down list or list field

 New text

Note: Text elements are not suited to tab groups. Use text fields to define different
text elements for different tabs in a tab group, see Adding Fields.

 New icon

 New list, see Defining a New List on page 173.
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Note: You can only define one list per mask.

2. Click on the desired position in the mask.

3. Enter the desired element properties, see Element Properties on page 182.

4. Click on OK.

Adding Fields

To add a new field:

1. Click on  (Field).

The Field Selection window is displayed:

2. Select the field type:

• Info area field: Select this radio button to include a database field. Select the
info area from the Info area drop-down list and the field from the Fields list.

Note:  If you are adding a field to the search or match-up masks for companies,
persons or properties, two entries are available for each info area in the Info area
list. Select the entry ending with (Mask). Otherwise, the fields in the mask cannot
be edited.

• Text field: Use this option to add static text to a tab.

3. Click on OK.

4. Click on the desired position in the mask.

The Field Properties window is displayed, see Field Properties on page 182.

Note:  Users can only add those fields that they are allowed to access according
to their access rights, see Defining Rights at the Field Level in the CRM.core
Administrator Guide.The same field can be added to a mask several times.

180AUREA CONFIDENTIAL

Chapter 4: User Interface

https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-2_8_7-Defining-Rights-at-t_crm.html


Deleting Elements
Learn how to delete elements.

You can delete elements as follows:

• Click on the element and select Elements > Delete from the menu.

• Right-click on the element and select Delete from the popup menu.

• Click on the element and press the Del key.

Listing all Elements
Learn how to display all elements in the mask.

Select Options > Show all Elements from the menu to open a window displaying
all elements in the mask:

• Type: Icon indicating the type and name of the element. Concealed tabs in a tab
group are indicated with "(inactive)".

• Coordinates: Coordinates of the element.

• From-To Field: The number range of the fields in a tab group is displayed next
to tab groups, see View Tab.

• ID: Button IDs are displayed in this column, see Button Properties on page 188.

Select an element and click on Delete to delete it. Click on Update to edit the ele-
ment's properties.

Select an element and click OK to select the element in the mask.
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Element Properties
Upon adding a new element, the element's properties are displayed.

To display the properties of an existing element:

• Click on the element and select Elements > Properties from the menu.

• Double-click on the element.

• Right-click on the element and select Properties.

• Click on the element and press Alt+Enter.

Field Properties
A field's properties are defined in the Field Properties window.

The Field Properties window fields are defined below:

• Info area: Name of the info area containing this field.

• Field number: Field number

• Order: Tab order of the field in the mask.

• Tab group no.: The number of the tab the field has been assigned to, if applicable.

• Tab group text: Name of the tab

• Field text: Name of the field. Click on  (Multi-language Input) to edit the name
of the field in the available languages.

Note: You can rename fields globally in the data model, see Renaming Fields in
the CRM.core Administrator Guide.
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Output Field Contents

These settings define the formatting of the field contents.

• Left/Right/Center: Select the alignment of the field contents.

• No border: Enable this option to display the field without a border.

Note: This setting takes precedence over the No field border option in the Tab
Group Properties window.

Field Text Output

These settings define the formatting of the field name.

• Align right: Align field text to the right (default: left-aligned).

• Hide field text: Enable this option to prevent the name from being displayed.

• Field text border: This option is only available for fields in lists.

• Definition: Enable this check box to add a multi-language description field,
see Text Fields for Descriptions.

Field Type

These settings determine the field type:

• Checkbox: The field is displayed as a check box.

• Icon: The field contents are displayed as an icon. Choose this option for fixed
catalogs that use icons.

• Note field: A field for notes that spans several lines. The Output Field Contents
pane is grayed out when you select this option.

Note: This option is not available for document, link, e-mail and pure text fields.

• Free Field: A field whose contents are calculated and displayed using internal
formulas. Do not change these fields' type.

• Drop-down list: The field is displayed as a drop-down list. This option is only
available for catalog fields.

• Standard field: Aurea CRM standard field

• Text field only: This option is active if Text field is selected in the Field Selection
window, see Text Fields for Descriptions.

• Hyperlink: The field is displayed as a hyperlink. These fields can be used for
web pages, e-mail addresses, links to Aurea CRM records and paths to documents,
applications etc.

• update.CRM  document field: Depending on the interface settings in the current
desktop format (see Masks Tab on page 234), clicking on  (Load) icon either
loads an external document or is used to select a document from within Aurea
CRM's document management system. This option is active for fields defined as
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document fields in the data model, see Properties in the CRM.core Administrator
Guide.

• Document field: Users can click on  (Load) to enter an external document. The
document is not stored in Aurea CRM's document management system.

Note:  Select a field with at least 256 characters to display the path.

• Show reference: The record's reference is displayed in the field. References
must be enabled using the Show links option in the interface settings, see Misc.
Tab on page 237. This option is only available for fields in summary index cards.

Text Fields for Descriptions

To add an information field to a mask (or mask type list):

1. Click on  (Field).

The Field Selection window is displayed:

2. Select Text field in the Field Selection window.

3. Click on OK.

4. Click on the desired position in the mask.

The Field Properties window opens.

5. Enable the Definition check box in the Field Properties window.

6. Enter the desired text under Field text. Your text can include carriage returns.

7. Click on OK.

8. Resize the field using the mouse. If the text is longer than the space available in
the field, a scroll bar is automatically displayed. A ToolTip containing the full text
is displayed if the mouse cursor is positioned over the field.

9. Save the mask.

Note: You can determine how long (in milliseconds) ToolTips are displayed using
the ToolTips Duration configuration entry, see Mask in the CRM.core Administrator
Guide.
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Tab Group Properties
A tab group's properties are defined in the Tab Group Properties window.

Tabs divide the mask into sections. Tab groups consist of several tabs. Users can
switch between tabs within a tab group, see Tab Groups on page 201.

View Tab

These settings determine the how the tab is displayed:

• Order: The order in which the tabs are selected during editing. All tabs in the
mask are numbered sequentially (star ting from zero), see Editing Tab Groups.

• From-To Field: The field numbers of the fields in the current tab. All fields in the
mask are numbered sequentially (star ting from zero).

Example: Order "4" and From- to field "13-17" indicate that the current tab is
number "4" on the mask and there are 5 fields on this tab. If "-1 –1" is displayed,
the tab does not contain any fields.

The tab order of the fields is determined by their position within the tab, see Field
Tab Order.

• Title: The name of the tab. If the tab is a member of a tab group, this text is
displayed on the tab's label. Add the "&" character before the letter entered in
the Shortcut field to underline the letter used to switch to the tab.

• Shortcut: Enter a letter to be used as a shortcut. Alt+Letter switches to the tab.

• Center title: Centers the title.

• No tab label: The tab group is displayed without a label.

• Tab label left/above/below: Determines where the label is displayed.

Font

• Title: The font type, size etc. used for the title.

• Field Text: The font type, size etc. used for field names.

• Field Contents: The font type, size etc. used for field contents.
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Bitmap

• Left/Right of text: Determines whether the selected icon is displayed to the left
or right of the tab title.

• Load Icon: Click on this button to select an icon. You can only select Aurea CRM
bitmaps. You need to select either Left of text or Right of text check box before
you can click on this button.

Transfer to Tab Grp.

Use this option to select assign the tab to a tab group, see Editing Tab Groups.

Colors Tab

These settings determine the colors, backgrounds and borders used by the tab:
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Output

• Double border: Surrounds the tab with a double border.

• No border: The tab is displayed without a border.

• Fixed border: If this option is enabled, the double border remains unchanged
when a field in the tab receives focus (in edit mode). This option only applies to
the Double border option. This option has no effect on tabs with a label.

• Transparent: The tab is displayed transparently, but field colors are retained.

Note: The Transparent option is not suited to tab groups.

• No background: The background color of the tab is disabled. The current mask
color is used instead.

• Always visible: The tab remains visible, even if it contains no visible fields. You
can use this option to display the tab even if the user does not have the appropriate
field access rights.

• No field border: All fields in the tab are displayed without a border.

Note: The No border setting for individual fields takes precedence over this
setting.

• Gradient: The tab color is displayed with a gradient. The Tab Background and
2nd background color colors are the 2 colors used.

• Use default colors: Enable this option to ignore the current settings and to use
the color settings defined in the current desktop format instead, see Colors Tab
on page 224 and Skins Tab on page 226.

Colors

To determine the colors of elements in the tab:

1. Select the corresponding element from the list.

2. Select the desired color from the drop-down list.

A preview is displayed to the right.

Background Pattern

Select the background to be used by the tab here.

Double Border (Field)

Use these settings to determine which fields are displayed with a double border.
Double borders are only displayed in edit mode for mandatory, catalog and text
fields.

Color Tables

Click on this button to select from a number of predefined color schemes. A preview
of the selected settings is displayed.

Click on Tabs to assign the selected color scheme to several blocks. Blocks with
no title are listed using the tab number (displayed under Order on the View tab),
see View Tab.
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Button Properties
A button's properties are defined in the Button Properties window.

Fields of Button Properties window:

• ID: The button's ID is assigned automatically by the system.

• Tab group: Assign the button to a tab using the drop-down list. To use the button
to switch between tabs, enable the Switch tabs option under Attributes as well.

• Shortcut: Enter a letter to be used as a shortcut. Use Alt+Letter as a shortcut
instead of clicking on the button.

Table

• Index: ID of a predefined Aurea CRM button loaded using the Load button (-1
for user-defined buttons).

• Load: Loads a pre-defined Aurea CRM button.

Different buttons are available depending on the context, e.g. ">> Extended
Search" and "<< Simple Search" (numbers 1265 and 1266) are available in the
company search mask. Other buttons are available in all masks, e.g. "Add to Fa-
vorites" (number 1275).

Use the Format field under Standard/Drop-down list/List Box to assign triggers,
workflows, reports etc. to a user-defined button, see User-defined Buttons on
page 190.

Status

• Disabled: Automatically enabled for buttons used to switch between tabs and
cannot be changed.

• Hidden: Automatically enabled for buttons used to switch between tabs and cannot
be changed.
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Attributes

Switch tabs: Enable this option to use the button to switch between tabs, >>  .

• Place on tab: Places the button on the tab. The button can then only be moved
within the tab.

• In title: Positions the button in the tab's title.

Hide: The button is not displayed when the corresponding tab is active. To make a
button visible again, select Options > Show all Elements, double-click on the name
of the button, and disable the option.

• Disable: The button is displayed as inactive when the appropriate tab is active.
This option does not need to be enabled for buttons used to switch between tabs;
these buttons are displayed as inactive by default when the appropriate tab is
active.

Type

• Standard: Standard button.

• Drop-down list: The button is displayed as a drop-down list.

The following drop-down lists are predefined:

• For choosing a category in the mask in the Document info area (no. 1030)

• For choosing the month and year in the Calendar (nos. 1015 and 1016)

• BTB only: for choosing a rep in the Opportunity Overviewinfo area (no. 4066)

You can also use drop-down lists to directly choose selections in the Properties
(BTB) and Company+Person levels, see Selections in the User Manual. Choose
the button "1237 Selection" using the Load button under Table.

• List box: The button is displayed as a list box.

The following list boxes are pre-defined:

• Define Print Format (no. 1033)

• Participants list: This option is only available in the Activity level and is used
to display participants (no. 1082).

Use the Load button to load the Participants button.

Always/Never in context menu

You can determine whether buttons are displayed as mask buttons or context menu
entries:

• Always in context menu: The button is displayed as a context menu entry.

• Never in context menu: The button is displayed as a button in the mask.
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Note:  If neither of these check boxes is enabled for a button, the Move mask
buttons to context menu option in the current desktop's interface settings is applied,
see Masks Tab on page 234 (General pane).If the current desktop format includes
context menu entries for the level being edited in the Mask Generator, only those
mask buttons are displayed where the Never in context menu option is enabled.

Standard/Drop-down List/List Box

• Text: Name of the button, drop-down list or list. Add the "&" character before the
letter entered in the Shortcut field to underline the letter.

Format: Format(s) executed by clicking on the button, see User-defined Buttons
on page 190:

• Font: Use this button to specify the font settings for the button's text.

• Use original Text: This check box is available if you have loaded an Aurea CRM
button using the Loadbutton. Enable this check box to display the original button
text in all languages.

User-defined Buttons
Learn how to define custom buttons.

To define buttons used to execute user-defined functions (triggers, workflows etc.):

1. Define a new button, see Adding Elements on page 179.

2. Click on  (Select) next to the Format field in the button properties.

3. Select the desired function from the popup menu, e.g. Analysis format.

4. Load the desired format and confirm, see Loading, Saving and Deleting Formats
in the User Manual.

5. Depending on the selected function, you can determine fur ther options, e.g. the
context of the analysis:
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6. Click on OK.

The name of the selected format is displayed in the Format field.

The first number is the internal number of the format type. The subsequent num-
bers represent the selected options (in this case: 0=Current level, 1=Current
record, 2= Entire database).

7. Configure the rest of the button properties, if desired, see Button Properties on
page 188.

8. Click on OK.

9. Save the mask.

Note:  Buttons used to execute a format can only be used in the Aurea CRM win
main module.

You can execute multiple user-defined functions one after another from a single
button (e.g. multiple triggers, or combinations of different formats). Enter the formats
in the Format field using the following syntax:

Format type ID;Options;Format Name@Format type ID;Options;Format Name@ etc.

Note:  If you do not specify any options, the default settings are used.

Example: 22;Trigger1@22;Trigger2@7;2;1;1;Single letter

In this example, two triggers are executed one after another; a single letter is then
sent by e-mail and saved in Aurea CRM's document management system.

Format Type IDs

FormatNo.

Search condition1

Single letter7

Mask18

Trigger22

Workflow28
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FormatNo.

Dashboard30

Spreadsheet34

XML Report44

Analysis format45

Timeline47

Loading Conditions using a Button
Learn how to define a button used to enable conditions

Follow the below steps:

1. Define a new button, see Adding Elements on page 179.

2. Click on  (Select) next to the Format field in the button properties.

3. Select Search Condition.

If the current level includes multiple info areas (e.g. Company + Person), the
available info areas are displayed in a list. Select the desired info area.

4. Load the desired (global or user-specific) condition, see Loading, Saving and
Deleting Formats in the User Manual.

The selected condition is displayed in the Format field.

5. Configure the button's other properties, see Button Properties on page 188.

6. Click OK.

7. Save the mask.

When a user clicks on the button, the selected condition is enabled. The condition
can be disabled by selecting Data > Activate Conditions > <Info Area>. Alterna-
tively, you can define an additional button used to disable the conditions that ac-
cesses an empty condition.

Note:  Buttons that activate conditions can only be used in the main module. When
clicking on a button that activates conditions, any currently active conditions and
autofilters are automatically disabled, see Conditions in the User Manual.
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Special case: Product Search in the FS Vertical
You can customize the mask used to search for products based on the product
number

For fur ther details, see Product Search in the FS Business Logic Manual.

Select Extras > Edit Mask from the menu in the Company+Person level.

1. Double-click on Search Pr..

2. Enter the abbreviation of the product info area(s) to be displayed in the search
in the Format field in the Button Properties window.

• AL: Securities Account

• BS: Bldg. Soc. Sav.

• DI: Service

• KR: Loan

• KT: Account

• KV: MV - Insurance

• NV: Other - Insurance

• VS: Personal Insurance

• WT: Security Title

• VW: Asset Values

Additional options:

• PU: The All option is displayed in the search and users can search in all product
info areas.

• FI: If a product is found in the product search based on the product number,
the person associated with the product record is displayed, not the product
record.

Separate abbreviations using a semicolon (;).

3. Save the mask.

If a user now selects Search Pr. in the Company+Person level, the defined
search options are displayed:
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If you only entered the "PU" option, no radio buttons are displayed in the product
search.

Text Properties
Text properties are defined in the Text Properties window.

Fields of Text Properties window:

• Text: Enter the desired text here.

• Color: The color of the text.
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Attributes

• Center/Left/Right: The alignment of the text relative to the mask.

• Absolute: Allows you to position the text freely by clicking on the desired position.

• Shadow: Enable this check box to select a color from the drop-down list below.
The text is displayed with a shadow in this color.

• Font: Click on this button to define the font type, size etc.

Icon Properties
Icon properties are defined in the Icon Properties window.

Fields of Icon Properties window.

Attributes

• Resource: This option is always grayed out. The option is enabled if you select
a predefined Aurea CRM icon.

• File: This option is always grayed out. The option is enabled if you select a user-
defined icon.

• Transparent: The icon's background color is set to transparent.

• As wallpaper: The icon is displayed as a background image behind other mask
elements.

• Choose Icon: Click on this button to choose from the predefined icons or to load
your own bitmap. The icon is displayed in its original size and cannot be changed.

Name

Displays either the name of predefined icons or the path and file name of custom
icons.
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List Properties
List properties are defined in the List Properties window.

Fields of List Properties window.

Attributes

• Mask Type: This check box is enabled automatically if you are editing a mask
type list.

• Center Horizontally: The list is centered horizontally within the mask. Drag the
list element in the mask generator to resize the list. Note that the Max width (GU)
setting is ignored if

• Horizontal/Vertical Scroll Bar: Enable these options to display scroll bars if the
list size exceeds the size of the mask.

• Total Line: A line containing the total is displayed at the bottom of the list.

List Height

• Maximum: The list height is automatically set to the maximum available in the
window. The list is resized if the window is resized.

• Fixed: The maximum list height is set to Max height (GU); the minimum list height
is set to Min width (GU). If both these values are equal, the list is always displayed
with the same height. If the Center horizontally option is disabled, the width of
the list is set to the value entered in the Max width (GU) field. If the list dimensions
exceed the current size of the window, scroll bars are displayed.

• Centered: Adds a margin below the list. Enter the size of the margin in the Lower
border (Pix).
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Horizontal Grid

Grid units are based on the current font.

• Font Width: The font width is used as the horizontal grid unit.

• ½ width: Half the font width is used as the horizontal grid unit.

• ¼ width: A quarter of the font width is used as the horizontal grid unit.

• Minimum (pixels): The horizontal grid unit is never smaller than the pixel size
specified here.

Vertical Grid

• Font size: The font height is used as the ver tical grid unit.

• ½ size: Half the font height is used as the ver tical grid unit.

• ¼ size: A quarter of the font height is used as the ver tical grid unit.

• Minimum (pixels): The ver tical grid unit is never smaller than the pixel size
specified here.

Changes to the ver tical grid units affect the Row Height field.

Rows and Columns

• No. Cols.: Lists can be spread over several columns. Note that these columns
are not list columns; each such column contains all the fields in the list.

• Row Height: The height of each row in grid units. This value is automatically
converted to pixels or grid units if the Line Height in Pixels is enabled/disabled.

• Row Spacing: Increases the spacing between rows by this amount of pixels (color
= background color).

Note: The Row Spacing setting only applies if the Cell-oriented options is also
enabled.

• Column Spacing: The spacing between columns in pixels (color = background
color).

Separators

• Cell-oriented: Surrounds each cell with a border. Enter the width of the border
in the Width field.

• Dashed: Only applied if the Cell-oriented option is disabled. This check box is
only available for mask type lists.

• Width: The width of the border surrounding cells if the Cell-oriented option is
enabled.
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Position and Size

• Left border (Pix): The size of the left hand margin in pixels. The margin has the
same color as the list background.

• Max width (GU): Maximum width of the list in grid units (only applied if Fixed is
selected under List Height and Center Horizontally is disabled under Attributes).

• Lower border (Pix): Specifies the height of the margin at the bottom of the list
(if the Centered option under List Height is enabled).

• Top border (Pix): Top margin in pixels. The margin has the same color as the
list background.

• Max height (GU): The maximum height of the list in grid units. If the window is
resized, the height of the list does not exceed this value.

• Min. height (GU): The minimum height of the mask in grid units. If the window
is resized, the list is never resized to be smaller than this value.

• Line height in pixels: Determines whether the line height is specified in pixels.
The value in the Row Height field is automatically converted if this option is
enabled/disabled.

• Use default alignment: The Vertical Position (User Interface > Mask tab > Lists
pane) defined for lists in the current desktop format is applied, see Masks Tab
on page 234.

Colors

To determine the colors of list elements:

1. Select the corresponding element from the list.

2. Select the desired color from the drop-down list.

• Color Tables: Click on this button to select from a number of predefined color
schemes.

• Alternate colors per line: Rows in lists are displayed in two alternating colors
(Line Background and 2nd line background).

• Use default colors: Enable this option to ignore the current settings and to use
the color settings defined in the current desktop format instead, see Colors Tab
on page 224 and Skins Tab on page 226.

Buttons

• Cell Font: Click on this button to define the font type, size etc. used in rows in
the list.

• Header Font: Click on this button to define the font type, size etc. used in the
header.

• Appearance: Opens the List Bar Properties window, see Configuring the Appear-
ance of the Selected Record on page 199.

• Header: Opens the Header Properties window, see Header Properties on page
200.

• Total Line: Opens the List Summary Line Properties window, see Configuring
the Total Line on page 200. This button is only active if the Total Line option is
enabled under Attributes.

198AUREA CONFIDENTIAL

Chapter 4: User Interface



Configuring the Appearance of the Selected Record
The appearance of the current record in the list is configured in the List Bar
Properties window.

Click on Appearance in the List Properties window to configure the appearance.

Appearance

• Background The current record is displayed with the selected background color.

• Border: The selected record is displayed with a border in the selected color.

• None: The current record is not distinguished visually.

• Cursor left/right: Use these options to determine whether the cursor should be
displayed to the left or right of the current row.

Frame

• Use these options to determine whether the Left and Right frames of the list
should be displayed.

• Click on Border to define the properties of the frame:

• Dimensions: Enter the width of the frame and the border within the frame.

• Colors: Use these settings to configure the colors of the individual frame
elements.
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Colors

Define the colors used for the current record here.

Header Properties
Click on Header in the List Properties window to configure the header.

• Height: Height of the header in grid units.

• Border width (Pixels): Width of the border in pixels.

• Colors: Use these settings to define the colors in the header.

• Mask/User-defined text: These options are only available in mask type lists:

• Mask: The header is defined as a mask. Select Options > List Sub-unit
> Header to define the mask used by the header, see Defining Mask Type Lists.

• User-defined text: The header only contains text.

Enter the desired text in the Text field.

Configuring the Total Line
Enable the Total Line option in the List Properties window to include sum totals
in your list.

Click on the Total Line button to define the appearance of the total line.
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• Height: Height of the line in grid units.

• Border width (Pixels): Width of the border in pixels.

• Colors: Define the colors used in the total line here.

• Mask/User-defined text: These options are only available in mask type lists:

• Mask: The total line is defined as a mask. Select Options > List Sub-unit
> Total Line to define the mask used by the total line, see Defining Mask Type
Lists.

• User-defined text: The total line only contains text.

Enter the desired text in the Text field.

Tab Groups
A tab group consists of several tabs.

To create a tab group:

1. Click on  (Tab).

2. Click on another tab on the mask.

3. A message is displayed. Confirm the message with Yes.

Editing Tab Groups

To switch to a specific tab in the mask generator:

• Select Options > Show all Elements, select the tab and click OK.

• Click on the tab group and use the Tab key to navigate between tabs in the group.

• Right-click on the tab group and select Show Next Tab from the popup menu.
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• Click on the tab group and select Options > Tab Group > Show Next Tab from
the menu.

• Select Options > Test Mask/List and click on the tab to test it. Select Options
> Edit Mask/List to return to edit mode.

To remove a tab from a group or assign the tab to a new group using the mouse:

1. Navigate to the desired tab.

2. Hold down the Shift key and use the mouse cursor to drag the tab to the desired
position.

• Drag the tab to an empty area on the mask to remove the tab from the current
tab group. Any buttons added to the mask and used to switch to this tab lose
their function.

• Drag the tab to another tab group to assign the tab to the new tab group. You
are asked to confirm the assignment. Click on Yes.

The tab is assigned to the new tab group.

To remove a tab from a group or assign the tab to a new group in the Tab Group
Properties window:

1. Navigate to the desired tab.

2. Open the Tab Group Properties window.

3. Select the target tab from the Transfer to Tab Grp. drop-down list.

Select the empty entry (at the end of the list) to remove the tab from its current
group. Any buttons added to the mask and used to switch to this tab lose their
function.

4. Confirm the message to adjust the position.

5. Click on OK.

To change the order of tabs within a tab group:

1. Select Options > Order from the menu.

A list of all tabs and fields not assigned to tabs is displayed.
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2. Click on the name of the tab you wish to move and drag the line to the desired
position.

3. Click on OK.

Field Tab Order

To change the tab order of fields in a tab:

1. Navigate to the desired tab.

2. Select Options > Tab Group > Field Order from the menu.

3. Select the field whose position you wish to change.

4. Move the cursor to the desired position between two fields. Once the cursor
changes, click to move the field.

The selected field is moved.

5. Click on OK.

Aligning Fields

To align the fields in a tab:

1. Select the tab or a field to align the other fields with.

2. Select Options > Tab Group > Field Order from the menu.
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If you selected a field in step 1, it is displayed under Align with Field.

3. Select all the fields you wish to align in the Fields list.

Enable Select All to select all the fields.

4. If you did not select a field in step 1, you can now determine how to align the
fields.

• Left: Fields are assigned the position of the field fur thest to the left.

• Right: The right field borders are aligned with the right edge of the field fur thest
to the right.

5. Determine the following settings:

• Text: Field names are aligned.

• Contents: Field contents are aligned.

• Text length: All field names are set to the length of the longest field name.
This option is only available if the Text check box is enabled.

• Field lng : All field lengths are set to the length of the widest field. This option
is only available if the Contents check box is enabled.

6. Click on OK.

Defining Buttons to Switch Between Tabs

If you define tab groups without labels, you need to define buttons used to switch
between the tabs:

1. Define a new button and do not assign it to a tab.

The Button Properties window opens.

2. Select the tab the button should activate from the Tab group drop-down list.

3. Enable the Switch tabs option under Attributes.

4. Enter a caption for the button in the Text field.

5. Click on OK.

6. Define fur ther buttons for the remaining tabs in the tab group.

7. Save the mask.
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Defining a Global Color Scheme
You can define a global color scheme for all masks, lists and tables in Aurea CRM
and assign the corresponding desktop format to users, groups and stations.

For fur ther details, see Skins Tab on page 226.

To define a global color scheme:

1. Start Aurea CRM win as SU.

2. Switch to the Company+Person level.

3. Select Extras > Edit Mask from the menu.

4. To change the background, open the Mask Properties window and change the
settings in the Background pane, see Mask Properties on page 175.

5. Define the color settings (in the Colors and Double Border (Field) panes in the
Tab Group Properties window, see Tab Group Properties on page 185) of the
following tabs:

• The first tab without any tab labels (1)

• The second tab without any tab labels (2)

This setting is used for all tabs groups without tab labels, except for the first
block (1). If only one block without tab labels is present in the mask, that tab's
settings are applied to all tabs without labels.

• The first tab group with tab labels (3)
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These settings apply to all tab groups with tab labels. If no tab group with tab
labels is present in the mask, the settings defined for the second tab group
without labels (2) are applied.

• The first transparent tab

To do so, define a transparent tab (Tab Group Properties, Colors tab,
Transparent check box).

Global summary index cards are defined in the same manner as masks. The first
tab's settings are applied to all tabs.

Settings for global lists are defined under Horizontal Grid, Vertical Grid, Colors,
Rows and Columns, Separators, Cell Font, Header Font, Appearance and
Header in the List Properties window, see List Properties on page 196.

Settings for global lists can also be applied to tables, see Tables.

6. Save the mask or list and exit the Mask Generator.

7. Select Extras > Define Desktop from the menu, see Defining a Desktop on page
215.

8. Load the desktop format you wish to assign the global color scheme to.

9. Click on User Interface under Global Settings.

10.Switch to the Skins tab.

11.Load the desired formats under Masks, Lists and Tables, and enable the Default
check box, see Skins Tab on page 226.

12.Save the format.

Tables

Tables in Aurea CRM win are similar to lists, but are used for other functions (selec-
tions, print formats, appointment distribution), >> Tables in the User Manual.

You can use list formats to customize the colors of tables. Colors are assigned to
tables as follows (Colors and Separators panes in the List Properties window in
the Mask Generator):

TableList

List Properties (see User-defined Buttons on page 190) - Colors pane:

Table background and grid colorList Background

Cell background color, if the original color
is white

Line Background

Cell background color, if the original color
is gray

2nd Line Background
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TableList

Text colorLine Foreground

Upper cell frame colorFrame above

Bottom cell frame colorFrame below

List Bar Properties (see Configuring the Appearance of the Selected Record on
page 199) - Colors pane:

Background cell color while entering data
or selecting a catalog value

Background

Text color in text and catalog cells during
input

Text

Upper frame color of text and catalog
cells

Frame above

Bottom frame color of text and catalog
cells

Frame below

Header Properties (see Header Properties on page 200) - Color pane:

Background color of the headerBackground

Color of the header textText

Upper frame colorFrame above

Bottom frame colorFrame below

List Properties - Separators pane:

Cell border widthWidth

List Properties - Rows and Columns pane:

Spacing between rows in the tableRow Spacing

Header Properties:

Header border widthBorder width
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Automatic Layout
You can use the automatic mask layout function to automatically arrange fields.

For fur ther details, see Automatic Layout Rules.

This function is not available for masks that contain lists or tables.

To use the automatic mask layout function:

1. Select Options > Automatic Layout from the menu or enable the Automatic
Layout option in the Mask Properties window.

The current mask is automatically converted. "automatic layout" is displayed in
the status bar.

You cannot move mask elements using the mouse or keyboard or edit the mask
size if the automatic layout option is enabled.

2. Edit the current mask or create a new mask, see Layout Settings on page 210 and
Creating a Mask Using the Automatic Layout Function.

3. Disable the Automatic Layout option once the mask has been converted.

Automatic Layout Rules

The following rules apply to the automatic mask layout function:

• Automatic layout mode uses one main tab in the upper por tion of the mask and
a tab group in the lower por tion.

If the upper por tion of the mask includes several tabs positioned next to one an-
other, these tabs are grouped together in a single tab. The contents of the original
tabs are separated by an empty line between them.
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Note: The structure used by the Company+Person level, which uses two main
tabs, is retained.

• All fields must be assigned to a tab group.

• Fields are arranged in two columns:

• If a field is positioned entirely to the left of the center of a tab, it is assigned
to the left-hand column.

• If a field is positioned entirely to the right of the center of a tab, it is assigned
to the right-hand column.

• If the field spans the center of the tab, it spans both columns.

• If several fields are next to each other in the same column (e.g. Postal Code
and City), these fields are displayed over several lines, one above the other.

• Fields exceeding a certain length are either displayed spanning both columns or
spanning several lines, see Layout Settings on page 210.

• All fields in summary index cards occupy a single column.

• Check boxes are displayed in their default size as a box.

• You cannot use icons or text elements.

• Icons used to indicate field contents are always added to a fixed pane to the right
of the mask.

• A single text field can be added per mask for descriptions (information field,
see Text Fields for Descriptions). This field is displayed to the right of any icons.

• No buttons are displayed; all options are available from the context menu only.

Creating a Mask Using the Automatic Layout Function

To create a new mask using the automatic layout function:

1. Switch to the level you wish to define a new mask for, and open the Mask
Generator, see Defining a New Mask on page 173.

2. Select Options > Automatic Layout from the menu.

3. Select File > New Mask from the menu.

A new mask is created that contains two tabs.

4. Click on  (Field).

5. Enable the check boxes next to the fields you wish to display in the mask. Up to
15 fields can be added to a tab.

6. Click on OK and click on the desired tab.
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The fields are automatically laid out on the tab, see Automatic Layout Rules.

7. Make any fur ther settings, see Layout Settings on page 210 and Automatic Layout
Field Properties.

8. Save the mask.

Layout Settings
Learn how to set Layout settings.

Select Options > Layout Settings from the menu to configure the automatic layout
settings.

Tab Group

• Font: Font for tab headings, field texts and contents.

• Group header: Font size of the tab headings.

• Field text: Font size of the field texts.

• Field contents: Font size of the field contents.

Note: You cannot configure fonts or font sizes in the Tab Group Properties
window when using the automatic layout function.

• Top margin: Upper margin in the tab group in grid units.

• Margin left/right: Left and right margin in the tab group in grid units.

Mask

• Minimum width: The width of the mask in grid units.

• Top margin: Upper margin of the mask in grid units.

• Margin left/right: Left and right margins of the mask in grid units.
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Summary Index Card

• Minimum width: The width of the summary index card in grid units.

Fields

• Field texts (%): Percentage of the total width of the tab for field names.

• Field contents (%): Percentage of the total width of the tab for field contents.

• Single column (%): Percentage of the total width of the tab fields spanning both
columns.

• Column spacing (%): Percentage of the total width of the tab for the spacing
between two columns.

• Single column field length: Fields longer than the length entered here (in
characters) automatically span the entire width of the mask when they are added
to the mask or the mask is converted.

• Field length spanning multiple lines: Fields that contain more characters than
the number entered here automatically span the entire width of the mask and
several lines.

• Number of lines: Enter the standard size (in lines) for fields spanning several
lines.

• Right/Left-align field text: Determines whether field names are aligned to the
right or left.

Note: The Align right and Hide field text options in the Field Properties window
(under Field Text Output) are not available when using the automatic layout
function.

• Fixed/Variable catalogs as drop-down lists: Determine whether fixed and
variable catalogs are displayed as drop-down lists instead of windows.

The settings are automatically saved in a global "Mask Layout" format, see Formats
in the User Manual.

Click Reset to revert to the default settings.

Automatic Layout Field Properties

The following options are available in the Field Properties window when using the
automatic layout function:

• Two Columns: The field spans the entire width of the mask (i.e. both columns).
The next field is moved to the following line.

• Append Spaces: An empty line is added after the current field. If a field is located
to the right of this field, the second field is moved to the line after the empty line.

• Field Height (in lines): The size of fields spanning multiple lines.
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Note:  If a field spans several lines, it automatically occupies the full width of the
mask.

Converting Masks
Learn how to convert several saved masks to an automatic layout at once.

Follow the below steps:

1. Open the Mask Generator.

2. Select Options > Convert Masks from the menu.

All mask formats are listed.

3. Enable the check box in the Select column next to the masks you wish to convert.

Click on  (Select All) to select all masks; click on  (Clear Selection) to des-
elect all masks.

Note:  Grayed out mask formats contain lists or tables and cannot be converted.

If the check box in the Summary Index Card column is enabled, the mask is
converted like a summary index card, see Automatic Layout Rules. The automat-
ically enables this setting based on the mask size, but this can be changed.

The check box in the Autom . layout column is enabled for masks that have al-
ready been saved using the automatic layout feature.

4. Click on a mask and click  (View) to display the mask.
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5. Enable the Create a backup of the original mask option and enter text in the
Append the following to the name of the backup field. A backup of the converted
masks is created in the process.

Note: The name of backups is limited to 60 characters.

If a backup already exists with the specified name, backups are numbered sequen-
tially (from "_1" to "_99").

6. Enable the Write converted mask names to log file check box and specify a
log file in the Log file field to create a log file.

These settings are saved for each user in the gm.ini file.

7. Click Start to begin the conversion.

Wizard Masks
Wizards can be used to guide users through the entry of data.

To define a wizard mask:

1. Define a mask with the desired fields.

2. Open the Mask Properties window.

3. Enable the Automatic layout and Wizard mask check boxes in the Layout pane.

4. Select the elements for the wizard mask.

• << Button: Back button

• >> Button: Next Button

• Description: Text field for descriptions and instructions

• Cancel button: Cancel button (cancels the entry without saving).

• Finish Button: Finish button (saves the data).
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Note:  By default, the Cancel and Finish buttons send the "cancel" or "save"
command to the current level. They can also be used to load masks or initiate
triggers or workflows, see Button Properties on page 188.

5. Click on OK.

The buttons are displayed under the mask.

6. If you have chosen to include a Description, double-click on the field to enter the
text.

7. Click on OK.

8. Save the mask.

9. Define fur ther wizard masks for subsequent steps.

10.Reload the first mask.

11.Double-click on the Next -> button.

The Button Properties window opens.

12.Click on  (Select) to the right of the Format field (under Standard/Combo
Box/List Box).

13.Select a mask to be accessed by clicking on the Next button.

14.Define the previous and next masks in the same manner for all masks in the
wizard. Note that the first mask may not contain a <- Back button and the last
mask may not contain a Next -> button.

Desktop
Desktop formats allow you to configure user interface elements, levels and info
areas, as well as define new levels.

The settings are saved in a format (see Formats in the User Manual) and can be
assigned to users, groups and stations, see Assigning Desktops.

You can:

• configure how users can navigate in Aurea CRM win (define star t levels and
provide access to levels, dashboards and workflows from the icon bar or Info
menu), see Navigation on page 219.

• configure the menus in Aurea CRM win (rename or deny access to entries),
see Configuring Menus on page 222.

• configure the user interface in Aurea CRM win (colors, skins, context menu, level
headers etc.), see Configuring the User Interface on page 223.
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• add buttons to the general toolbar (templates, search, print, program calls),
see Configuring the General Toolbar on page 241.

• define level properties (masks, header, templates, conditions etc.), see Level
Properties on page 248.

• define info area settings (references, search, filter masks, conditional formatting,
tree view), see Info Area Settings on page 290.

• create parent desktops containing default settings that are extended by child
desktops that contain settings for specific departments or users, see Extended
Desktops on page 299.

• deny access to levels, see Denying Access to Levels on page 250.

• define new levels, see Defining New Levels on page 301.

Use access rights to prevent users, groups or stations from defining new levels and
accessing the desktop settings, see Defining Further Settings in the CRM.core
Administrator Guide.

Defining a Desktop
Learn how to define a desktop.

To define a desktop:

1. Select Extras > Define Desktop from the menu.

All levels (and their dependent levels) available in Aurea CRM win's main module
are displayed in the Define Desktop window along with their ID.

• Right-click in the list and select Find from the popup menu to search for a level.
You can search for either a por tion of the level's name or the level ID.

• Click on  (Load) next to the Desktop Format field to load a desktop format.
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• Click on  (Delete) to remove the format name from the Desktop Format field.

• Enable the Extended desktop to define the current desktop as a child desktop,
see Extended Desktops on page 299.

• Click on Define Levels to define new levels, see Defining New Levels on page
301.

2. Configure the navigation elements:

• Fixed Icon Bar/Fixed Info Menu/No fixed icon bar/No variable icon
bar/Transfer from root level, see Fixed Icon bar and Fixed Info Menu.

• Start Levels: Levels opened automatically when the desktop is loaded, see Star t
Levels.

3. Define the global settings:

• Menu: Deny access to and rename menu entries, see Configuring Menus on
page 222.

• User Interface: User interface settings (colors, context menu, headers, masks,
lists etc.), see Configuring the User Interface on page 223.

• General Toolbar: Define which buttons are displayed in the toolbar, see Con-
figuring the General Toolbar on page 241.

4. Define level properties, see Level Properties on page 248.

5. Define info area settings, see Info Area Settings on page 290.

6. Click on Access to deny or allow access to the desktop by specific users, groups
or stations, >> Granting and Denying Access to Desktops.

7. Click on  next to the Desktop Format field to save the format, see Saving,
Loading and Deleting Formats in the User Manual.

Note: The interface and info area settings are saved in individual formats that
are referenced by the desktop format. You therefore do not need to re-save the
desktop format itself if you only edit the interface or info area settings.

Click on  (View) to display an overview of the desktop format, see Viewing and
Printing Formats in the User Manual.

Click on Clear All to revert to the default settings.

8. Click on OK to close the window and use apply the desktop format immediately.
Click on Cancel to close the window without applying the desktop.

9. Assign the desktop to the appropriate users, groups and stations, see Assigning
Desktops.
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Note: The Define Desktop dialog always displays all elements (levels, menu
commands etc.) irrespective of the currently valid CRM process configuration,
see CRM Process Configuration in the CRM.core Administrator Guide.

Desktop Access
Desktops can be assigned to users, groups and stations

For fur ther details, see Assigning Desktops.

Users can load any desktop they are permitted to access by selecting Extras > Load
Desktop from the menu, see Granting and Denying Access to Desktops.

Assigning Desktops

To assign a desktop format to be loaded at star tup to a user, group or station:

1. Open the Rights module, see Star ting Modules on page 13.

2. Switch to the desired user, group or station record.

3. Select the desired desktop format from the desktop format field.

4. Save the record.

Desktop formats assigned to a user take precedence over desktop formats assigned
to a group or station. Desktop formats assigned to a group take precedence over
desktop formats assigned to a station. In other words, more specific settings take
precedence over more general settings.

You can grant users, groups and stations permission to load other desktop formats
in addition to their default desktop, see Granting and Denying Access to Desktops.

Granting and Denying Access to Desktops

To deny or allow access to desktop formats for specific reps, groups and stations:

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure access to.

3. Click the Access button.
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All Stations, Groups and Reps are displayed.

4. Select one of the options at the bottom left:

• Deny access for user: If this option is enabled, the Stations, Groups and
Reps lists contain a column called Lock. Enable the check box to deny the
station, group or rep access to the desktop format.

• Allow access for user: If this option is enabled, the Stations, Groups and
Reps lists contain a column called Allowed. Enable the check box to allow the
station, group or rep to access the desktop format.

Note: Deny access for user is recommended if new users, groups and stations
should generally be allowed to access the desktop. Allow access for user is
recommended if new users, groups and stations should generally not be allowed
to access the desktop.

5. Enable the appropriate check boxes in the Stations, Groups and Users lists.

If access is denied or permitted for a station or group, the access rights automat-
ically apply to all the station or group's reps. In this case, the corresponding check
boxes in the Reps list are enabled and grayed out.

6. Click on OK.

7. Save the desktop format.

Only those desktops a user is permitted to access are listed when selecting Extras
> Load Desktop from the menu.
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Navigation
The options under Navigation in the Define Desktop window are used to define
star t levels, the icon bar, and the Info menu in Aurea CRM win.

Fixed Icon bar

The icon bar contains a fixed section (top) and a level-dependent section (bottom).
The fixed section is displayed on every level.

The following options are available from the Navigation section in the Define
Desktop window:

• No fixed icon bar: Enable this option to restrict the icon bar to the level-dependent
section.

• No variable icon bar: Enable this option to restrict the icon bar to the fixed
section.

• Transfer from root level: Enable this option to determine that the level-dependent
section is always transferred from the top-most level in the hierarchy (e.g. from
the Company+Person level to the Notes level). If no level-dependent icon bar
has been defined, the predefined Aurea CRM icon bar is used.

To configure the fixed section of the icon bar:

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure.

3. Click the Fixed Icon Bar button under Navigation.

• All independent levels that are accessible based on the desktop's settings are
listed under Levels.

• All available Workflows, Dashboards and Headers are listed.
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Select a dashboard in the Dashboard list and click on  (View) to display a
preview, >> Dashboards in the User Manual.

• The current icons in the fixed section of the icon bar are listed under Icon Bar.

4. Click on  (Properties) next to the Workflows, Dashboards and Headers lists
to edit the name and icon used by the entry, see Element Properties.

The name and icon used by levels are defined in the level properties, see Navi-
gation Tab on page 250.

5. To define additional headers:

a. Click on  (New) to the right Headers list.

b. Enter the desired text in the Text field.

c. Click on OK.

6. Click the Number Range button to define a range of IDs for headers in this
desktop, to prevent overlaps in IDs between hierarchic desktops. Existing header
IDs are adjusted accordingly, see Extended Desktops on page 299.

7. You can determine that the headers (i.e. the individual menu groups) in the icon
bars are minimized when Aurea CRM is star ted:

a. Select the desired entry under Headers.

b. Click on  (Properties).

c. Enable the Contracted check box.

Note: This setting is applied globally, irrespective of whether you enable the
Contracted check box in the fixed icon bar settings, the fixed Info menu or
level properties, see Navigation Tab on page 250.

d. Click on OK.

8. Select an item in the Levels, Workflows, Dashboards or Headers list and click
on  (Add) to add the entry to the icon bar. You can also double click on an item
to add it to the icon bar.

Note: Workflows and dashboards are not displayed as active levels for technical
reasons.

• Select an item in the Icon Bar list and click on  (Delete) to remove the entry.

• Click on  (Delete all)to delete all entries.

• Drag entries in the Icon Bar list to the desired position to change the order of
the entries.

• Click on Add Separator to add a separator to the menu.
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9. Click on OK.

10.Save the desktop format.

The level-dependent section of the icon bar is defined in the level properties,
see Navigation Tab on page 250.

Fixed Info Menu

The Info menu contains a fixed and a level-dependent section.

The fixed section corresponds to the left por tion of the Info menu. The fixed section
is displayed on every level.

To configure the fixed section of the Info menu:

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure.

3. Click the Fixed Info Menu button under Navigation.

4. Levels, dashboards and workflows are added, deleted and ordered in the same
way as in the fixed icon bar, see Fixed Icon bar.

5. Select an entry in the Workflows, Dashboards or Headers list and click on 
(Properties) to edit the name and icon used by the entry, see Element Properties.

The name and icon used by levels are defined in the level properties, see Navi-
gation Tab on page 250.

6. To insert a separator:

a. Click on  (New) to the right of the Headers list.

b. Enter the Text. (This text is not displayed in the Info menu.)

c. Click on OK.

d. Double-click on the entry to add it to the menu.

e. Drag the entry to the desired position in the Info Menu list.

A separator is displayed at this position in the Info menu.

7. Click on OK.

8. Save the desktop format.

The level-dependent section of the Info menu is defined in the level properties,
see Navigation Tab on page 250.

Element Properties

To edit the properties of elements in the fixed icon bar or fixed Info menu:

1. Select the desired element in the window used to define the icon bar or Info menu.

2. Click on  (Properties) or right-click in the list and select Properties from the
popup menu.

3. Enter the name of the new entry in the Text field.

Click on Default Text to revert to the original name.
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4. Enter "&" preceding the letter to be used as a shortcut to access workflows and
dashboards. (You need to use Ctrl+Shift+<letter> to access entries in the icon
bar.)

5. Click on Choose Icon to select an icon to be displayed next to the text.

6. Choose a predefined icon from the list of Available Icons or click on  to load
a bitmap.

Click on Default Icon to revert to the default icon.

7. Click on OK.

Start Levels

You can determine which levels, dashboards and workflows are opened automati-
cally when the desktop is loaded:

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure.

3. Click the Start Levels button under Navigation.

All levels that are accessible based on the desktop's settings are listed under
Levels.

4. Levels, dashboards and workflows are added, deleted and ordered in the same
way as for the fixed icon bar, see Fixed Icon bar.

Note: You need to first add any parent levels before you can add child levels.
Otherwise you receive an error message.

5. Click on OK.

6. Save the desktop format.

Note:  For users with a desktop format that includes star t levels the Load last
settings option at login has no effect. The defined star t levels are loaded instead.

Global Settings
Learn how to configure global settings.

Configuring Menus
Learn how to configure and manage menus.

You can rename menu entries and prevent users from accessing them. Entries to
which access is denied are grayed out in the menu.

To configure the menus in Aurea CRM win:

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure.
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3. Click on Menu under Global Settings.

All available menu entries are listed under Menu.

4. Enable or disable the check boxes to grant or deny users access.

Click on Deny All to disable all entries. Click on Allow All to enable all entries.

5. To rename menu entries:

a. Select the entry you wish to rename.

b. Click on Properties.

c. Enter the desired name in the Text field.

d. Enter a Hotkey, if desired.

Click on Default Settings to revert to the default name and hotkey.

e. Click on OK.

6. Click on Default Settings in the Define Menus window to revert to the default
settings at any time.

7. Click on OK.

8. Save the desktop format.

Configuring the User Interface
Learn how to configure and manage user interface.

To configure the Aurea CRM win user interface:

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure.
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3. Click on User Interface under Global Settings.

4. Define the necessary settings. The individual tabs are described below.

Click on Reset All to revert to the default settings.

5. Click on  (Save) next to the Format Name field to save the format, see Saving,
Loading and Deleting Formats in the User Manual.

6. Click on OK.

7. Save the desktop format.

Note:  If you are editing an existing format, you only need to save the user interface
format and not the desktop format, as the desktop format only contains a reference
to the user interface format.

The settings are applied to all levels.

Users can configure some of the user interface settings themselves by selecting
View > Desktop Properties form the menu, see Configuring the Display in the User
Manual. These user settings are automatically saved for each user in an "Interface"
format. The user settings take precedence over the desktop settings.

Colors Tab
Learn how to define the colors used by Aurea CRM win.

Use this tab to define the colors used by Aurea CRM win:
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• Color scheme: Select a color scheme from the drop-down list.

• Active level: Background color of the active level.

The Different background color for active info area option on the Misc. tab
must be enabled for this setting to take effect, see Misc. Tab on page 237.

• Summary index card: The color of the summary index card and the active level
in the icon bar.

• Context menu: Background color of the context menu.

• Frame: Color of the context menu's border. Color of all-day appointments displayed
in the calendar, see All-day Appointments in the User Manual.

• Fixed Icon Bar: Background color of the fixed icon bar and its Header.

• Icon Bar: Background color of the icon bar and its Header.

• Sample: Preview of your settings.

• Header: You can choose the colors used by the gradient in the header. Click on

 to switch between a horizontal and a ver tical gradient.

• Hyperlinks:

• Always underlined: Determines whether links (e-mail address, URLs, links to
other records) are always underlined.

• Choose color: Enable this check box to be able to select a Color for hyperlinks.
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Note:  Users can change these color settings by selecting View > Desktop
Properties from the menu. The user settings take precedence over the desktop
settings. You can deny users' access to the Colors tab in the Desktop Properties
window, see User Rights Tab on page 241.

To define a full color scheme, you also need to define settings for masks, lists and
tables, see Skins Tab on page 226.

Skins Tab
Use the Skins tab to define global color schemes (skins) for masks, lists and tables.

For fur ther details, see Defining a Global Color Scheme on page 205.

You can define up to three formats for each.

Users can change the color scheme by selecting View > Desktop Properties from
the menu (Colors tab, Global mask colors section), see Colors in Aurea CRM in
the User Manual.

1. Click on  (Load) in the Mask column to load an existing format. You can only
select formats defined for the Company+Person level.

2. Click on  (Multi-language input) in the Name column and enter the name of
the mask, list or table. If you do not enter a name, the mask, list or table is not
listed in the Desktop Properties window.

3. Enable the check box in the Default Value column to determine which mask, list
or table settings should be used by default.
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Click on  (Delete)to delete the selected entry.

4. Enable the Apply font settings option in the Tables pane to apply the font settings
defined for lists (list header and list rows) to tables, see List Properties on page
196.

5. Click on  under Summary Index Cards to load the summary index card to be
used by default.

6. Save the format.

Calendar Tab
Use the Calendar tab to define the colors used by the calendar.

These settings are used in the Calendar, Resource View and Overlapping Appoint-
ments levels.

You can also define level-specific calendar settings, see Calendar/Marketing Calen-
dar Tabs on page 284. If no specific settings have been defined for a level, the inter-
face settings are used.
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Colors

You can define different colors for the different types of appointments (activities,
tasks, To-Dos, absences). A stripe in the chosen color is displayed to the left of the
appointment. You can also define conditions to display appointments in specific
colors if they meet cer tain conditions, e.g. "Visits" with the Status "Completed" are
displayed in blue.

• Click on  (Multi-language Input) to edit the text of the appointment.

• Click  (Condition) to edit the condition.

• Click  (Color) to select the color.

To define a color for a specific appointment type:

1. Click on  (New) and select the desired appointment type, e.g. Activity.

2. Enter a name for the appointment in the Edit Text window (e.g. "Visit") and click
OK.

3. Define the condition, e.g. "Activity = Visit AND Status = Completed".

4. Select the desired color, e.g. blue.

5. Click on OK.

6. Save the interface format.

Visits with the status "Completed" are now displayed with a blue stripe in the
calendar.

Settings

• Morning from/to: Determine the time period to be classified as morning and
choose a color.

• Afternoon from/to: Determine the time period to be classified as afternoon and
choose a color.

• Public holidays: Enable the Display check box and select a color to be used for
public holidays.

• Remainder: Select a color to represent those times that are neither defined as
morning nor afternoon etc.

• Today: Choose the color used to highlight the current date.

• Only work hours: Enable this check box to restrict the calendar display to those
times defined as either morning or afternoon.
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• Small calendar as popup: Enable this check box to determine that the small
calendar is only accessible using  (Popup Calendar) in the appointment
overview's command bar.

If this option is disabled, the small calendar is displayed at the bottom right.

• Steps: Determine whether the calendar should display intervals of 15 minutes,
30 minutes or 1 hour.

• Working week/to: Use these fields to determine which days of the week are
considered workdays.

• Representative: Determine which appointments should be displayed in the
calendar (the current rep's, the current rep's group's, the group leader's, and the
current rep's deputy's appointments).

You can select multiple entries. If you do not select an entry, this is treated as
selecting all entries.

Note:  Users can change these settings using the  (Filter view) and  (Settings)
buttons in the Calendar, see Appointment Settings and Calendar Interface Settings
in the User Manual. The user settings are saved in the pro1.cfg file in the user
directory. The user settings take precedence over the desktop and interface settings.

You can deny users' access to the calendar settings, see Calendar/Marketing Cal-
endar Tabs on page 284.

Analyses Tab
Use the Analyses tab to define the appearance of bar and pie charts in analyses.

These settings apply to all analyses (in the database and Analysis modules, and
in the Sales Funnel info area in the BTB version).

• Visible Bars: Number of visible bars in bar charts. You can choose to display up
to 10 bars.
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This setting is ignored if you are using ComponentArt graphics.

• Click on  (New)to define a new color for the bar or pie chart. The button is
grayed out if you have already specified 10 colors, and you cannot define any
fur ther colors.

• Click on  (Delete) to remove the selected color from the list.

• Click on  to change a color.

Note:  Users can change these settings by selecting View > Desktop Properties
from the menu. The user settings take precedence over the desktop and interface
settings.

You can deny users access to the Analyses tab in the Desktop Properties window,
see User Rights Tab on page 241.

Context Menu/Header Tab
Use the Context Menu/Header tab to configure global settings for the context menu
and header.

Context Menu

• Docked: The context menu is docked on the right edge of the mask when Aurea
CRM is star ted.
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The context menu can be positioned freely by dragging it to the desired position.
If users switch to another info area and then return to the previous info area, the
context menu is displayed at its last position.

• Free-floating: The context menu is displayed at the top left of the mask below
the header when Aurea CRM is star ted.

The context menu can be positioned freely by dragging it to the desired position.
If users switch to another info area and then return to the previous info area, the
context menu is displayed at its last position.

• Popup only: Enable this option to determine that the context menu is only
available as a popup menu and using the  (Context Menu) button.

Note: The context menu can always be accessed with a right-click in the mask
or list, irrespective of the options enabled here.

• Remember last setting: The context menu is displayed in the same position as
when Aurea CRM is closed when the application is star ted.

• Display opened: Enable this option to open the context menu when a level is
opened.

• Show edit buttons: Determines whether the Edit, Save, Load and Cancel buttons
are displayed in the context menu instead of as buttons in the header.

Note: You can also determine where the edit buttons are displayed for individual
levels, see Header Tab on page 264. Level-specific settings take precedence over
any settings made here.

• Size: Size of the context menu (between 20 and 40% of the width of the level).

• Font: Click the Context Menu button to configure the font, style, size, color etc.
of the context menu's header. Click the Context menu entries button to configure
the font, style, size, color etc. of the context menu entries.

Header

• Search icon: Determines whether the Search icon ( ) is displayed in the header.

• Print icon: Determines whether the Print icon ( ) is displayed in the header.

The Print button can also be displayed in the general toolbar, see Configuring
the General Toolbar on page 241.

• Context menu icon: Determines whether the Context Menu icon ( ) is displayed
in the header.
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• Dependence icon: Determines whether the Dependence icon ( ) is displayed
in the header.

• Transfer icon: Determines whether the Transfer icon ( ) is displayed in the
header.

• Document icon: Determines whether the Document Overview icon ( ) is
displayed in the header.

• Level icon: Enable this check box to display the corresponding icon next to the
name of info area in the header.

• Show reference: Enable this check box to display the current record's reference
in the header (e.g. "Company:<company name>" in the Company+Person  level)
instead of the name of the level.

• Header info: Determines what percentage of the entire width of the level header
is taken up by the header info.

If the text is longer than the defined width, the text is truncated and "..." is append-
ed to the text.

Note:  If the Only display icons option is enabled for a level (see Header Tab
on page 264), the Level icon, Show Reference and Header info settings are
ignored.

• Navigation arrows: Determines whether the navigation buttons are displayed in
the header. (This setting does not affect the navigation buttons in the summary
index card, which are always displayed.)

• Spreadsheet icon: Determines whether the Excel icon ( ) is displayed in the
header.

Note: You can also determine whether the Search, Print, Context Menu,
Dependence, Transfer and Document Overview buttons are displayed for
individual levels, see Header Tab on page 264. Level-specific settings take
precedence over any settings made here.

• One line: The header info is displayed in a single line.

• Two lines: The header info spans two lines.

• Font: Use these buttons to determine the font, size, color, etc. of the header info,
header buttons and display information.

Note:  Users can change some of these settings by selecting View > Desktop
Properties from the menu. The user settings take precedence over the desktop and
interface settings. You can deny users access to the Context Menu/Header tab in
the Desktop Properties window, see User Rights Tab on page 241.

Icon Bar Tab
Learn how to configure the icon bar.

Use the Icon Bar tab to configure the icon bar:
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Icon Bar

• Adjust to screen resolution: The width of the icon bar is adjusted according to
the screen resolution.

• With border: The icons in the icon bar are displayed with a dark border (similar
to buttons).

• Hot track mode off: Enable this option to display icons in color at all times.

Otherwise icons are only displayed in color when the mouse cursor is moved over
them or the corresponding level is active.

• Display header icon on the right: Determines that the header icon is displayed
to the right of the header text ( ).

• Show navigation buttons: Enable this check box to use navigation buttons at
the top and bottom of the icon bar to scroll the icon bar. If this option is disabled,
a scroll bar is displayed to the left of the icon bar instead.

• Show text: Select this option to only display text entries the icon bar (left-aligned).

• Show icon: Enable this option to only display icons in the icon bar.

• Show text and icon: Both the text and icon are displayed in the icon bar (the
text is centered beneath the icon).

• Display icon next to text: The text is displayed to the right of the icon.

• Separator width: The width of the separators between entries.
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Logo

• Default Value: Enable this option to display the default Aurea logo at the top of
the icon bar.

• Change icon: Enable this option to choose your own bitmap to display at the top
of the icon bar.

Note: The maximum width of the logo is the width of the icon bar. The maximum
height is 30 pixels. Larger images are scaled down accordingly.

Font

You can change the font, size, color etc. of the Headers (group titles) and entries
in the Icon Bar.

Width

• Automatic: Select this option to determine the width automatically, based on
whether the name, icon or both are displayed.

• Fixed size: Select this option to set the width of the icon bar to a fixed value.
Enter the width in pixels in the Width field.

Note:  Users can change some of these settings by selecting View > Desktop
Properties from the menu. The user settings take precedence over the desktop and
interface settings. You can deny users access to the Icon Bar tab in the Desktop
Properties window, see User Rights Tab on page 241.

Masks Tab
Learn how to configure global settings for masks, lists and document fields.

Use the Masks tab to configure global settings for masks, lists and document fields:
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General

• Disable read-only fields: Determines whether read-only fields are displayed with
a gray background in edit mode.

• Highlight catalog fields: Determines whether the color settings defined for
catalogs in the mask (in the Mask Generator, Tab Group Properties window,
Colors tab) are also applied to catalog fields in edit mode, see Colors Tab on
page 224.

• Show telephone buttons: Determines whether the telephone icon is displayed
in telephone fields. Click on  (Make Call) to dial the number. Note that
CRM.phone must be installed.

• Use date navigator: Enable this option to use Aurea CRM's dedicated date and
time fields, see Entering the Date Directly in the User Manual.

Disable the option to use normal input fields to enter date and time values.

• Masked input fields: Enable this option to use masks (input formats) defined for
specific fields in the data model, see Mask in the CRM.core Administrator Guide.

• Do not select fields  contents: Determines whether the field contents in masks,
lists and tables are automatically selected when a field receives focus.

• Full screen mask: Enable this check box to adjust the mask to the screen
resolution, see Screen Resolution.

• Move mask buttons to context menu: Enable this option to determine that
buttons defined in individual masks are only displayed as entries in the context
menu. This setting can be overridden by individual buttons by enabling the Never
in context menu option in the Mask Generator, see Button Properties on page
188.

• Horizontal/Vertical position: Determine how far (in grid units, see Grid Units)
the mask should be displayed from the left and top edge of the window. This
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settings can be changed for individual masks (Position and Size section) in the
Mask Generator, see Mask Properties on page 175.

• Do not highlight mandatory fields: Mandatory fields are not highlighted.

• Display mandatory fields with frame: A frame is displayed surrounding
mandatory fields. The color of the frame is defined in the Mask Generator (Tab
Group Properties), see Colors Tab on page 224.

• Display mandatory fields with *: Mandatory fields are indicated using "*".

• Display mandatory fields with ! : Mandatory fields are indicated using "!".

• No icons in fixed catalogs: Displays catalogs without icons.

• Display icons in field: Displays icons directly in catalog fields.

• Display icons next to field: Displays catalog icons to the right of catalog fields.

Click on Fixed Catalog to configure the icon settings for individual catalogs:

These settings take precedence over the global settings (No icons in fixed catalogs,
Display icons in field and Display icons next to field).

Masks

Copy field contents with right-click: Enable this check box to allow users to copy
the contents of read-only and link fields to the clipboard by selecting Copy from the
popup menu.

Lists

• Activate row by positioning cursor: Enable this check box to allow users to
select a record by positioning the mouse over the left border of the list.

• Sort dependent levels with a click: Enable this check box to allow users to sor t
dependent levels by clicking on column headers in list view, see Sorting Records
in the User Manual.
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• Sort independent levels with a click: Enable this check box to allow users to
sort independent levels by clicking on column headers in list view, see Sorting
Records in the User Manual.

• Vertical position: Determines how far from the top edge of the window the mask
should be displayed. The units are grid units, see Grid Units.

Note: This option is only available if the Vertical Position option in the General
pane is disabled.

Documents

Use these options to determine where users can search for documents and what
information is displayed in document fields, see Document Management in the User
Manual.

• File system (save path): Clicking on  (Load) in document fields allows user to
search for documents in the file system. The path to the file is entered in the
document field; the document is not uploaded to the database.

Note:  Select a field with at least 256 characters to display the path.

• File system (save in database): Clicking on  (Load) in document fields allows
user to search for documents in the file system. The selected document is saved
in the database.

• Document management: Clicking on  (Select Document) opens the search
mask for the Document info area.

• Customer documents: Clicking on  (Select Document) opens the search mask
for the Customer Document info area. This is only possible if the current info
area is dependent on the Company or Person in Company info area.

• Document directory: Enable this option to determine that the directory specified
under Extras > Document Directories is opened when adding external documents.
Otherwise the My Documents directory is opened.

• Show ID: Enable this option to display the document ID (e.g. A100-1) in document
fields.

• Show title: Enable this option to display the name of the document in document
fields. This setting only applies to view mode. The document ID is always displayed
in new and edit mode.

• Show reference: Enable this option to display the document's reference in
document fields. This setting only applies to view mode. The document ID is
always displayed in new and edit mode.

Misc. Tab
Learn how to configure additional global interface settings.

Use the Misc. tab to configure additional global interface settings:
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Summary Index Card

• Show links: Enable this option to determine that links to the parent record are
displayed in the summary index card. Users can click on a link to switch to the
parent level, >> Summary Index Card in the User Manual.

• Link area: Enable this option to determine that users can click anywhere in the
summary index card to access the parent level. No links are displayed in the
summary index card.

• Display level icon: Determines whether the parent level's icon is displayed in
the summary index card.

• Display level text: Determines whether the name of the parent level is displayed
in the summary index card.

Levels

• Arrange all info areas vertically: Enable this option to determine that the parent
level is displayed to the left of child levels. If this option is disabled, the parent
level is displayed above the child levels.

• Open all info areas in integrated view: Determines whether all levels are opened
in integrated view, >> Integrated View in the User Manual.

• Show info area name in tooltips: Determines whether the name of the level is
displayed when the positioned anywhere over the mask or list background.

• Different background for active info area: By default, levels are displayed with
the background defined for the corresponding mask, see Mask Properties on page
175. If this option is enabled, the color selected under Active Level on the Colors
tab in the user interface settings is used instead, see Colors Tab on page 224.

• Show info area relationship indicators: Enable this option to display a small
arrow pointing from the parent to child info area in integrated view.
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New Documents

You can determine whether document records should be added As standard docu-
ments, As OLE documents or whether the user should decide (Query before
adding), see Document Management in the User Manual.

Rep Catalog

If the database contains a large number of reps, opening the rep catalog in tree
view can impact on performance, see Rep List in the User Manual.

If more than 10,000 entries are present, a warning is displayed, and the user can
decide to cancel the process. Only the first 70 dependent entries are displayed for
each entry.

The following options are available:

• Start with list: The rep list is displayed as a list.

• Start with tree: The rep list is displayed as a tree.

• Only display list: The rep list is opened as a list, and users cannot switch to the
tree view.

• Only display two levels: Enable this option to determine that the display is limited
to two levels in the hierarchy: a user and that user's group. If this option is
disabled, the hierarchy is not limited to two levels, and each branch can be
expanded fur ther.

• Start with rep view: When opening the rep list in tree view, reps are listed on
the top-most level.

• Start with group view: When opening the rep list in tree view, groups are listed
on the top-most level.

E-mail

• Save as activity: Enable this option to determine that the Activity level should
opened in new mode if a user clicks on the link or e-mail icon in an e-mail field.

• Default values: Specify any default values for activities added by clicking in
e-mail fields, see Defining Default Values in the User Manual.

• Mask: Select the mask to be used when adding the activity record.

Miscellaneous

• Show tooltips: Determines whether tooltips are displayed, e.g. for entries in the
general toolbar and icon bar.

Note: You need to select a Unicode font for tooltips in the Windows display
settings to display double-byte characters in tooltips.

• Display shortcut in tooltips: Determines whether keyboard shortcuts are also
displayed in tooltips.

• Do not query reciprocal relationships: Whenever a relationship is added, the
system asks the user whether a reciprocal relationship should be added as well.
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Enable this option to suppress the prompt. The reciprocal relationship is then
added automatically, see Relationships in the User Manual.

• User-specific transfer formats: When loading transfer formats, the Global
formats option is enabled by default, see Global Formats in the User Manual.
Enable this option to determine that the Global formats option should be disabled
by default.

• Document button always active: By default, the Document context menu entry
(or button) is only active if documents are present for the current record. Enable
this option to determine that the Document context menu entry (or button) should
always be active. This setting can improve performance when switching between
records, as the system no longer checks whether any documents are present for
the current record.

Dialog Boxes Tab
Learn how to configure multiple search windows in Aurea CRM win.

Use the Dialog boxes tab to configure a number of the search windows in Aurea
CRM win:

1. Select the desired search from the Dialog box list.

2. Click on  (Edit).

The Field Selection is displayed.

3. Select the fields to be displayed in the search results or load an existing field
format.

4. Click on OK.

The selected fields are listed under Hit List.

5. Save the interface format.
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User Rights Tab
Use the User Rights tab to determine which tabs users can access in the Desktop
Properties window

For fur ther details, see Configuring the Display in the User Manual.

Enable the corresponding check box under Tabs to allow users to access the tab.

If you deny access to all tabs, the View > Desktop Properties menu option is set
inactive.

Configuring the General Toolbar
Learn how to define buttons in general toolbar.

To define the buttons in the general toolbar (see General Toolbar in the User Man-
ual):

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure.

3. Click on General Toolbar under Global Settings.
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4. Define the desired buttons:

• Click  (New) under New - Templates to define a button used to add new
records, see New - Template on page 242.

• Click  (Edit) under Search list to define a button used to search in specific
levels, see Search on page 244.

• Use the Print check box under Active Entries to determine whether the 
(Print) button is displayed in the general toolbar, see Printing in the User
Manual.

• Click  (New) under Program Calls to define a new program call button,
see Program Calls on page 245.

Drag entries in the New - Templates and Program Call lists to change their order.

5. Enable the corresponding Use Default check box under New - Templates to
determine which template is accessed if a user clicks on the New button in the
general toolbar directly (as opposed to selecting an entry from the list).

6. Enable and disable entries in the Active Entries pane to disable cer tain buttons
without needing to remove them from the desktop format.

7. Use the Active check box under Program Calls to enable or disable individual
entries.

8. Click on OK.

9. Save the desktop format.

The defined buttons are available in all levels.

New - Template
Global new templates allow users to add new records without needing to switch to
the corresponding level.

For example, you could define new templates for different types of companies
(customers, par tners etc.) that open a mask with suitable default values.

New template buttons can only be added to the general toolbar for independent
levels. (For details on defining level-dependent new templates, see New - Templates
Tab on page 277.)

You can also use new template buttons to initiate triggers and workflows.

To define a new template button:

1. Click on  (New) under New - Templates in the General Toolbar window.
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2. Enter a Name.

3. Select the Level the new record should be added in. You can only select
independent levels.

4. Enable the Automatically save records check box to determine that records are
added using the default values and saved automatically.

Example: Certain standard tasks (e.g. writing minutes for a meeting) can easily
be created and saved with just a single click.

5. Select the Mask to be displayed when adding the record. If you do not choose a
mask, the standard mask is used.

6. The info areas that new records can be added to are listed in the Info Area
column. The available info areas depend on the selected Level. Enable the
corresponding check boxes next to the info areas.

For example, the Company and Person in Company info areas are available in
the Company+Person level. If you enable both Company and Person in Compa-
ny,a new company with a new person is added. If you only enable Person in
Company, only a new person is added (to the current company).

7. Load a set of Default Values for the new record or enable the User Default
Values check box to apply the default values defined by the user, see Defining
Default Values in the User Manual.

All default values are applied to the new record in the following order:

a. user-defined defaults,

b. default values defined in the Rights module,

c. default values of triggers defined in the access rights, if no trigger is selected
under Trigger (see below),

d. the default values selected in the Default Value field or the default values
assigned to the trigger selected under Trigger (see below).
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8. You can choose a non-interactive trigger to be executed in the mask, see Defining
Triggers in the CRM.core Administrator Guide.

Note: You can only select triggers defined for the corresponding info area.
Alternatively, enable the Trigger radio button and select a non-interactive new
template trigger.

9. Click on OK.

10.Save the desktop format.

To star t interactive triggers or workflows using a new template button:

1. Click on  (New) under New - Templates in the General Toolbar window.

2. Enter a Name.

3. Enable either the Trigger or Workflow radio button.

4. Load the desired format.

Note: You can only load interactive triggers that contain the Action "Add new",
see Add New in the CRM.core Administrator Guide.

5. Click on OK.

6. Save the desktop format.

Note:  If you define a global new template for the Resources level, you can also
access the Search drop-down list, see Special Case: New Templates in the Calendar.

Search
You can add buttons to the general toolbar used to search in cer tain levels.

This allows users to search for specific information (e.g. companies or activities)
from within any level. If a special search exists for the level (e.g. the company
search), this search is opened, otherwise the default search mask for the level is
opened, see Searching in the User Manual.

To define a search button:

1. Click on  (Edit) under Search list in the General Toolbar window.
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2. Select the Level to search in using the button.

3. Click Add. (Alternatively, double-click on the desired entry.)

The selected level is listed under Search list.

Double click on an existing entry, or select the entry and click on Delete to remove
the entry again. Drag entries in the Search list to change their order.

4. Click on OK.

5. Save the desktop format.

A search button is displayed in the general toolbar that provides access to the
selected entries:

Program Calls
You can add buttons to the general toolbar that open external applications, other
Aurea CRM modules or web pages. You can define up to 20 program call buttons.

To define a program call button:

1. Click on  (New) under Program Calls in the General Toolbar window.
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2. Enter the path to the desired application in the Shortcut field or click on  (Load)
to select the target file (*.exe, *.com or *.bat).

To open a web page, enter the target URL in the Shortcut field. (Leave the
Working directory and Parameters fields empty in this case.)

3. If you selected a target using the  (Load) button, the Working directory is
entered automatically. Otherwise enter the desired path.

4. Enter any parameters in the Parameters field.

5. Enter the Text to be displayed on the button.

6. Determine what should be displayed on the button under Icon:

• Use default: The default icon for program calls is displayed.

• Use associated: The icon associated with the application is displayed.

• Select Icon: Click on this button to choose from the predefined icons or to load
your own bitmap.

7. Enable the Display icon option to display just the icon. Enable the Display text
and icon option to display both the text and the icon.

8. Click on OK.

9. Click on OK in the General Toolbar window, and save the desktop format.

The program calls are displayed in the toolbar:
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Opening Documents

You can open documents using buttons in the general toolbar:

1. Click on  (New) under Program Calls in the General Toolbar window.

2. Click on  (Load) to the right of the Shortcut button.

3. Select the desired document.

4. Enter a Text for the button and select and configure the Icon settings.

5. Click on OK.

6. Click on OK in the General Toolbar window, and save the desktop format.

The button is displayed in the general toolbar:

Accessing Records

You can access Aurea CRM records that are required frequently using buttons in
the general toolbar:

1. Switch to the desired record.

Note: You can only access records in independent info areas from the general
toolbar.

2. Select Edit > Copy Link to Clipboard from the menu.

3. Select Extras > Define Desktop from the menu.

4. Load the desktop format you wish to configure.

5. Click the General Toolbar button.

6. Click on  (New) in the Program Calls pane.

Click in the Shortcut field and press Ctlr+V or select Paste from the popup menu
to paste the link to the record.

7. Enter a Text for the button and select and configure the Icon settings.

8. Click on OK.

9. Click on OK in the General Toolbar window, and save the desktop format.

The button is displayed in the general toolbar:
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Level Properties
Levels display data from one or more info areas (e.g. Company+Person).

You can customize levels in the Aurea CRM win main module:

1. Switch to the level you wish to configure.

2. Select Extras > Define Desktop from the menu, see Defining a Desktop on page
215.

3. Load the desktop format you wish to configure.

If a level's properties have been configured, a small red tick is displayed below
the level icon.

4. Click the Level Properties button or double-click on the desired level in the list
of Available Levels. (You can also right-click on the level and select Properties
from the popup menu.)

The Properties - <Level (ID)> window is opened.

5. All "variations" of the selected level are displayed to the left:
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• The level class as "Default Configuration" (in this case with ID "12000" for
Mailing).

• The levels included in this level class (in gray): in this case Mailing and Edit
Mailing (IDs "12001" and "12002").

• The parent levels: The Mailing level can be opened from the Company+Person
, Day Overview and Resources levels; the Edit Mailing level can be opened
from the Marketing Activity level.

The currently active combination of parent levels and levels is displayed below
the tree.

6. Select the desired entry:

• Click on the Default configuration entry to change common settings for all
variations of the selected level.

• Click on one of the available parent levels to change the settings (e.g. buttons)
for that combination of parent level and level only.

7. You need to disable the Use default configuration check box before you can
configure settings for a specific combination of level and parent level.

8. Configure the desired settings. The individual tabs are described in the following
sections.

Note:  Not all tabs are available for all levels. For example, you cannot access
the Search tab for levels without a search function (e.g. Appointment Overview,
Calendar, etc.).

9. Click on OK in the Properties - <Level (ID)> window.

10.Save the desktop format.
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Denying Access to Levels
Learn how to deny access to specific levels in the desktop settings.

These settings are cumulative, i.e. if access is denied to levels in a parent desktop,
access is also denied to these levels in any child desktops, see Extended Desktops
on page 299.

• Disable the appropriate check boxes to deny access to the combination of levels:

In this example, the user cannot access the Mailing level from the Day Overview
level, nor the Edit Mailing level from the Marketing Activity level.

If you disable the check box next to the Default Configuration entry, the user
cannot access the level at all.

Note: These desktop settings only deny access to levels, not to info areas.Info
area access is defined in the Rights module, see Defining Rights at the Info Area
Level in the CRM.core  Administrator Guide. If you deny access to the Activity info
area, access is automatically denied to all levels that display activity data (Day
Overview, Activity Overview etc.).

You can grant access to processes (levels, menu options, buttons) in the CRM
Process Configuration level, either across the entire system or for specific roles,
see CRM Process Configuration in the CRM.core  Administrator Guide.

Navigation Tab
Use the Navigation tab to configure the level-dependent section of the icon bar and
Info menu.

Level dependent sections are only displayed in the specific level they are defined
for. The level-dependent section of the icon bar is displayed below the fixed section;
the level-dependent section of the Info menu is displayed to the right of the fixed
section.
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Icon Bar/Info Menu

• Use default: Determines that the default Aurea CRM settings are used.

• Empty: Determines that the level-dependent sections of the icon bar and Info
menu are not displayed.

• Custom: Click the Define buttons to configure the level-dependent section of the
icon bar and Info menu. Define entries in the same way as for the fixed section,
see Fixed Icon bar and Fixed Info Menu.

You can add the following levels to the icon bar and Info menu:

• all independent levels,

• all levels that are children of the current level,

• the current level's parent level.

You can copy the icon bar and Info menu settings to other levels:

1. Select the level whose settings you wish to copy in the Define Desktop window.

2. Select Copy Icon Bar and Info Menu from the popup menu.

3. Select the level you wish to apply the settings to.

4. Select Insert Icon Bar and Info Menu from the popup menu.

Note:  Entries that open dependent levels are not copied if the levels are not
dependent on the target level. Example: The Company+Person icon bar accesses
the Activity level; this entry is not copied to the Absence level.

Change Text and Icon

Click the Change Text and Icon button to change the keyboard shortcut and the
text and icon displayed. Configure the text and icon as for the fixed section of the
icon bar and Info menu, see Element Properties.
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Masks/Lists Tab
Use the Masks/Lists tab to determine the mask and list formats.

used by the Default View (each level in a separate window) and Integrated View
:

For fur ther details, see Integrated View in the User Manual.

Default View/Integrated View:

Mask: Select the original mask (accessible via View > Original Mask from the
menu).

List: Select the list to be used.

Mandatory mask: Enable the Mandatory mask check box to determine that the
user cannot load another mask. If the check box is disabled, the mask is defined
as the original mask. The original mask is loaded the first time a level is opened,
and can be reloaded at any time by selecting View > Original Mask from the menu.

Note:  By default, all settings defined by users under View > Define List Format
(font, number and contents of columns, sum total etc.) are applied from the user's
settings. Enable the Do not load last list settings check box to prevent user settings
from being applied.

Always open level with list: Determines whether the level is always opened in list
view.

Always open level with mask: Determines whether the level is always opened in
mask view.

Note: These options are not available in levels that do not provide an integrated
or mask view (e.g. the company search, Day Overview etc.).

For more information on masks and lists, see Masks and Lists in the User Manual.
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Level is opened with this dashboard: Select the dashboard the level should be
opened with.

Do not load last list settings: Enable this option to prevent user-specific list settings
(font, number and contents of columns, total lines etc.) from being applied the next
time the level is opened, see Lists in the User Manual.

Filter Masks Tab
Use the Filter Masks tab to define filter masks for the level.

Filter masks are masks that display suitable information based on conditions such
as the type and status of records. For example, you could determine that activities
are displayed with different fields, colors etc. in the Activity Overview depending
on whether the activity's status is "Missed" or "Scheduled".

The following options are available:

• No filter mask: No filter mask is used.

• Use filter masks from info area: The filter masks defined for an info area in the
level are used, see Filter Masks Tab on page 296.

• Use filter masks for level: The filter masks defined for the level are used.

To use filter masks defined in the info area settings:

1. Enable the User filter masks from info area option.

2. Select the info area whose settings you wish to use from the drop-down list.
(Alternatively, select an info area from the Filter Masks From  Info Area
drop-down list and click on Switch to to display and edit the settings for the info
area.)

3. Click on OK.

4. Save the desktop format.
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Note:  If the desktop is an extended desktop, enable the Inherit configuration
option to inherit the filter masks from the parent desktop as opposed to from the
info area settings, see Extended Desktops on page 299.

To define filter masks for a level:

1. Enable the User filter masks for level option.

2. Click on  (New) to the right of the Filter Mask for Level list.

3. Select Default Mask, Integrated Mask or Summary Index Card from the popup
menu.

The Define Conditions window opens.

The info areas present in the level are displayed to the left.

4. Click on  (Condition) next to an info area and define a condition (see Conditions

in the User Manual). Alternatively, click on  (Load) under Condition: <Info
Area> to load a condition.

5. Enable the optional check box to link info areas using a logical OR (only one of
the info areas for which the optional check box is enabled needs to meet the
condition for the filter mask to apply).

Note: The optional check box applies to the condition and all other settings in
this window.
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6. You can define filter masks for the "Default configuration" that display different
data in different variations of the level:

• Determine whether the condition must be met or must not be met under
Condition: <Info Area>.

• Use the settings under Info Area: <Info Area> to determine whether the info
area must occur in the level, must not occur in the level, or whether this is
not important.

This allows you to determine that a filter mask is only applied if a level contains
a cer tain info area. For example, the filter mask for missed activities is only
displayed if the Activity Overview level includes the Company and Person
in Company info areas. If the Activity Overview is accessed from the Offer
level, the filter mask is not applied.

• Use the options under Record: <Info Area> to determine whether a record
must be present (must contain data), must not be present (must be empty)
or whether this is not important.

For example, this allows you to display a different mask in the Company+Person
level if no person records exist for a company.

7. Click on OK.

8. Select the desired mask format.

9. Click on OK.

Your settings are displayed under Filter Mask for Level.

• Click on  (Condition) to edit the settings.

• Click on  in the Mask Format column to load a different mask.

• Enable or disable the check boxes in the Default Mask, Integrated Mask and
Summary Index Card columns to determine which view the mask should be
used in.

The lines are processed sequentially. The first condition that a record fulfills is
applied. Edit the order by dragging entries with the mouse.

10.Click on OK.

11.Save the desktop format.

Summary Index Cards Tab
Learn how to configure a level's summary index cards.

Use the Summary Index Cards tab to configure a level's summary index cards:
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• For Summary Index Cards: Select the mask to be used if this level is displayed
in the summary index card.

Enable the Mandatory mask check box to determine that the user cannot load
another mask.

Enable the Overwrite predecessor levels check box to only display the summary
index card for the current level's immediate parent, if the current level has several
parents.

Example: Company - Offer - Offer Item

If the Overwrite predecessor levels check box is enabled for the Offer level,
the company is not displayed in the summary index card of the Offer Item level.

• Summary Index Cards: Select the summary index card for the current level.

Enable the Mandatory mask check box to determine that users cannot load an-
other mask.

Note: The Summary Index Card settings are only available if the current level
has a parent.

Conditional Formatting Tab
Use the Conditional Formatting tab to determine that fields should be displayed
in different colors depending on their content.

The following options are available:

• Do no use conditional formatting: No conditional formatting is applied.

• Use conditional formatting from info area: The conditional formatting defined
for an info area in the level is applied, see Conditional Formatting Tab on page
296.

• Use conditional formatting for level: The conditional formatting defined for the
level is applied.
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To use conditional formatting from the info area settings:

1. Enable Use conditional formatting from info area.

2. Select the info area whose settings you wish to use from the drop-down list.
(Alternatively, select an info area from the Conditional Formatting from Info
Area drop-down list and click on Switch to to display and edit the settings for
the info area.)

3. Click on OK.

4. Save the desktop format.

Note:  If the desktop is an extended desktop, enable the Inherit configuration
option to inherit the conditional formatting from the parent desktop as opposed
to from the info area settings, see Extended Desktops on page 299.

To define conditional formatting for the level:

1. Enable Use conditional formatting for level.

2. Click  (New) next to the Conditional Formatting for Level list.

The Define Conditions window opens.

3. Click on  (Condition).

4. Define the condition(s).

5. Click on OK.

A new line is displayed under Conditional Formatting for Level.
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• Condition: Use this column to edit or display the condition.

• Info Area: Select the info area that the conditional formatting applies to. If you
do not specify an info area, the formatting is applied to the entire mask or row
in lists.

• Field: Select the field that the conditional formatting applies to. If you do not
specify a field, the formatting is applied to all fields in the info area. To apply
formatting to more than one specific field in an info area, define additional lines
for these fields.

• Text: Enable the check box in the Text column to display the text in the selected
color.

• Background: Enable the check box in the Background column to display the
background in the selected color.

• Color: Click  (Color) to select the font or background color.

• Mask/Lists: Enable the corresponding check boxes in the Mask or Lists column
to determine whether conditional formatting should be applied in mask or list
view.

Note:  Performance may suffer when outputting a large volume of data in lists
using conditional formatting.The currently active row uses the defined text colors;
the background color is only used if the Background option is enabled in the List
Bar Properties, see Configuring the Appearance of the Selected Record on page
199.

The lines are processed sequentially. The first condition that a field fulfills is ap-
plied. Edit the order by dragging entries with the mouse.
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6. Click on OK.

7. Save the desktop format.

Sorting Tab
Learn how records are sor ted in a level.

Use the Sorting tab to determine how records are sor ted in a level:

Predefined Sort

To use a predefined sor t index:

1. Select the info area to sor t by in the top Sort Order pane.

2. Select the field to sor t records by lower Sort Order pane.

3. Determine whether records should be sor ted in Descending or Ascending order.

Note:  Predefined sor t indices are only available for independent levels (e.g.
Company+Person).
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Custom Sort

To define a customer sor t order:

1. Click the Sort button under Fields.

2. Select the fields that records should be sor ted by (up to 5 fields per info area).

3. Enable the Always open level with this sort order check box to activate the
settings.

Note:  If you want loaded selections to remain active, disable this option for the
Company+Person and Property (BTB only) levels.

Enable the Always open level with these sort fields check box to only load the
sort fields when the level is opened. If you do not enable this option and users
change the sor t order, the user settings are applied.

Allowing Users to Sort

You can determine (for each level) whether users can sor t records using the menu
(Data > Sort) or by clicking in the list header:

• Allow sorting: Disable this check box to prevent users from sorting in general.
If this option is enabled, users can search using the menu (as well as sor t lists
by clicking on the column header if Click on header to sort is enabled).

• Click on header to sort: Enable this check box to determine that users can sor t
records by clicking on the list header. If this option is disabled, users can only
search using the menu. If the check box and tick are grayed out, the settings
defined under Lists in the Masks tab of the interface settings are applied,
see Masks Tab on page 234.

Conditions Tab
Learn how to define conditions that determine which records are displayed in a
level.

Use the Conditions tab to define conditions that determine which records are dis-
played in a level:
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1. Double-click on  (Condition) to define a condition (see Conditions in the User

Manual), or click on  (Load) to load an existing condition.

Click on  (Edit) to edit the selected condition. Click on  (Delete) to delete

the selected condition. Click on  (View) to display the condition.

2. You can apply the condition to the info area as follows:

• No additional settings: The condition is inactive. Users can activate the condition
by selecting Data > Activate Conditions > <Info Area> and edit the condition
by selecting Data > Define Conditions > <Info Area>.

• The Active check box is enabled: The condition is active. Users can deactivate
the condition by selecting Data > Activate Conditions > <Info Area> and edit
the condition by selecting Data > Define Conditions > <Info Area>.

• The Mandatory Condition check box is enabled: The condition is active and
cannot be deactivated or edited by users.

Note: These conditions affect the display of records in a specific level. Use the
Rights module to define conditions affecting the display of records in info areas,
see Conditional Access to Info Areas in the CRM.core Administrator Guide.

3. The lower section of the mask contains settings applicable to child levels of the
Company+Person level:

• Person-related/Company-related/Both: Determine which option is enabled
by default when the level is opened. Users can change this setting in the Data
menu.
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This setting is only applied if you also enable the Always open level with
these conditions option.

• As fixed default The level is opened with the selected setting
(Person-related/Company-related/Both). Users cannot change this setting in
the Data menu.

• Always open level with these conditions: If this option is enabled, the level
is always opened with the selected setting (conditions and
Person-related/Company-related/Both). If the option is disabled, the settings
are loaded when the user opens the level for the first time. Once the user
changes the settings, the user settings are applied the next time the level is
opened.

4. Click on OK.

5. Save the desktop format.

Search Tab
Use the Search tab to configure the search for a level.

For fur ther details, see Searching in the User Manual. Users can load these settings
using the  (Predefined search fields) button in the search mask.
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To configure the search for a level:

1. Enable the Allow searching check box. If this option is disabled, users cannot

access the Data > Search menu entry or the  (Search) button in the level
header.

2. Determine the Search area:

• Default Value: The default search area defined for the search mask is used.

• Current context: The search is executed in the context of the current parent
record. For example, the search is only applied to activities linked to the current
person.

• Entire database: The search is executed across the entire database.

Changes made to the search area by users are not saved in the pro1.cfg file,
i.e. the level settings are reloaded each time Aurea CRM win is star ted.

3. Click on  (Edit) to the right of the Search Fields list.

4. Select up to 5 fields in the Field Selection window or load an existing format.
These fields are entered in the search mask by default.

The number to the left of the selected field shows the order in which the fields
have been selected and are displayed in the search mask.

5. Click on OK.

The selected fields are listed under Search Fields.

6. Double-click on an operator to change it.

7. Enable the Allow changes to search fields check box to allow users to choose
other fields in the search.

8. Define the Hit List:

• Click on Search Fields -> Hit List to transfer the search fields to the hit list.
Any existing fields in the hit list are removed in the process.

• Click on  (Edit) to the right of the Hit List and select the fields that should
be added to the hit list, or load an existing format. Click on OK.

The hit list is loaded when the user first opens the search. If the user changes
the hit list, the user settings are loaded in the search from then on.
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9. Enable the Use fields defined in the desktop hit list check box to load this hit
list each time the search is star ted. In this case, user-specific hit lists are not
saved.

10.Click on OK.

11.Save the desktop format.

Search settings can also be defined per info area, see Search Tab on page 295.
Select an info area from the Search from Info Area drop-down list and click on
Switch to to open the Search tab of the info area's properties.

Note:  If no level-specific configuration is defined for the search, the info area
specific configuration is used.

If you have defined both level-specific and info area-specific search settings, the
level settings are used (in addition to any search criteria defined for the info area).

If the search is accessed from a link field using , the info area settings are applied.

Special search masks (Select Person, Search Activity) are defined in the user in-
terface settings, see Dialog Boxes Tab on page 240. You can edit the special search
masks used by the Company, Person in Company and Property (BTB only) info
areas in the Mask Generator, see Mask Generator on page 169.

Use the Links tab define which data in source levels should be used as search cri-
teria when searching for records to link to, see Using Field Contents as Search
Criteria. These settings take precedence over the search fields defined for the info
area in the info area settings.

Header Tab
Learn how to configure the appearance of the level header and its entries.

Use the Header tab to configure the appearance of the level header and its entries:
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Color

Enable the Use default check box to use the global interface settings, see Colors
Tab on page 224.

Disable the check box to edit the color and gradient of the level's header. Click on

 to switch between a horizontal and a ver tical gradient.

General

Use the check boxes to determine which buttons should be displayed in the header.
If the check boxes are gray, the user interface settings apply, see Context
Menu/Header Tab on page 230.

Level Commands

To display or remove level-specific buttons (e.g. the  (Person) button in the
Company+Person level) in the level header:

1. Click the Level Commands button.

A window is opened listing all the level-specific buttons.

2. Use the check boxes next to the buttons to determine which buttons should be
displayed.

3. Click on OK.

Note: The Level Commands button is not available in custom levels and the "Default
Configuration".

Only display icons

Enable this check box to display only the level icon in the header without any text.
This setting takes precedence the Level icon, Show reference and Header Info
options in the user interface settings, see Context Menu/Header Tab on page 230.

Edit

• New: Determines whether the  (New) button is displayed in the header.

• Position of edit buttons: Use this setting to determine where the  (Edit), 
(Save),  (Delete) and  (Cancel) buttons are displayed.

• Default Values: The global user interface settings are applied, see Context
Menu/Header Tab on page 230.

• Header: The edit buttons are only displayed in the header.

• Context Menu: All edit buttons are only displayed as entries in the context
menu.
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Reference

If you are displaying the reference in the header, select the info area whose reference
should be displayed in a level containing multiple info areas, see Reference Tab on
page 292.

Special

Define any additional buttons that initiate cer tain actions (menu commands, work-
flows, triggers etc., see Defining Actions Buttons on page 266) or access other levels
(see Accessing Levels with Buttons).

Defining Actions Buttons
Learn how to define action buttons used to access header items.

To display text or define buttons used to access menu commands, workflows,
dashboards, triggers, single letters in the header:

1. Click on  (New) under Special in the Header tab.

2. Select the desired Type.

3. Click on Choose Icon to choose a predefined icon or load your own bitmap.

4. Select the desired menu command or format in the Format field.

Note:  If you are defining a button for the "Default Configuration", ensure that
you only select actions that require info areas that are present in all variations
of the level.

5. The Tooltip field contains the same text as the Format field. Edit the text to
display a different tooltip.

If you selected "Text" in the Type field, enter the text to display in the header.

6. Determine which modes the button is active in (View, New and Edit).

7. Enter a letter in the Hotkey field. This defines the keyboard shortcut Ctrl+Letter
for the button.

8. Click on OK.
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The defined buttons are displayed under Special and can be edited and deleted

using the  (Edit) and  (Delete) buttons.

Accessing Levels with Buttons

To define buttons used to access other levels:

1. Click on  (New) under Special in the Header tab.

The Header Properties window opens.

2. Enable the View option.

3. Select the desired level from the drop-down list. All levels linked to the current
level are listed.

If the desired level is unavailable:

• Define a new dependent level, see Defining New Levels on page 301.

• Define a link to the desired target level, see Links Tab on page 273.

4. Determine which modes the button is active in (View, New and Edit).

5. Enter a letter in the Hotkey field. This defines the keyboard shortcut Ctrl+Letter
for the button.

6. Click on OK.

The defined buttons are displayed under Special and can be edited and deleted

using the  (Edit) and  (Delete) buttons.

Note:  Buttons are not displayed if they access levels to which access is denied or
info levels which have been deleted in the data model.
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Context Menu Tab
Use the Context Menu tab to configure a level's context menu.

You can:

• Add entries used to access menu commands, workflows, triggers etc., see Adding
Actions to the Context Menu on page 269.

• Add entries used to access other levels, see Accessing Levels with the Context
Menu on page 270.

• Add the links defined on the Links tab, see Adding Links to the Context Menu on
page 271.

• Add entries used to display the history or tree view, see Accessing the History
from the Context Menu on page 271 and Accessing the Tree View from the Context
Menu on page 272.

• Add separators and text entries to structure the menu, see Structuring the Context
Menu on page 272.

Default Context Menu Entries

Certain functions are defined as entries in the context menu in specific levels (e.g.
Transfer to external calendar in the Activity level).

1. Disable the corresponding check boxes under Default Context Menu Entries to
remove entries from the context menu.

Click on  (Select all) or  (Clear selection) to select or disable all entries.

Note: These settings are unavailable in the "Default Configuration".
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Adding Actions to the Context Menu
Learn how to add actions to context menu.

To add actions to the context menu:

1. Click on  (New) under Special on the Context Menu tab.

2. Select the desired Type.

Select "Function" from the Type drop-down list to add functions not assigned to
the level by default. For example, you can add the Add to Favorites entry to the
context menu in levels containing records whose key is composed of the station
number and serial number.

Select "Separator" or "Text" to add entries used to structure the menu,
see Structuring the Context Menu on page 272.

3. Select the desired menu command or load the desired format in the Format field.

Note:  If you are defining the context menu for the "Default Configuration", ensure
that you only select actions that require info areas that are present in all variations
of the level. You need to use global formats for actions of the Type "Single Letter"
and "Search Condition", see Global Formats in the User Manual. If you wish to
access conditions in a level that contains multiple info areas, you also need to
select the target info area.

4. Assign the option to a Menu Group, see Structuring the Context Menu on page
272.

Entries in the same menu group are grouped together in the context menu. The
group's icon is displayed next to the first entry in a menu group, see Context
Menu in the User Manual.

5. The Text field contains the same text as the Format field. Edit the text to rename
the menu option.

6. Determine which modes the option is active in (View, New and Edit).

7. Use the options under View to determine which views the context menu entry is
available in (mask/list/default/integrated).
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8. Enter a letter in the Hotkey field. Ctrl+Alt+Letter can then be used to access the
context menu option.

9. Define a Condition for one or more info areas in the level, to determine under
what conditions the menu option should be active, see Conditions in the User
Manual.

Note:  Options such as Document or Survey are only available if a document or
questionnaire is entered in the record. Conditions have no effect on these options.

10.Click on OK.

The defined context menu options are displayed under Special and can be edited

and deleted using the  (Edit) and  (Delete) buttons.

Accessing Levels with the Context Menu
Learn how to define a context menu entry.

To define a context menu entry used to access other levels:

1. Click on  (New) under Special on the Context Menu tab.

2. Enable the View option.

3. Select the desired level from the drop-down list. All levels linked to the current
level are listed.

If the desired level is unavailable:

• Define a new dependent level, see Defining New Levels on page 301.

• Define a link to the desired target level, see Links Tab on page 273.

4. Define your settings, as described under Adding Actions to the Context Menu on
page 269.

5. Click on OK.

The defined context menu options are displayed under Special and can be edited

and deleted using the  (Edit) and  (Delete) buttons.

Note:  Context menu options are not displayed if they access levels to which access
is denied or info areas which have been deleted in the data model.
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Adding Links to the Context Menu
Learn how to add the links defined on the Links tab to the context menu, enable
the links on the Context Menu tab.

Follow the below steps:

1. Click on  (New) under Special on the Context Menu tab.

2. Select Show defined links.

3. Determine the Mode, View and Condition under which the link is displayed in
the context menu, see Adding Actions to the Context Menu on page 269.

4. Click on OK.

A "Hyperlink" entry is added to the Special list. Click on  (Edit) or  (Delete)
to edit or delete the entry.

Accessing the History from the Context Menu
Learn how to access the history in the Aurea CRM win main module, you need to
add a context menu entry for each level and info area.

Follow the below steps:

1. Click on  (New) under Special on the Context Menu tab.

2. Select History.

3. Select the desired Info Area.

4. Enter a name for the entry in the Text field (e.g. "Company History").

5. Define your settings, as described under Adding Actions to the Context Menu on
page 269.

6. Click on OK.

A "History" entry is added to the Special list. Click on  (Edit) or (Delete) to
edit or delete the entry.

Note: You can also configure access to the history from the fixed or level-dependent
section of the icon bar, see Fixed Icon bar. The current record's history is opened
when users select the entry. The history needs to be activated for each info area
in the Rights module, see Enabling the History in the CRM.core Administrator
Guide.
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Accessing the Tree View from the Context Menu
Learn how to access the tree view in the Aurea CRM win main module, you need
to add a context menu entry for each level and info area.

Follow the below steps:

1. Click on  (New) under Special on the Context Menu tab.

2. Select Tree View.

3. Select the desired Info Area.

4. Enter a name for the option in the Text field.

5. Define your settings, as described under Adding Actions to the Context Menu on
page 269.

6. Click on OK.

A "Tree View" entry is added to the Special list. Click on  (Edit) or  (Delete)
to edit or delete the entry.

Note: You can also configure access to the tree view from the fixed or
level-dependent section of the icon bar, see Fixed Icon bar. The current record is
displayed in the tree view when a user selects the entry.

You can configure the tree view for each info area, see Tree View Tab on page 297.

Structuring the Context Menu
Learn how to make entry to context menu and reorder/manage the existing entries.

Adding Text Entries and Separators

1. Click on  (New) under Special on the Context Menu tab.

2. Select either "Text" or "Separator" from the Type drop-down list.

3. Select the desired Menu Group.

4. If you selected "Text", enter the entry's Text.

5. Click on OK.
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Reordering Entries

To reposition an element within a menu group:

1. Click on an entry in the Special list and drag it to the desired position.

Repositioning Menu Groups

To change the order menu groups in the context menu:

1. Click on  (New) or  (Edit) next to the Special list.

2. Click on  (Edit) next to the Menu Group field under Action.

3. Drag the menu groups to the desired positions.

4. Click on OK.

Note: These settings are applied globally, not just to the context menu in a specific
level.

Changing Icons

An icon is assigned to each menu group. The icon is displayed next to the first entry
in the group. (No icons are displayed if the context menu is only displayed as a
popup menu, see Context Menu/Header Tab on page 230.)

To assign a different icon to a menu group:

1. Click on  (New) or  (Edit) next to the Special list.

2. Click on  (Edit) next to the Menu Group field under Action.

3. Double-click on the desired entry.

4. Choose a predefined icon from the list of Available Icons or click on  to load
a bitmap.

5. Click OK to exit the Choose Icon and Edit Menu Group windows.

Note: These settings are applied globally, not just to the context menu in a specific
level.

Links Tab
Use the Links tab to define links between levels for which no direct link exists in
the data model.

One of the info areas in the source level must however contain a custom link or a
link to an info area in the target level, see Link in the CRM.core Administrator
Guide.

Links must be defined to link records and display linked records.

273AUREA CONFIDENTIAL

Desktop

https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-3_5_8_8-Link_crm.html


You can:

• Define links between levels, see Defining Links.

• Define the target info area of custom links, see Defining Target Info Areas.

• Define default search criteria for link fields, see Using Field Contents as Search
Criteria.

Add a context menu entry with the option Show defined links enabled to display
the links defined here in the context menu as well, see Adding Links to the Context
Menu on page 271.

When a user clicks on a link (or selects the context menu option), the linked record
is opened in the target level.

Defining Links

To define a link (e.g. from the activity mask in the calendar to the Marketing Activ-
ity level):

1. Click on  (New) under Defined Links.

The Link Definition window is displayed.

2. Select the type of link in the Link type field (1:1, 1:n or n:1).

3. Select one of the info areas in the source level under Source info area (in this
case, the Activity info area in the Calendar level).
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All info areas linked to the source info area in the data model using the selected
link type are listed in the Target Info Area column. If the desired info area is not
listed, you need to add a link to the data model, see Link in the CRM.core Admin-
istrator Guide.

The index is displayed in the Index column, see Index in the CRM.core Adminis-
trator Guide.

The ID of the corresponding link in the data model is displayed in the Link ID
column, see Link IDs in the CRM.core Administrator Guide.

Defining Target Info Areas

You can define the possible target info areas for custom links in levels. If you do
not specify any info areas, all info areas whose key is composed of the record and
station number are available. (Exception: Available target info areas for links in the
Task level are predefined. However, you can add fur ther info areas.)

To define the target info areas:

1. Define a link to the desired target levels, see Defining Links.

If a user clicks on  (Find) in the source level (e.g. Ticket), only the defined
target info areas can be selected:

2. Define search default values for these links, if desired, see Using Field Contents
as Search Criteria.

Using Field Contents as Search Criteria

You can use the contents of fields in the source info area as search criteria when
linking a record via a link field. These settings take precedence over the info area
settings, see Search Tab on page 295.

To use field contents in the source info area as search criteria in the target info
area:

1. Define a link, see Defining Links.

2. Click on Search to define the search fields and values.
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3. Determine the Search area:

• Default Value: The default search area defined for the search mask is used.

• Current context: The search is executed in the context of the current parent
record.

• Entire database: The search is executed across the entire database.

4. Click on  (Edit) to the right of the Search Fields list.

5. Select up to 5 fields that should be transferred the search mask by default.

6. Click on OK.

The selected fields are listed in the Target Info Area column in the Search Fields
list.

The default operator is displayed for each field.

7. Double-click on an operator to change it.

8. Click on  (Select Field) in the Initial Info Area column.

The Field Selection window opens.

9. Select a corresponding field in the target info area for each of the fields selected
in the source info area. The content of the field in the source info area is used
as the default comparison value.

10.Enable the Allow changes to search fields check box to allow users to choose
other fields in the search.

11.Define the Results List:

• Click on Search Fields > Hit List to transfer the search fields to the hit list.
Any existing fields in the hit list are removed in the process.

• Click on  (Edit) to the right of the Hits list and select the fields to be displayed
in the results list from the available info areas. Alternatively, load an existing
format. Confirm your settings with OK.

The hit list is loaded when the user first opens the search. If the user changes
the hit list, the user settings are loaded in the search from then on.
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12.Enable the Use fields defined in the desktop hit list check box to load this hit
list each time the search is star ted. In this case, user-specific hit lists are not
saved.

13.Click on OK.

These default values are transferred to the search mask when a user clicks on
the  (Search) button.

New - Templates Tab
Use the New - Templates tab to define templates used when new records are added
in a level.

The templates are available from a drop-down list next to the  (New) button in the
header.

For example, you can define templates that use different masks and default values
for various activity types (e-mails, telephone calls, visits etc.).

You can also use new template buttons to initiate triggers and workflows.

Defining level-specific template buttons is done in the same way as defining buttons
for the general toolbar, see New - Template on page 242.

Enable the check box in the Use Default column to determine which template should
be used when a user clicks directly on the New button in the header.

Enable the New check box on the Header tab to display the New button in the
header, see Header Tab on page 264.
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You can configure fur ther display Options that affect how records are added and
edited:

• Switch to normal view when adding new records: Determine whether the view
automatically switches from integrated view to normal view when adding records.

• Switch to initial view after adding new records: Determines whether the view
is returned to integrated view once the record has been saved.

• Switch to list view after adding new records: Determines whether the view is
returned to list view once the record has been saved.

• Switch to normal view when editing records: Determine whether the view
automatically switches from integrated view to normal view when editing records.

• Switch to initial view after editing records: Determines whether the view is
returned to integrated view once the record has been saved.

• Switch to mask in edit mode: Determines whether the view is switched from list
to mask view when editing records.

• Return to list view after editing: Determines whether the view is returned to list
view once the record has been saved.

Special Case: New Templates in the Calendar

If you define new templates for the Calendar, Resources or Overlapping Appoint-
ments levels, double-clicking in the mask opens a window with all the available
templates (also available from the drop-down list next to the New button in the
header).

Use the Search drop-down list to determine the context of the new appointment.
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The following options are available:

• Company: The company search is opened when the template is accessed. The
user can then search for the company that the activity should be added for.

• Person in Company: The person search is opened when the template is accessed.
The user can then search for the person that the activity should be added for.

• internal  -> Company: An activity is added to the company entered in the
FI_StaNo and FI_SerNo fields of the current rep when the template is accessed.
This allows a rep to add internal records for his company. If these fields are empty
in the rep record, the company search is opened instead.

• intern  -> Person in Company: An activity is added to the person entered in the
FI_StaNo , FI_SerNo , PE_StaNo  and PE_SerNo fields of the current rep when
the template is accessed. This allows a rep to add internal records for himself. If
the KP_StaNo and KP_SerNo fields are empty, the person search is opened
instead.

Start Page Tab
Use the Start Page tab to configure the Aurea CRM win star t page. You can add
links to independent levels, workflows, dashboards, analyses, reports, search areas,
documents and web pages to the star t page.

Depending on your ver tical version, several star t page levels are available. You can
also define additional levels as star t pages, see Defining New Levels on page 301.
Integrate the star t level in the icon bar or configure it as a star t page, see Fixed
Icon bar and Star t Levels.

To define a star t page:

1. Double-click on the desired star t level in the Define Desktop window.

2. Switch to the Start Page tab.

3. Enter the Title.
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You can include data from the current rep's record. Use "$%IDx" to include a field
("x" = field number).

Example: "You are logged in as $%ID3." > "You are logged in as John Smith."

4. Enter a Text to be displayed on the star t page. You can also include rep data in
the Text.

5. Determine whether any documents can be accessed from the star t page
(Document and Document 2 fields).

• Text/Text 2: Enter a description for the document here

• Document/Document 2: Click on  (Load) to load a document or click on 
(Select Document) to select a document from the Aurea CRM win database.
The first document is displayed as a hyperlink above the main area; the second
document is displayed below.

6. Configure the Background color and Font on the star t page under Colors.

Enable the Use mask colors check box to apply the interface settings.

7. Select a background for the star t page under Wallpaper:

a. Click on  (Load).

b. Choose a predefined icon from the list of Available Icons or click on  (Load)
to load a bitmap.

c. Click on OK.

d. Determine how the image should be displayed:

• Center: The image is centered on the star t page.

• Repeat: The image is tiled.

• Fit to size: The image is resized to fill the entire star t page.

• Transparent: Enable this option to display the image with a transparent
background.

8. Configure the links displayed on the star t page under Entries, >> Defining Entries.

• Show icons: Determines whether the corresponding icons are displayed next
to links.

• Show explanation: Determines whether a descriptive text is displayed next to
links.

9. Click on  (Save) next to the Format field to save the star t page as a separate
format, see Saving, Loading and Deleting Formats in the User Manual.

10.Click on OK.

11.Save the desktop format.
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Defining Entries

To add an entry to the main area of the star t page:

1. Click on  (New) under Entries on the Start Page tab.

2. Select the type of entry:

• Format: Select Format and choose the desired Type to add a link to a workflow,
dashboard, analysis or XML report to the star t page.

Click on  (Load) to select the desired format.

• View: Enable the View option and select the level to add a link to the level to
the star t page. All independent levels are available.

Note:  If you add an entry for a level that is locked, the entry is not displayed
on the star t page.

• Search: Select Search and choose the desired level to add a link to the search
mask to the star t page.

• New - Template: Select New - Template and click on Define to create a new
template, see New - Template on page 242.

• Text only: Select Text only and enter the Text under Icon and Text to add a
text entry. This allows you to divide the star t page into several sub-sections.

If you select the Text Only option without entering any text, an empty line is
added.

• Hyperlink: Select Hyperlink and enter a URL in the Text field under Icon and
Text (e.g. www.aurea.com).

3. Click on  (Load) next to the Bitmap field under Text and Icon and select the
icon to be displayed next to the link. If you select icons of different sizes, all icons
are resized to the size of the first icon (maximum size: 24x24 pixels).

Enter a Text for the entry.
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Enable the Use default icon or Use default text check boxes to use the default
text or icon.

4. You can enter an Explanation of the entry.

5. Click on OK.

The entry is listed under Entries and can be edited and deleted using the 

(Edit) and  (Delete) buttons.

Edit the order by dragging entries with the mouse.

Fields Tab
Use the Fields tab to determine which information is displayed in the tree view in
hierarchic levels (Relationship Hierarchy, Installed Base (BTB and OTC),
Campaign Planning, Ticket and custom hierarchic levels).

To define the text displayed in the tree view:

1. Click on  (Text) next to the info area you wish to display data from.
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2. Click on  (New). Click on  (Delete) to delete existing entries.

3. Select an Info Area from the drop-down list to include data from the info area in
the text.

4. Add elements as for references, see Reference Tab on page 292.

Note: You can include data from both the Company, Person in Company and
Relationship info areas in the Relationship hierarchy level. Use the company
and person fields in the Company and Person in Company info areas, not in the
Relationship info area. Only use fields in the Relationship info area to display
details of the relationship (e.g. the type of relationship).

5. Click on OK.

The corresponding information is displayed in the tree view:
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Calendar/Marketing Calendar Tabs
Use the Calendar and Marketing Calendar tabs to configure the calendar.

The Calendar tab is only available in the Calendar, Resources and Overlapping
Appointments levels.

Note: The Marketing Calender tab is available for the Marketing Calendar level.
You can configure the marketing calendar in the same manner as the normal
calendar, i.e. define colors, texts and masks for campaigns, activities and responses.

You can also define calendar settings in the interface settings, see Calendar Tab
on page 227. If no specific settings have been defined for a level, the interface settings
are used.

Users can change these settings using the  (Filter view) and  (Settings) buttons
in the Calendar, see Appointment Settings and Calendar Interface Settings in the
User Manual. The user settings are saved in the pro1.cfg file in the user directory.
The user settings take precedence over the desktop settings.

Enable the Fixed Default and User as Fixed Default options to prevent users from
being able to change the calendar settings, see Colors and Texts and Settings.

Calendar settings can be saved as a separate format, see Formats in the User
Manual.

View

Use the options under View to define masks, texts and conditions that determine
how and which Activity, Task, Absence and To-Do records are displayed in the
calendar:
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• Click on  (Load) in the Mask column to load a mask to be used by the
appointment type. The mask is displayed at the bottom left when a user clicks on
an appointment, see Calendar in the User Manual. If you do not choose a mask,
the default mask is used.

Note:  If the mask contains links (e.g. the -> Marketing Activity field in the activity
mask), you need to define a link to the corresponding target level for the link to
function, see Defining Links.

• Click  (Text) in the Text column to define the text displayed in calendar entries,
see Defining the Text Displayed in Calendar Entries.

• Enable the Display check box to determine that appointments of the corresponding
type are displayed in the calendar. For example, disable the Display check box
for the Activity info area to determine that no activities should be displayed.
User-defined appointment settings (Status, Type, Priority) are ignored in this
case.

• Click on  (Condition) to define a condition that determines which appointments
should be displayed (e.g. only To-Do records whose Status is "Open"),
see Conditions in the User Manual.

Defining the Text Displayed in Calendar Entries

To define the text displayed in a calendar entry:

1. Click on  (Text) in the Text column of the desired Info Area under View on the
Calendar tab.
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2. Click on  (New).

3. Select an Info Area from the drop-down list to include data from the info area in
the text.

4. Add elements as for references, see Reference Tab on page 292.

5. Determine the following for each text:

• Percentage: Enter the percentage of the width of the appointment the text
should cover.

• New Line: Enable this check box to determine that the text should begin on a
new line.

• Display icon from fixed catalog: Enable this check box to determine that the
corresponding icon should be displayed instead of catalog values.

Note: To display the icon, you need to define a separate text including only
the field.

• Only display participants: Affects the Participant ID field. Enable this option
to display the names of reps instead of the rep and group IDs.

• Line break after semicolon: Enable this check box to add a line break after
each semicolon.

• Click on  (Delete)to delete the selected entry.

• Use the arrow buttons to change the order of entries.

6. Click on  (New)to add fur ther entries.

7. Click on OK.
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The appointments are displayed in the calendar with the defined settings; in this
case an activity in the Calendar:

Colors and Texts

Use the settings under Colors and Texts to configure the color and texts displayed
for individual appointment and activity types. For example, you could display
"Completed" activities in a different color from "Scheduled" activities.

• Define the name, conditions and colors used by calendar entries as in the interface
settings, see Calendar Tab on page 227.

• Click in the Text column to define the text displayed in calendar entries,
see Defining the Text Displayed in Calendar Entries.

• Enable the Fixed Default check box to deny access to the  (Settings) button
in the level header. This prevents users from changing the color settings in the
calendar.

Settings

Use the options under Settings to define the following calendar settings:

• Use Default: Enable this check box to determine that the work hours and colors
defined in the interface settings should be used, see Calendar Tab on page 227.

Disable the Use Default check box and click on Modify to define level-specific
settings. The window that opens when you click on Modify contains the default
Aurea CRM settings, not the current interface settings.

• Fixed Default: Enable this check box to prevent users from being able to edit
the calendar settings. The  (Settings) button is then disabled.

• User as Fixed Default: Enable this check box to prevent users from being able
to change the settings defined in the list below (the Rep and Active Reps lists
in the Appointment Settings window and the Representative list in the calendar
settings are disabled).
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If you select entries in the list but leave User as fixed default disabled, the set-
tings are applied until changed by the user.

• Views: You can define additional calendar views that users can select from a
drop-down list in the calendar's header:

To define additional views:

1. Click on  (New) to the right of the Views field.

The Define View window opens.

2. Define the desired settings.

3. Enter a Name for the view.

4. Click on OK.

Quick Add Tab (OTC only)
Use the Quick Add tab to define default values and lists used by the quick add
functionality (e.g. for orders).

For fur ther information on the quick add functionality, see Quick Add in the OTC
Business Logic Manual.

Initial selection/Initial sorting

Users can determine which items should be displayed and how items are sor ted
during quick add.
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To define default values, select the desired option from the Initial selection and
Initial sorting drop-down lists.

Last number of Order

The Last Orders option in the Order - Quick Add info area displays all items used
in the most recent orders. Determine the number of recent orders to take into account
in the Last number of Order field (up to a maximum of 3).

These settings are also available for the POS - Quick Add and Competition - Quick
Add info areas.

List definitions

You can determine that different lists are displayed depending on the contents of
the parent record, e.g. you can display a list used to enter quantities and discounts
in kind for orders containing a special offer, see Defining Lists for Quick Add Levels.

Defining Lists for Quick Add Levels

To define a list for a quick add level

1. Click on  (New) next to the List Definitions field on the Quick Add tab.

2. Enter a name for the list in the Edit text window.

3. Click on OK.

The Field Selection window opens.

4. Select a field and define a condition that determines when the list should be
displayed, >> Conditions in the User Manual.

5. Click on OK.

The Field Selection window opens.
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6. Select the quick add fields. All fields in the Item Master and current info area are
available. Use the arrow button to change the field order. Click on an entry in the
Width column to change the column width (max. 255).

7. Click on OK.

The Define Initial Selection window is displayed.

8. Select the desired setting. This value replaces the value selected on the Quick
Add tab.

9. Click on OK.

The list is listed under List definitions. Click on the icons in the list (Name,
Search Crit., Info Area Fields, Initial  Selection) to edit your settings.

The lines are processed sequentially. The list defined for the first condition a
record fulfills is used. You can edit the order by dragging entries with the mouse.

Info Area Settings
Learn how to define user interface settings for individual info areas.

Follow the below steps:

1. Select Extras > Define Desktop from the menu.

2. Load the desktop format you wish to configure.

3. Click the Info Areas button in the Define Desktop window.
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All info areas you can access based on your access rights are listed under
Available Info Areas.

4. Click on  (Load) next to the Info Area Format field to load an existing format.

5. Select the info area you wish to configure.

Info areas for which settings have already been configured are indicated with a
red tick below the info area icon.

6. Define the desired settings:

• Reference: Use the Reference tab to define references displayed in the header,
link fields etc., see Reference Tab on page 292.

• Search: Use the Search tab to configure the search settings for the info area,
see Search Tab on page 295.

• Filter Masks: Use the Filter Masks tab to define filter masks for the info area,
see Filter Masks Tab on page 296.

• Conditional Formatting: Use the Conditional Formatting tab to configure
the appearance of the info area based on the contents of records, see Condi-
tional Formatting Tab on page 296.

• Tree View: Use the Tree View tab to configure the tree view, see Tree View
Tab on page 297.

7. Click on  (Save) next to the Info Area Format field to save the format,
see Saving, Loading and Deleting Formats in the User Manual.

8. Click on OK.

9. Save the desktop format.
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Note:  If you are editing an existing format, you only need to save the user interface
format and not the desktop format, as the desktop format only contains a reference
to the user interface format.

Reference Tab
Use the Reference tab to define references and target levels.

The reference is the text displayed for a record in link fields, links in the context
menu and in e-mails, in summary index cards and in the tree view.

By default, the name of the level is displayed in the header (e.g. Company+Person).
Level names can be changed on the Navigation tab, see Navigation Tab on page
250.

To display the reference in the header instead of the level name, disable the Show
reference option on the Context Menu/Header tab in the user interface settings,
see Context Menu/Header Tab on page 230. If a level contains several info areas,
select the info area whose reference should be displayed in the header on the
Header tab in the level properties, see Header Tab on page 264.

The default reference is displayed if you enable the Show reference option but
have not defined a reference for the info areas in the level (e.g. "Company: <com-
pany name>" is displayed in the Company+Person level).

You can also define references directly in the data model using corresponding
configuration entries, see Data Model in the CRM.core Administrator Guide (Ref-
erence Text option). The desktop settings take precedence over settings in the
Configuration info area.

To define a reference:

1. Select the desired info area under Available Info Areas.

2. Switch to the Reference tab.
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Add the desired elements under Elements/Wildcard. You can freely combine el-
ements.

The following options are available:

• Field Content: Select this option and click on Insert Elements to open a list
of fields in the selected info area. Enable the check box next to the field whose
contents should be displayed in the reference and click on OK.

• Field Name: Select this option and click on Insert Elements to open a list of
fields in the selected info area. Enable the check box next to the field whose
name should be displayed in the reference and click on OK.

• Info Area Name: Select this option and click on Insert Elements to open a list
of available info areas. Enable the check box next to the info area whose name
should be displayed in the reference and click on OK.

• Display with Previous Field Only: Select this option and click on Insert
Elements to add the "{<}" placeholder. The next element added to the reference
is then only displayed if the element before the placeholder is not empty.

Example (Person in Company info area): "{2KP0*Form of address}{<}
{2KP3*First Name} {2KP2*Last Name}": The space between the form of address
and first name is only displayed for records containing a form of address.

• Always Display: By default, text elements are only displayed if the following
element is not empty. Select this option and click on Insert Elements to add
the "{.}" placeholder. The next element you add is then displayed even if the
following element is empty.

Example: "{2KP}{.}: {2KP0*Form of address}{<} {2KP3*First Name} {2KP2*Last
Name}": The text element ": " following the info area name is displayed even
if the Form of address field is empty.

• User-defined Text: Select this option and click on Insert Elements to add text
(including punctuation and spaces), see Defining Multilingual References.

3. Save the info area format.

The reference

"{2KP}{.}: {2KP0*Form of address}{<} {2KP3*First Name} {2KP2*Last Name} -
{2KP11*"Department"}: {2KP11*Department}"

is displayed as:

.
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Defining Multilingual References

To display references correctly in all languages, you need to define the text elements
for all languages. To define a reference in several languages, such as "Reminder:
<Subject> for <Rep>" for the Reminder info area:

1. Select the desired info area (e.g. Reminder) under Available Info Areas.

2. Switch to the Reference tab.

3. Select the Info Area Name option.

4. Click the Insert Elements button.

5. Select "Reminder" from the list and confirm with OK.

6. Select the Text option and click on Insert Elements.

7. Enter the text in the available languages (e.g. " for ", " für " etc.).

Note:  Include the spaces in the text element. If you add the space directly (i.e.
not using the Insert Elements button), the space is only displayed in the current
language.

8. Click on OK.

9. Select the Field Content option and click on Insert Elements.

10.Select the Rep/Group field and click OK.

11.Save the info area format.

The reference is displayed as follows (e.g. as a tooltip):

 or 

Selecting the Target Level

You can determine which level an info area is opened in by default in the Reference
tab.

1. Click on  (Edit) next to the Target Level field and select a level.

The target level is used by the following functions:

• Link in reports

• Custom links

This setting is only used by levels for which you have not defined a target level on
the Links tab in the level properties, see Defining Links.
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Search Tab
Use the Search tab to configure the info area's search.

The search is configured in the same manner as for levels, see Search Tab on page
262.

In addition, you can define search conditions for each info area. This allows you to
exclude cer tain records from the search, for example inactive person records or
appointments that have been missed.

1. Double-click on  in the 'Current' Condition field, see Conditions in the User
Manual.

2. Define the condition.

3. Enable the Current condition active check box to activate the condition when
the search is opened.

4. Enter a Description of the condition. It is displayed as a tooltip for the Current
condition active check box in the search mask, see Searching in the User Manual.

Search settings can also be defined per level, see Search Tab on page 262. Select
a level from the Search from Level drop-down list and click on Switch to to open
and edit the level-specific search settings.

Note:  If you have defined both level-specific and info area-specific search settings,
the level settings are used (in addition to any search criteria defined for the info
area).

If the search is accessed from a link field using , the info area settings are applied.
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Use the Links tab to define record contents in the source info area to be used as
search criteria when linking records, see Using Field Contents as Search Criteria.
This setting takes precedence over the search fields defined for the info area in the
info area settings.

Filter Masks Tab
Use the Filter Masks tab to define filter masks for the info area.

Filter masks for info areas are defined in the same manner as for levels, see Filter
Masks Tab on page 253.

To use filter masks defined for an info area in a level, enable the Use filter masks
from info area option on the Filter Masks tab in the level properties, and select
the info area from the drop-down list.

Available filter masks are automatically applied to the details view in the tree view,
see Tree View Tab on page 297.

Select a level from the Filter Masks from Level drop-down list and click on Switch
to to open and edit the level-specific filter masks.

Conditional Formatting Tab
Use the Conditional Formatting tab to configure the appearance of the info area
based on the contents of the current record.

Conditional formatting for info areas is defined in the same manner as for levels,
see Conditional Formatting Tab on page 256.
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To use conditional formatting defined for an info area in a level, enable the Use
conditional formatting from info area option on the Conditional Formatting tab
in the level properties, and select the info area from the drop-down list.

Select a level from the Conditional Formatting from Level drop-down list and click
on Switch to to open and edit the level-specific conditional formatting.

Note: The Use conditional formatting from info area setting must be enabled for
workflow levels to use conditional formatting in workflows.

Tree View Tab
Use the Tree View tab to configure the info area's tree view.

The tree view depicts relationships between records (parent and child records are
displayed), see Tree View in the User Manual.

To configure the tree view for an info area (e.g. Person):

1. Select the desired info area under Available Info Areas.

2. Switch to the Tree View tab.
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3. Select one of the following options:

• Only display selected links: Determines that the info areas for which the
check box is enabled in the Select column are displayed in tree view.

• Do not display selected links: Determines that the info areas for which the
check box is enabled in the Select column are not displayed in tree view.

4. Select a ratio under Links to display the linked info areas. Determine which info
areas should be displayed in tree view.

Only records in the selected info areas are displayed when the tree view is opened
(e.g. for a person record).

5. Determine how records are displayed in the tree view:

a. Select an info area under Available Info Areas (e.g. Activity).

b. Switch to the Tree View tab.

c. Click the Select Fields button under Sorting.

d. Select (up to 5) fields used to sor t records in the selected info area.

e. Click on OK.

f. Enable or disable the Allow Drag&Drop check box as desired. If the option
is enabled, users can move records in this info area between parent nodes
(e.g. move an activity from one person to another), as well as merge companies
and persons.

If the check box is gray, the setting defined in the Configuration info area
applies, see General Settings in the CRM.core Administrator Guide
(Drag&Drop  in Tree View option).
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g. Determine the Maximum number of records in this info area to be displayed
in the tree view. If you leave the field empty, all records are displayed.

h. Click on  (Edit) next to the Condition field to define a condition that
determines which records should be displayed in the tree view (e.g. only
activities whose Status is "Open"),   Conditions in the User Manual.

i. Click on  (Edit) next to the Mask or List fields to load a mask or list to be
used by records selected in the tree view, see Mask Generator on page 169.

Alternatively, click on  (Load) to load an existing format.

If you do not specify a mask, the custom mask is displayed. If you do not
specify a list, the List option is unavailable from the context menu in the tree
view.

Loading a list has no effect on 1:1 links, and the List option is always available.

If you have defined filter masks for the selected info area, the filter masks are
used instead of the mask entered in the Mask field, see Filter Masks Tab on
page 296.

6. Configure any fur ther info areas.

7. Save the info area format.

In order for users to be able to access the tree view, you need to add a link to the
Tree View level to either the icon bar or define a context menu for each info area,
see Accessing the Tree View from the Context Menu on page 272.

Records are displayed using the references defined in the info area settings,
see Reference Tab on page 292.

The text and background color of the root node is taken from the list bar colors in
the current color scheme, see Configuring the Appearance of the Selected Record
on page 199.

Extended Desktops
You can create hierarchies of desktop formats and inherit settings that should apply
globally.

You then only need to define a small subset of changes to the format for individual
departments or users.

To define a desktop as an extended desktop:

1. Select Extras > Define Desktop from the menu.

2. Load the desired desktop format.

3. Enable the Extended Desktop check box.
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4. You have the following options:

• If you enable only the Extended  desktop check box, the extended desktop
inherits settings based on where the desktop is assigned. Extended desktops
defined for login roles inherit the settings defined for the rep; extended desktops
defined for reps inherit the group desktop settings; extend group desktops
inherit the station desktop settings.

Settings in desktops assigned to roles are inherited according to the priority
entered in the login role.

• Enable the Extended Desktop option and select a desktop in the Fixed  parent
desktop field to define the current desktop as a child of the selected desktop.

• Click on  (Load parent desktops) to load and edit the parent desktop's
settings.

• Click on  (View) to display a print preview of the desktop format:

5. The Inherit configuration check box is displayed in the windows in the desktop
settings and is enabled by default.

The settings in the parent desktop are applied to the extended desktop.

Note: The Inherit configuration check box is not present in the Icon Bar
Properties window. The names of levels, workflows and dashboards in the child
desktop are used. If no name has been defined for an element, the name is applied
from the parent desktop.

Note: The global interface settings are not inherited, see Configuring the User
Interface on page 223. The interface format defined in the current desktop is always
used.

6. Disable the Inherit configuration check box and make the desired settings.
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If you enable the Inherit configuration check box on the Links and Context
Menu tabs in the level properties, the Group links or Group menus check box
is displayed. Enable the check box to combine the links and context menu options
in both the parent and current desktop, instead of only applying those defined in
the child desktop.

The type, format and level are compared for context menu entries; the link type,
source and target info areas are compared for links. If duplicate entries exist, the
entry defined for the current desktop is used.

Example: The current desktop contains a context menu entry of the type Level,
which is only displayed in view mode, see Context Menu Tab on page 268 (Mode
> View). The same context menu entry is active in the parent desktop in display,
new and edit mode.

In this case, the current desktop's settings are applied, and the entry is only dis-
played in view mode.

7. Save the desktop format.

8. Click on OK.

Defining New Levels
You can define new info areas in the Data Model in the Maintenance module.

For fur ther details, see Adding New Info Areas in the CRM.core Administrator
Guide.

You need to include new info areas in a level to access the info area in Aurea CRM
win.

Level definitions are automatically saved in a format of the type "Defined levels",
see Formats in the User Manual.

To define a new level:

1. Select Extras > Define Desktop from the menu.

2. Click the Define Levels button.

The Select User Group window is displayed.

3. Specify whether you are an Aurea employee, a Partner of Aurea, or a Customer.
Level IDs are assigned from different number ranges depending on your choice.

Note: You require a password for the Aurea and Partner options.

4. Click on OK.

The Define Levels window is displayed.
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5. Click on  (New) to the right of the Levels list.

The Edit ID window opens.

The level ID is generated automatically. To change the ID, select the User Set-
tings option and enter the desired number. Any number divisible by 1,000 in the
applicable number range is allowed (e.g. 200,000,000 - 299,999,000 for cus-
tomers).

6. Click on OK.

The Edit text window is displayed.

7. Enter the name of the level.

8. Click on OK.

The new level is listed under Levels.

Select a level from the list and click on  (Delete) to delete the level.

Note: The  (New) and  (Delete) buttons are only available on the main
station. If a level no longer exists, all links to the level are deleted when the
desktop is loaded. The IDs of deleted levels are not reused.

9. Select the Type of level (Standard Level, Start Page or Hierarchy).

Note: You do not need to define a mask or list for star t pages. The level
commands (e.g. navigation buttons etc.) are unavailable in the level settings for
star t pages, and the corresponding flags are also unavailable.
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For details on defining hierarchic levels, see Defining Hierarchic Levels on page
310.

10.Click on  (Edit) next to the Info area selection field to define a transfer fields

format. Alternatively, click on  (Load) to load an existing format.

The transfer field format must contain all info areas to be displayed in the level,
>> Transfer Fields in the User Manual. Only one info area in the transfer format
may be defined as a root info area. All other info areas need to be dependent on
the root info area.

The following settings in the transfer fields format are used to display data: info
areas, index relationships, conditions, sor t order and the maximum number of
records. You do not need to select any fields.

Note:  If you wish to access the level using a custom link, you need to select the
corresponding Index in the transfer field format (link IDs 126 or 127).

The info areas in the transfer format are listed under Info areas.

11.Click on  (Edit) next to the Mask or List fields to define a list to be used by

the level, see Mask Generator on page 169. Alternatively, click on  (Load) to
load an existing format.

Click on  (Delete) to remove the selected format.

12.Click on  (Edit) next to the Settings field to configure the general settings for
the level, see Level Settings on page 304.

13.If you are defining a dependent level:

• Click on  (Edit) next to the Predecessor field to configure the parent level,
see Defining Parent Levels on page 309.

• Alternatively, click on  (Edit) next to the Relationship with Parent to define
valid parent levels based on the info areas in the parent level, see Defining the
Relationship with the Parent Level on page 309.

14.Click on OK.

The new level is listed under Available Levels as a child of the parent level. The
level can be configured in all desktop formats, see Accessing the Level in the
CRM.core Administrator Guide and Level Properties on page 248.
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Level Settings
The Level Settings window is used to determine general settings for the level.

Follow the below steps:

1. Choose one of the categories: Edit, General or Open. For each option in the list,
determine whether the option is Permitted or Not permitted, see Edit Options,
General Options and Open Options.

2. Enable the check boxes under Level commands to determine which buttons are
displayed in the level header. Enable Select All to select all options.

Note:  Include only the buttons required based on your settings in step 1.These
settings are applied to all variants of the level, irrespective of the parent level.

3. Click on OK.
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Edit Options

The level can only be opened once.PRO_MULTIPLE_INSTANCES

Not allowed: The last settings used are
not saved for this level (i.e. mask, condi-
tions, sor t criteria).

PRO_SAVE

Not allowed: Conditions cannot be ap-
plied to the level. The corresponding op-
tions in the menu are disabled.

However, you can still apply autofilters.

PRO_FILTER

Not allowed: The search is disabled for
this level. The Search options in the
header and menu are disabled.

PRO_SEARCH

Not allowed: View mode is disabled for
the level. The level is opened in either
new or edit mode.

PRO_MODE_SCROLL

Not allowed: New mode is disabled for
the level. Clicking the New button has no
effect.

PRO_MODE_INSERT

Not allowed: Edit mode is disabled for
the level. Clicking the Edit button has no
effect.

PRO_MODE_UPDATE

Not allowed: Templates cannot be de-
fined for new records in the New - Tem-
plates tab in the desktop settings.

PRO_NEW
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General Options
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Not allowed: Mask view is disabled. The
level is loaded with the custom mask. The
menu options used to load masks are
disabled and corresponding entries in the
desktop settings are disabled.

PRO_UI_MASK

Not allowed: List view is disabled. The
List button in the level header is dis-
abled.

PRO_UI_LIST

Not allowed: The custom mask is dis-
abled for this level. The menu option
used to load the custom mask is disabled.

PRO_UI_MASK2

Allowed: The level is always displayed
in integrated view.

PRO_UI_INTEGRATE

Not allowed: The level may not be dis-
played in the integrated view. The button
used to switch to the integrated view in
the level header is not displayed.

Allowed: Child levels are always dis-
played in integrated mode.

PRO_UI_INTEGRATE_CHILD

Not allowed: Child levels cannot be dis-
played in integrated mode.

Allowed: Dependent levels are integrated
horizontally when they are first opened.

PRO_UI_INTEGRATE_HORZ

Allowed: Dependent levels are integrated
vertically when they are first opened.

PRO_UI_INTEGRATE_VERT

Not allowed: Sum totals are not permit-
ted in lists.

PRO_UI_LIST_TOTAL

Not allowed: The summary index card
cannot be loaded; the corresponding
menu option is disabled.

PRO_UI_LOAD_PMASK

No masks can be loaded in mask view.PRO_UI_LOAD_MASK

No masks can be loaded in list view.PRO_UI_LOAD_LIST

Not allowed: The level is displayed
without the level header. The Header tab
in the desktop settings is no longer dis-
played.

PRO_UI_MASK_HEADER
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Not allowed: The level is displayed
without a context menu. The Context
Menu tab in the desktop settings is no
longer displayed.

PRO_UI_MASK_CONTEXT

Not allowed: The level is displayed
without the icon bar.

PRO_UI_INFOBAR

Not allowed: Prevents scrolling between
records in parent levels using the summa-
ry index card.

PRO_UI_NOVGSCROLL

Open Options

Allowed: The settings last used by the
level are not restored when the level is
reopened.

PRO_CRE_NOT_SAVE

Allowed: A new instance is created each
time the level is opened.

PRO_CRE_DUPLICATE

If multiple instances are not permitted,
open instances are automatically closed
before opening the new instance.

PRO_CRE_CLOSE_MULTIPLE_IN-
STANCE

Allowed: No other level can be given fo-
cus whilst this level is open.

PRO_CRE_LOCK_ACTIVE

Allowed: The level cannot be given fo-
cus.

PRO_CRE_LOCK_INACTIVE

Allowed: Clicking on OK, Save or Cancel
automatically closes the level.

PRO_CRE_CLOSE_ON_COMMAND

Allowed: The level is not stored in the
history (i.e. you cannot return to the level
using the Back and Forwards buttons).

PRO_CRE_NOTQUEUE
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Defining Parent Levels
Learn how to define parent levels for info areas.

All levels containing an info area linked to the current level's parent info area are
displayed. Select one or more levels and confirm with OK.

The new level can only be opened if one of the defined parent levels is opened.

Defining the Relationship with the Parent Level
You can determine which info areas and indices are used to link to the parent level.

A valid parent level is then determined at runtime.

1. Choose a link type (1:1, 1:n or n:1).

A list of all info areas linked to the current level's parent info area via the selected
link type is displayed.
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The index is displayed in the Index column.

2. Enable the Mandatory check box for the desired info areas.

3. Click on  (Flags) to determine when the level is a valid parent level:

• PRO_PREL_MUST: The info area must be present in the parent level.

• PRO_PREL_MUSTNOT: The info area must not be present in the parent level.

• PRO_PREL_INCLUSIVE: At least one of the info areas with this setting enabled
must be present in the parent level.

• PRO_PREL_EXCLUSIVE: At most one of the info areas with this setting enabled
may be present in the parent level.

• PRO_PREL_MUST_POS1: This info area must be the first info area defined in
the parent level (in the order specified under Data > Sequence).

• PRO_PREL_MUSTNOT_POS1: This info area may not be the first info area
defined in the parent level.

• PRO_PREL_KEY: The info area is used to form the key. The system
automatically uses the station number and serial number entered in the
corresponding parent record when adding new records.

Defining Hierarchic Levels
You can display records in the tree view in hierarchic levels.

For fur ther information on hierarchic levels, see Hierarchic Levels in the User
Manual.

To define hierarchic sub-levels for a level:

1. Define an n:1 link from the info area to itself in the data model, see Link in the
CRM.core Administrator Guide.

2. Apply the changes to the current data model.

3. Select Extras > Define Desktop from the menu.

4. Define a new level, see Defining New Levels on page 301.

5. Select "Hierarchy" in the Type field under Properties.

6. Select the info area contained in the parent level under Info area selection (e.g.
the Property info area (BTB only) for the property hierarchy).

If no Index is defined in the settings in the transfer field format, Aurea CRM win
searches for a suitable index at runtime. If no suitable index is found, the level
is not opened.

310AUREA CONFIDENTIAL

Chapter 4: User Interface

https://help.aurea.com/crm/crm-win-user-manual/crm-win-user-manual/dita/topics/c_win_UsrMan-3_11-Hierarchic-Levels_upd.html
https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-3_5_8_8-Link_crm.html


7. Define a Mask with any number of tab groups. The first tab with the following
properties is used for the tree view, see Tab Group Properties on page 185:

• the tab group must be empty (no fields etc.)

• the No tab label option on the View tab must be disabled

• the Always visible option on the Colors tab must be enabled

8. Select the desired parent level under Predecessor (see Defining Parent Levels
on page 309) and/or define the Relationship with Parent, see Defining the Rela-
tionship with the Parent Level on page 309.

9. Click on OK.

10.Add an option to the context menu in the parent level used to access the hierarchic
view, see Accessing Levels with the Context Menu on page 270.

11.Save the desktop format.
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5
Additional Modules and Applications
Explore additional special features and functions in CRM.Win.

Configuration
Learn about the configuration settings that apply to Aurea CRM win only.

For information on configuration settings of Aurea CRM, see Configuration in the
CRM.core Administrator Guide.

mm.ini File

[Communication]

To shorten the duration of outputting and inputting initial data stock downloads, use
the following setting in the global mm.ini file:
[Communication]
FastLoad=*

To create initial data stock download fields for specific stations, specify the station
numbers:
FastLoad=1000,1001,...

For details, see Quick Mode.

[SMTP]

The entries for SMTP define the Aurea CRM win settings used when:

• Sending e-mails by clicking on an e-mail address field or using the File > E-mail
or File > Single Letter menu options.

The SMTP settings entered in the mm.ini file are displayed as the default settings
the first time a mail is sent. These values can be changed however, see SMTP
Connection Settings in the CRM.core  Administrator Guide. Users can save their
login data using the Store credentials option. The login data is saved in the
smtp.cfg file in the user directory, and the dialog box containing the connection
settings is no longer displayed when sending mails.

The Connection Settings dialog is then no longer automatically displayed when
sending e-mails. The Connection Settings dialog can still be accessed by holding
down Shift while selecting File > E-mail from the menu.

If a suitable configuration entry is present, the Connection Settings dialog is
also not displayed.

• Sending mass mailings and e-mails via triggers.
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The SMTP settings entered in the mm.ini file are used if no suitable configuration
entry or smtp.cfg file is found, see SMTP Connection Settings in the CRM.core
Administrator Guide.

To use SMTP, you need to enter "SMTP" as the E-Mail Client under General Set-
tings in the Configuration info area, see General Settings in the CRM.core Admin-
istrator Guide.

Mandatory mm.ini entries:
smtpHost=<SMTP server name or IP Address>
smtpUser=<SMTP user name>
smtpPass=<SMTP password>
smtpSenderAddr=<The user's e-mail address>
smtpSenderName=<The user's name>

Optional entries:
smtpPort=<port>

The default por t is 25.
smtpAuth=<Login method>

The following login methods are available:
0 = AUTH_NONE
1 = AUTH_CRAM_MD5
2 = AUTH_LOGIN
3 = AUTH_PLAIN
4 = AUTH_NTLM

Analysis Module
Learn to analyse data and obtain results in Aurea CRM.win.

The Analysis module allows you to:

• Analyze data in info areas using your own using criteria.

• Display the results of the analysis as a table, bar or pie chart.

• Export the results to a spreadsheet.

You can also star t the analysis module from the command line, see mman.exe Pa-
rameters on page 343.

Users can access the Analysis module if they have the necessary access rights,
see Module Access Rights, System Locks and Process Tracking in the CRM.core
Administrator Guide. However, users may still only access the data they have been
granted access to (in the Rights module).

Users can define their own analyses in Aurea CRM's main module, see Analyses
in the User Manual.

Note:  By default, the graphics library from ComponentArt is used. If Aurea CRM is
star ted over the network or .NET Framework 2.0 is not installed, bar and pie charts
are displayed using Aurea's graphics. You can define that charts should always be

313AUREA CONFIDENTIAL

Analysis Module

https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-4_4-SMTP-Connection-Sett_crm.html
https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-4_1_2_21-General-Settings_crm.html
https://help.aurea.com/crm/crm-core-admin-guide/crm-core-admin-guide/dita/topics/c_core_admin-2_6_1_1_2-Module-Access-Rights_crm.html
https://help.aurea.com/crm/crm-win-user-manual/crm-win-user-manual/dita/topics/c_win_UsrMan-11-Analyses_upd.html


displayed using Aurea's graphics, see Analyses in the CRM.core Administrator
Guide.

When using the predefined color schemes in Aurea CRM, the colors used by analyses
are selected to match the color scheme (ComponentArt bar charts only use one
color per row). If you are using a custom color scheme, you should also configure
the analysis colors. To do so, select View > Desktop Properties from the menu
and switch to the Analyses tab.

Defining an Analysis
Learn how to define an analysis.

To define an analysis:

1. Start the Analysis module, see Star ting Modules on page 13.

2. Enable the Selection or Property Selection (BTB only) check boxes to restrict
the analysis to a predefined selection. Double-click in the Sel.Name field to choose
a selection.

3. Click in the Info Area cell in the first row of the table and select the info area you
wish to analyze (e.g. Company) and click on OK.

Note: To remove an info area from the analysis, click in the Info Area column
and disable the check box next to the info area. The info area is removed from
the table.

4. Click in the Text column and edit the text if you wish to change the header used
in tables and charts (e.g. "Company Revenue").

5. To restrict the analysis to records that meet specific conditions, click in the
Condition column and define the condition, see Conditions in the User Manual.

6. Click in the Field column and select the field to be used as the analysis unit, and
click OK.

7. Define the analysis unit, see Defining the Analysis Unit on page 315.

8. Click in the Totals column to calculate sum totals for each analysis unit. Select
the desired field (e.g. "Revenue").

314AUREA CONFIDENTIAL

Chapter 5: Additional Modules and Applications

https://help.aurea.com/crm/crm-win-user-manual/crm-win-user-manual/dita/topics/c_win_UsrMan-11-Analyses_upd.html
https://help.aurea.com/crm/crm-win-user-manual/crm-win-user-manual/dita/topics/c_win_UsrMan-4_10-Conditions_upd.html


9. Click in the Sub-analysis cell If you wish to add another analysis unit (e.g. to
analyze revenue per country per sector), see Creating a Sub-analysis on page
317.

10.If you wish to analyze a fur ther info area, define additional lines in the analysis
format.

Note:  Edit the value in the Pos. column to change the order of the info areas.
The order of the info areas in the table corresponds to their order in the analysis.

11.Click on  (Save), see Saving, Loading and Deleting Formats in the User Manual.

Note:  Load an existing format with  (Load). Click  (Delete) to clear the mask.

Defining the Analysis Unit
The analysis units you define determine the number of bars in bar charts, slices in
pie charts and rows in tables.

To define an analysis unit:

1. Select Analysis Unit from the context menu. The Unit dialog box is displayed.

2. Click on Generate. The Generate Scale dialog box is displayed.

3. Enter a value in the Maximum field to limit the number of analysis units.

4. Depending on the type of field:

• Catalog fields: Click OK if you have selected a catalog field to include all
catalog values as analysis units.

• Numeric fields: Enter the upper and lower thresholds in the From and To fields
and enter the interval in the Intervals field to generate an automatic scale.

5. The generated scale is displayed. The analysis units are displayed in the upper
section. The corresponding condition used to define the analysis unit is displayed
under Condition.
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6. Select an analysis unit and click  (Delete) to delete it.

7. Click  (New) to add a new analysis unit above the selected one, or click 
(Edit) to edit the currently selected unit:

a. Enter the name of the unit in the Text field in the Analysis Unit dialog box.

b. Add or edit conditions used to define units by clicking on  (New) or  (Edit)
respectively. Select the logical operator (AND or OR) used to combine conditions
under Link and enter the Comparison value. Click OK.

8. Drag analysis units within the list to change the order in which they are displayed.

9. Click  to save your settings.

10.Click OK.
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Creating a Sub-analysis
Sub-analyses allow you to refine an analysis using an additional field.

To create a sub-analysis:

1. Click in the Sub-analysis column.

2. Select the desired field and click OK.

3. Click on Generate to define the analysis units, see Defining the Analysis Unit on
page 315.

The main analysis mask is displayed again. The selected field is displayed in the
Sub-analysis cell.

Executing the Analysis
Learn how to execute the analysis and display results.

Click  (Start) to execute the analysis.

The results of the analysis are displayed in a table.

• Sum: The sum total for all records that fall within the defined range of possible
values defined for your analysis unit.

• Sum Total: The sum total for all records, including those outside the range (in
the example above, this would be companies in other countries from those listed).

Use the following options to change the view:

• Select Percent, Absolute or Totals from the drop-down list to determine the data
displayed in the table.

• Select < or > from the context menu to edit the table width.

• Select Diagram from the context menu to display the analysis as a bar chart:
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The following buttons are available when displaying a chart:

• Options: Opens the Options dialog box, see Options on page 319.

• Zoom: Opens the chart in a second window which can be resized.

• Pie Chart / Bar Chart: Switches between a bar chart and pie chart.

• Percent / Absolute: Switches between displaying percentages and absolute
values.

• Sub-analysis: Switches to the results of the sub-analysis. The <, >, Diagram
and Transfer options are again available from the context menu in the
sub-analysis.
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• Transfer: Transfers the chart and data to your spreadsheet.

• Click  (Level back) to return to the Analysis Format info area. The date the
analysis is last carried out is entered in the Date field. The following options are
available from the context menu to export the results or display them again: Table,
Diagram, Sub-analysis, Transfer.

Options
The options available depend on whether you are displaying a bar chart or pie chart.

Below options are available:

Sort

These options are used to determine how the data in the charts are sor ted.

• Ascending / Descending: Data in the chart is sor ted in ascending or descending
order.

• Alphabetical: Data is sor ted alphabetically.

• Fixed: Data is sor ted according to the order of the lines in the analysis unit format.

Display decimal places

Determines whether decimal places are displayed.

Alignment Legend/Levels (only pie charts)

• Left/Right: Displays the legend to the left or right.

• Top/Bottom: Displays the legend at the top or bottom (only for charts using the
ComponentArt graphics).

• Show legend: Displays the legend.

• Sum total in legend: Sum totals are displayed in the legend next to the analysis
unit (only for charts using Aurea's graphics).

• Display labels on pie charts: Labels are additionally displayed on the chart (only
for charts using the ComponentArt graphics).
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Text/Caption (only pie charts using Aurea's graphics)

• Border: Displays text with a border.

• Background: Displays text with a different background color from the chart.

Bar (only bar charts)

• Scale on the side: Displays the scale on the left of the chart (only for charts
using Aurea's graphics).

• Scale on background: The unit of analysis can be shown in the background in
addition to or as an alternative to showing the unit of analysis at the side (only
for charts using Aurea's graphics).

• Maximum bar height: The highest bar value is used to limit the size of the bar
chart.

• Relative bar height: The cumulative total across all columns is used to limit the
size of the bar chart.

• Visible bars: Determines the maximum number of bars displayed at once (only
for charts using Aurea's graphics).

• Show totals: Displays sum totals at the bottom of the chart (only for charts using
Aurea's graphics).

• Split levels: Levels (several bars behind one another) are split into separate
charts (only for charts using Aurea's graphics).

Settings (only bar charts using Aurea's graphics)

Click on the Levels, Classes and Totals buttons to define the colors and font used
in the following parts of the table (1=Levels, 2=Classes, 3=Totals):

Determine the color of the Background, Text, Top frame, Bottom frame as well
as the Font settings.

protocol.exe
The protocol.exe file is included with Aurea CRM. Upon star ting Aurea CRM for
the first time, the file is registered as the protocol handler for all links that star t with
update :/ /. Executing the exe file also registers it.

When calling such links, protocol.exe checks whether the Aurea CRM win main
module is running. If so, the contents of the link are transferred to that instance. If
the Aurea CRM win main module is not running, the system attempts to star t the
Aurea CRM win main module from the directory containing protocol.exe.
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Aurea CRM uses these functions:

• For links in e-mails that open records (Edit > Send Record as Link to).

• For popup windows with links to messages or reminders.

• In reports defined using the Output link option. A link is created for each record
in the report.

You can also:

• Call links from other applications if Aurea CRM is installed and protocol.exe
is registered.

• Create reports that include links to other levels and serves as a star t page.

Loading Records in Aurea CRM
Learn how to load records in Aurea CRM.

Call

update://mmba/Navigate/Goto?Key=Rel-KeyFields&Pro=ProId&No=Station

Parameters

Rel : Info area abbreviation

KeyFields : The values in the primary key fields, separated by '-'.

ProId : The level in which the record should be opened.

Station: The current station number (optional)

Example

update://mmba/Navigate/Goto?Key=FI-100-1256

Restriction

When targeting dependent levels, it is not possible to guarantee that all parent levels
are already opened or is open automatically.

This link can also be generated in Aurea CRM by selecting Edit > Copy Link to
Clipboard from the menu.

Opening Levels
Learn how to open levels in Aurea CRM.

Call

update://mmba/Navigate/Goto?Pro=ProId
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Parameters

ProId : The level that should be opened

Example

update://mmba/Navigate/Goto?Pro=1001

Restriction

When targeting dependent levels, it is not possible to guarantee that all parent levels
are already opened or opens automatically.

Opening Websites in Aurea CRM
Learn how to open websites in Aurea CRM.

Call:

update://mmba/Navigate/Goto?Pro=2410000&Url=URL

Parameters:

URL: Address of the website to be opened

Example:

update://mmba/Navigate/Goto?Pro=2410000&Url=www.google.at/search?hl=de&q=Sun-
shine%20%20AG

Loading Formats
Learn how to load formats in Aurea CRM.

Call

update://mmba/Format/Goto?Name=FormatName&Type=FormatNumber

Parameters

FormatName : Name of the format to be opened.

FormatNumber : The number of the format type.

Example

update://mmba/Format/Goto?Name=FI_KP_Timeline&Type=30

Restriction

The following formats are supported: Workflows (28), dashboards (30), analysis
formats (45), XML reports (44). All formats must be level-independent or have an
independent level as the root level.

322AUREA CONFIDENTIAL

Chapter 5: Additional Modules and Applications



Starting the Search
Learn how to star t the search in Aurea CRM.

Call

update://mmba/Search/Goto?Pro=ProId

Parameters

ProId : The level to be searched. The special searches available for the Compa-
ny+Person and Property levels is star ted. In the case of the Company+Person
level, either the person or company search is star ted, depending on which is last
active. You can also enter the level number of the special search for companies,
persons and properties.

Restriction

When targeting dependent levels, it is not possible to guarantee that all parent levels
are already opened or opens automatically.

Displaying Selections
Learn how to display selection in Aurea CRM.

Call

update://mmba/Selection/Goto?Name=SelectionName?Key=OJ

Parameters

SelectionName : The name of the selection format (must be present for the current
user).

Key=OJ: Needs to be included if the selection contains properties (only in the BTB
vertical).

Example

update://mmba/Selection/Goto?Name=NewProperties?Key=OJ

Creating or Expanding a Selection
Learn how to create and expand selection.

Call

update://mmba/Selection/Create?Name=SelectionName&File=FileName&Mode=Mode
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Parameters

SelectionName : The name of the selection to be added or expanded for the current
user.

FileName : The name of the file containing the list of record IDs to be included in
the selection. This file must be stored in the current user's Aurea CRM directory.
The list of record IDs needs to be formatted as follows: Info area abbreviation;Record
ID; Record ID ;Info area abbreviation;Record ID;… If you enter the company or
person abbreviations, the target is a normal selection; otherwise the selection con-
tains properties.

Mode: There are two possible parameters:

• new: A new selection is created. If a selection with the same name already exists
for the current user, the existing selection is overwritten.

• update: An existing selection is expanded to include the transferred records.

Example

update://mmba/Selection/Create?Name=MySelection&File=data.txt&Mode=new

Chart Structures
Charts allow you to depict relationships between records.

The default configuration of Aurea CRM does not however support the display of
charts, which must instead be implemented using an add-on.

Aurea CRM win allows you to generate XML reports that can contain the following
data:

• A corporation’s structure

• All functions/positions of persons in a company, and all functions that are missing

• Information on properties, including sub-properties, opportunities and participants

The following steps are necessary in Aurea CRM win:

1. Define the chart format, see Defining a Chart Format on page 325. The chart format
determines the name of the chart, and the info area or record type from which
the report/chart can be generated.

2. Define the individual chart elements in the chart structure, see Defining Chart
Elements on page 326. The elements determine which records are searched for
and how they are included as elements in the report and their relationships with
one another.

3. Define an XML report based on the chart structure, see Defining Reports on page
328.

4. Create the XML report, see Creating Reports on page 328.
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The XML file can be used to display the chart (requires the programming of an add-
on).

The following examples cover the most important options when defining charts:

• Example: All Persons in a Company with Activities on page 330

• Example: All Persons in a Company with Department Heads on page 332

• Example: All Persons in a Company with Activities or Notes on page 335

• Example: Ticket Hierarchy on page 339

Defining a Chart Format
Learn how to define a chart format.

To define a chart format:

1. Open the Define chart level in the main module (select Info > Define chart from
the menu in the Aurea CRM win main module).

Note: The Define chart level is disabled by default in the CRM process
configuration and is only enabled for the SU. If other users should be able to
access this CRM process, you need to grant access to the "Define chart" CRM
process in the CRM Process configuration level in the Rights module, see CRM
Process Configuration in the CRM.core Administrator Guide.

2. The window containing all fields in the mask is also opened. Reposition the window
so you can enter information on the chart.

3. Enter the following:

• Title: The chart’s title (multi-language text field)

• Description: A description of the chart (multi-language text field)
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• Explanatory text (when missing data): This text is displayed if no data could
be determined to be used in the chart (multi-language text field)

• Info Area: The info area that the chart can be accessed from

• Condition: A condition that must by met by the record in order for the chart to
be accessed (optional parameter)

4. Click on  (Save) to save the format.

The name of the format is displayed in the Name field. Chart formats are saved
in the Format info area (Type: "Chart")

Defining Chart Elements
Chart elements determine which records are read from the database and which
record data is used by nodes in the XML output or chart.

To define the elements in a chart format:

1. Click on the Chart element entry and select New from the context menu.

A new chart element is added.

2. Click on the arrow icon in the Title field and enter a title.

This title is displayed in the hierarchical view of the chart element instead of the
automatically assigned ID (No. field).

3. Use the following fields to define how the root node of the chart should be
determined:

• Info Area: Specify the target info area to search for records.

• Element type:  Determine how records that are found are handled in the report:

- Generate new Elements:  A new element (node) is created for the record.

- Saves Records:  All records found are grouped in a single element.
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• Data Collection: Determine whether the data in the chart is determined using
transfer fields ("Read Engine") or a global query (Aurea CRM web only).

• Chart Format:  Double-click in this field and define the fields that should be
transferred to the report in a transfer fields format, or select the query.

For more details on transfer fields, see Transfer Fields in the User Manual.

4. Use the following fields to define how the root node’s children are determined:

• Chart Data (Children): Determine whether the data in the chart is determined
using transfer fields ("Read Engine") or a global query (Aurea CRM web only).

• Chart Format (Chart Format (Children)): Double-click in this field and define
the fields that should be transferred to the report in a transfer fields format, or
select the query.

5. You can add additional chart elements to the root node and other chart elements
(by selecting New from the context menu), allowing you to depict your structure.
There is no restriction on the number levels in the hierarchy.

For more information on the individual fields in chart elements, refer to the online
field help. You can:

• Define conditions that must be met by records

• Group nodes by catalog value
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• Recursively determine the records in the chart

• Link the report to workflows, triggers or Aurea CRM web wizards.

You can use drag & drop to move chart elements within the structure.

Note:  Select View > All Mask Fields to display the window containing all fields in
the mask.

While it is possible to include a variable condition in the chart's definition, the dialog
used to enter the variable value is not displayed when generating the report.

Defining Reports
Learn how to define reports.

To define a report containing a chart format:

1. Select Extras > Define Report Format from the menu.

2. Enter the chart type in the Select Chart field.

Note: The Select Chart field is used in chart reports instead of the Select
transfer fields option.

3. Save.

If you have enabled the Shorten tags and attributes option, the following chart-
specific node names are abbreviated as follows in the XML output:

• "nodes" > "nds"

• "node" > "nd"

• "level" > "lv"

• "groupBy" > "grBy"

For a description of this option and other options used to define reports,
see Defining Report Formats in the User Manual.

Creating Reports
The info area and condition defined in a chart format determine the type of record
from which the report can be created.

To create a report containing a chart format:

1. Switch to the desired record.

2. Select File > Reportfrom the menu.

3. Select the desired report format and confirm with OK.
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The XML report is displayed.

All texts defined in multiple languages are displayed in the current language.

The following XML elements are used in chart reports:

• <diagram>: Root node, contains all data

• <nodes>: Contains the data structure

• <definition>: Contains the chart’s definition
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Example: All Persons in a Company with Activities
The following report can be generated from a company and displays all persons in
the company and their activities.

Chart element for persons, that generates nodes for all persons in the company:

The chart element for persons uses two transfer fields formats that define the
structure of the data transferred to the chart:

Use the Fields tab to determine the fields to be transferred for persons.
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Use the Fields tab to determine the fields to be transferred for activities.

Chart elements for activities that generates nodes for all activities for a person:

The XML report contains all persons in the company and all their activities:
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Example: All Persons in a Company with Department
Heads
The reports in this topic can be generated from a company and displays all persons
in the company.

Persons whose position is "Department head" are additionally displayed in a separate
node. The Transparent element option is used to transfer data within the structure.
Persons are additionally grouped according to the entry in the "Department" field.

Chart element for the company nodes:
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Transfer fields format for companies and persons:

Use the Fields tab to determine the fields to be transferred for companies and
persons.

Definition of the person node used for department heads: all employees (including
the department head) are transferred to the next level (using the Transparent  ele-
ment option):
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Condition for the department head: nodes are generated on this level for department
heads:

Definition of the person node for employees in the departments: employees are
grouped by department on this level (Group by Field option):
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XML report: a department head is found and is displayed at the star t. All employees
are then grouped by department below the department head:

Example: All Persons in a Company with Activities or
Notes
The report in this topic can be generated from companies and contains all persons
and their activities.

If no activities are present for a person, notes are displayed instead (Optional set-
ting).
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Transfer fields format for companies and persons:

Use the Fields tab to determine the fields to be transferred for persons.

Transfer fields format for persons and activities:
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Use the Fields tab to determine the fields to be transferred for activities.

Chart element for activities:

Optional chart element for notes: if the parent node cannot be added (i.e. there are
no activities), nodes are created for all notes instead:

Transfer fields format for notes:
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Use the Fields tab to determine the fields to be transferred for notes.

The XML report contains all persons in the company and their activities:

If no activities are present for a person, the notes are displayed:
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Example: Ticket Hierarchy
The report in this topic can be generated from a ticket and displays all tickets linked
to the current ticket in the ticket hierarchy.

In the first step, the system searches recursively for the root ticket (Recursive op-
tion). In the second step, nodes are generated for all the root ticket’s child tickets
(Clone option). Relationships between tickets are established using indices.

Chart elements used to search recursively for the top-most ticket in the ticket hier-
archy (Recursive option):
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Transfer fields format for the root ticket: search upwards in the hierarchy using index
1:
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Use the Fields tab to determine the fields to be transferred for the top-most ticket.

Chart elements for child tickets: search recursively for all child tickets. A node is
added for each ticket that is found (Clone option):

Transfer fields format for the child tickets: search using index 2:
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Use the Fields tab to determine the fields to be transferred for the child tickets.

The XML report contains the entire ticket hierarchy:
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6
Aurea CRM Commands and Parameters
Here is the list of Aurea CRM commands and parameters.

For information on the usage of command line parameters, see Aurea CRM Param-
eters in the CRM.core  Administrator Guide.

mman.exe Parameters

-a

Executes the specified analysis:
mman.exe -u <User> -p <Password> -a "Revenue 2009"

-f

Loads the specified analysis format:
mman.exe -u <User> -p <Password> -f "Revenue 2009"

-s

Use this parameter to execute multiple analyses sequentially:
mman.exe -u <User> -p <Password> -s c:\windows\script.txt

Contents of the text file (ASCII, Unicode, UTF8):
-a "Revenue 2005"
-a "Revenue 2006"
-a "Revenue 2007"
-a "Revenue 2008"

mmco.exe Parameters
-k

Starts the input or output of a communication file, see Communication Steps on
page 120.
mmco.exe -u com -p <Password> -k I,101,102,l -k o,101,102

The following options are available:

• i: Input communication file

• o: Output communication file

• 101,102 etc.: Numbers of the stations to communicate with. If no station numbers
are specified, communication takes place for all stations for which a communication
connection exists, see Defining Communication Connections.

You can also enter number ranges: mmco.exe -u com -p <Password> -k o ,10
-1000 outputs communication files for stations 10 to 1000.

• l: Use this option to delete records marked as deleted automatically, without
requiring the deletion to be confirmed manually, see Communicating Deleted
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Records on page 137. The number of days entered in the Delete Cycle in Days
field in the Station info area is taken into account when deleting records.
mmco.exe -u com -p <Password> -k i,l

• u: Output a data stock download, see Data Stock Download on page 117.

mmco.exe -u com -p <Password> -k o,101,u

Outputs a data stock download (-k o ,u) for station 101.

Use info area codes to output a data stock download for specific info areas, e.g.
u :FI:KP:MA, see Partial Data Stock Download.

• +: Inputs a data stock download.

mmco.exe -u com -p <Password> -k i,1,+

Inputs the data stock download (-k i ,+) generated on the main office (1).

• r: Use this option to create a new data stock download for an existing station to
reset the station, see Outputting a new Data Stock Download for an Existing
Station.
mmco.exe -u com -p <Password> -k o,101,r

Outputs a new data stock download for station 101.

• w: Use this option to output all catalog values. By default, only catalog values that
have changed are output.
mmco.exe -u com -p <Password> -k o,101,w

Catalogs are output for station 101 (o ,101). All catalog values are output (w).

• n: Use this option to prevent catalog values that are added on a branch office
from being input on the catalog maintenance station.
mmco.exe -u com -p <Password> -k i,101,n

Data is input from station 101 (i ,101). No catalog changes are input (n), i.e.
catalog values added or edited on the branch office. Exception: If a new or edited
catalog value is used in a record on the branch office and this record is also
communicated. In this case, the catalog value is input.

• m: Use this option to execute an automatic communication process using a
communication connection with the Execution set to "manual", see Defining
Communication Connections.
mmco.exe -u com -k ein,101,m

Data is input from station 101 (i ,101). The communication connection defined
as "manual" is used (m). Change control and manual match-up options are ignored.
Combine this parameter with the parameter k to determine that the change control
and manual match-up dialogs should be displayed.

• k: Use this option to execute automatic communication with manual control.

mmco.exe -u com -k ein,101,m,k

Data is input from station 101 (i ,101). The communication connection defined
as "manual" is used (m). Messages are output, changes can be verified manually
and records can be matched up manually (k), see Communication with Change
Control and Communication with Manual Match-up.
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• q: Use this option to suppress the license registration request. Use this option if
you use the SU user for automatic communication. Otherwise the communication
process is aborted.
mmco.exe -u com -p <Password> -k i,101,n

• z: By default, the delta is determined (time stamp comparison) by writing all data
to a temporary file, which prevents fur ther access to the database. However, this
requires free disk space equivalent to the size of the database.

Use this option to minimize the memory required by the communication process:
the delta is determined by querying the database and written directly to the
communication file. When using the z parameter, the disk space requirements
are lower, however this can negatively impact on the performance of the commu-
nication process.
mmco.exe -u com -p <Password> -k o,1,z

A branch office outputs data for the main office (o ,1). The memory used by the
communication process is minimized (z).

• WriteRecTmp: By default, records are output in a compressed format. Use this
option to output records in an uncompressed format.
mmco.exe -u com -p <Password> -k o,101,WriteRecTmp

• D3DontCheck: Use this option to prevent the system from checking whether records
entered in link fields are also output when outputting D3 links:
mmco.exe -u com -p <Password> -k o,101,D3DontCheck

• b: This option (benchmark) is only for test purposes.

-c

Starts an external application after the communication process:
mmco.exe -u com -p <Password> -k i,l -k o -c x:\move_com_files.bat

Use the –c parameter a second time to specify a working directory for the application.

--oe

Use this parameter to suppress communication via e-mail, >> Communicating via
E-mail on page 77. The input or output is star ted without the Mapi.dll file. This pa-
rameter takes precedence over the settings in the Communication info area.

For example, mmco.exe -u com -u com -p <Password> -k o,101,u --oe creates a
data stock download for station 101. Communication does not take place via e-mail,
irrespective of the settings entered in the communication connection.

-s

Use this parameter to execute multiple communication processes sequentially:
mmco.exe -u <User> -p <Password> -s c:\windows\script.txt

Contents of the text file (ASCII, Unicode, UTF8):
-k o,101,u
-k o,102,u
-k o,200,u

In this example, data stock downloads are created for multiple stations.

--DmMerge
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Use this parameter to suppress the confirmation prompt when merging data models.
The data models are merged, see Merging Data Models in the CRM.core Adminis-
trator Guide.

mmim.exe Parameters

Importing or exporting data using the command line requires:

• An import or export format, see Defining an Import/Export format on page 19.

• The external file containing the import data (at the location specified in the format),
see Import File/Import Database.

Check the log files immediately after each automatic import. The log files are over-
written by the next import.
-e

Starts the Export module. If this parameter is not used, the Import module is
star ted.
-f

Specifies the import or export format:
mmim.exe -u <User> -p <Password> -f "Import Companies"
mmim.exe -e -u <User> -p <Password> -f "Export FI/KP"

-d

Path and name of the import or export file. Used instead of the file entered in the
format.
mmim.exe -u <User> -p <Password> -f "Import Companies" -d
"c:\MyDocuments\companies_csv"

Note:  Allowed max. length of path and name: 259 characters. If the string passed
with -d exceeds this limit, mmim.exe is not star ted and a message is written to the
log file.

-c

This parameter applies to export only. If the target export file exists, the file is not
overwritten, but a new file is created. The files are numbered sequentially (*.0, *.1
etc.).

You can speed up the export process by selecting the Upd field in the Sort By field
and star ting the export with -c.

mmim.exe -e -u <User> -p <Password> -f "Export Companies" -c

-n YYYYMMDD

This parameter applies to export only. Records are only exported if they are entered
on or after the specified date.
mmim.exe -e -u <User> -p <Password> -f "Export Companies" -c -n 20090815

-k

This parameter applies to import only. The import is executed using manual control,
see Executing the Import on page 79.
mmim.exe -u <user> -p <Password> -f "Import Companies" -d c:\companies_csv -k
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Note: The parameters -d, -k, -n and -c apply to the previous format specified with
–f:
mmim.exe -e -u <User> -p <Password> -f "Export Companies" -n 20090815 \
-d c:\fi0815.csv -f "Export Activities" -n 20090901 -d c:\ma0901_csv

--lkz

This parameter applies to export only. Records marked as deleted are also exported
(DelCd field enabled).
mmim.exe -e -u <User> -p <Password> -f "Export Companies" --lkz

-s

Use this parameter to execute multiple imports or exports sequentially:
mmim.exe -u <User> -p <Password> -s c:\windows\script.txt

Contents of the text file (ASCII, Unicode, UTF8):
-f IMP_FIKP
-f IMP_AK
-f "Import Activities"

If an error occurs during batch import, mmim.exe returns the following error codes:

Format not found525

Format could not be loaded / format de-
fect

526

No access to source file502

No connection to source table or field(s)
in the source table wrong

504

SQL error510

--abortOnError

To cancel a batch import as soon as one of the imported files causes an error, use
-- abortOnError together with -s.
--sqlwhere

Use this parameter to restrict the imported data using an SQL WHERE clause (in
double quotes). This parameter can be used in conjunction with the following param-
eters:

• -f

• -s

If the Import table option is not enabled for the format specified the parameter is
ignored and a message is written to the log file.

When using -- sqlwhere together with packet size, you need to specify the packet
size in the command line as well.
mmim.exe -u <User> -p <Password> -f "Import Companies" --sqlwhere "WHERE PLZ=1040
/*packetSize=1000*/"
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--transactional

Use this parameter to use transactions: Each row is imported within a database
transaction. If one of the records in a row contains incorrect data, the entire row is
rolled back, e.g. if the import of an offer for a company fails, the related company
is not imported as well.

If user input is required during the import of a record, the transaction is aborted.

Note: When importing with transactions the Package processing option is not
supported, see Info area properties on page 47.
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